Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. sportex's Avatar
    Member

    Posts
    121 Posts
       #1  
    Got home 1.30am from work this morning, had a bit play on my 8x, watched TV for a bit, then when I went to bed I put mobile on charge and noticed that the red charging light didn't go on and the chime never sounded . I pressed the standby button hoping to boot the phone up but nothing happened . Repeated this a few times, still wouldn't start up. Left phone on charge anyway. Woke up this moŕrning checked 8x and it was still dead. Tried a few times to start it up with no luck. Decided to post this thread on phone central with my desire hd.and as I started typing the 8x made a noise and the red light started flashing. A large flat battery icon appeared on the screen showing it starting to charge. Then the phone boots up, start screen appears and it startsto charge.. checked the phone and all seems ok. Left it on to charge. It has the new update installed and I thought this might have something to do with thus problem as it hasn't happened before.
    Last edited by sportex; 12-13-2012 at 04:47 AM.
  2. SteelSteve's Avatar
    Member

    Posts
    188 Posts
    #2  
    I've had similar issues in the past with my Lumia 710, and others have reported this problem with the 8X. Doing a hard reboot seems to resolve the issue for most. If you look through some of the other posts, someone posted how to do the hard reset on the 8X. Good Luck.
  3. sportex's Avatar
    Member

    Posts
    121 Posts
       #3  
    Thanks , I came across a similar post after I had posted mine. Should have done a search beforehand.
  4. #4  
    Did you get it working again?
  5. sportex's Avatar
    Member

    Posts
    121 Posts
       #5  
    Quote Originally Posted by Coolknight1968 View Post
    Did you get it working again?
    yep, booted up 5 hours later. No problems since
    Still a great phone

Similar Threads

  1. Replies: 15
    Last Post: 12-04-2012, 03:28 AM
  2. Zune is Dead PLEASE NO!!!!
    By gibbyhome in forum Upcoming & Rumored Devices
    Replies: 7
    Last Post: 06-27-2011, 12:20 AM
  3. Stuck (not dead) pixels
    By Luisraul924 in forum HTC HD 7 / 7s
    Replies: 4
    Last Post: 02-19-2011, 12:52 AM

Posting Permissions