Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 12 of 12
Like Tree1Likes
  • 1 Post By sschevy010
  1. sschevy010's Avatar
    Member

    Posts
    13 Posts
       #1  
    I recently purchased this AT&T HTC 8X as Unlocked. Got onto Straight talk and at start I was unable to do Data and MMS. After configuring APNs on Internet and MMS, I am able to have Web and able to send MMS but unable to receive MMS. It just keeps saying Get media content (32KB) and when getting it, just repeats after 5-10 seconds.

    My settings I have are....

    Internet APN-
    APN- tfdata
    Username- Blank
    Password- Blank
    Proxy Server- Blank
    Proxy Port- Blank
    IP Type- IPv4v6

    MMS APN-
    APN- tfdata
    Username- Blank
    Password- Blank
    WAP Gateway (Url)- 66.209.11.33
    WAP Gateway Port- 80
    MMSC (Url)- http://mms-tf.net/
    MMSC Port- 80
    Maximum MMS Size- Blank
    IP Type- IPv4v6

    Are any of these incorrect? I noticed on straight talk site it has MMS Proxy, But i do not see that option and at same time I have spoken with Straight talk support and they have escalated this to higher up group. Was not sure if anyone has answers to this or not..

    What Sim card am i Using? Using the Straight talk sim for AT&T

    HTC Support team were helpless on this situation as well...

    Any help would be great and thank you in advance!
  2. stmav's Avatar
    Retired Moderator

    Posts
    3,685 Posts
    Global Posts
    3,767 Global Posts
    #2  
    The only setting info I found on Straight Talks site was for locked phones. And it was different from what you have.
  3. sschevy010's Avatar
    Member

    Posts
    13 Posts
       #3  
    Quote Originally Posted by stmav View Post
    The only setting info I found on Straight Talks site was for locked phones. And it was different from what you have.
    If you're showing different settings on their site than what I have, can you please post it? cause this is what I see on their site...

    FIELD SETTINGS
    NAME straight talk
    APN tfdata
    PORT 80
    MMSC http://mms-tf.net
    MMS PROXY mms3.tracfone.com
    MMS PORT 80
  4. sschevy010's Avatar
    Member

    Posts
    13 Posts
       #4  
    Does anyone use Straight talk on this phone?
  5. sschevy010's Avatar
    Member

    Posts
    13 Posts
       #5  
    almost 400 views, just curious... I am sure you guys do have straight talk, but are you having same issues or not? or is it just my SIM card causing this problem as straight talk techie says? lol.... may as well talk to myself..
  6. sschevy010's Avatar
    Member

    Posts
    13 Posts
       #6  
    Well, the issue has been resolved.. Turns out that it was on the Carrier end after I was able to reach higher management team by phone. It was some MMS settings they set on their end to make the MMS to work right on this windows Phone.. So therefore if you are having same issues, more than likely it is on them no matter how much they say its the phone limitations.. it really isn't.. if it worked for me on this HTC 8X windows phone, it will work for you too.

    Settings on APN are same except the WAP Gateway been changed back to mms3.tracfone.com

    Enjoy!
    Thanked by:
    jrdatrackstar1223 likes this.
  7. kwambe5's Avatar
    Member

    Posts
    35 Posts
    #7  
    I cannot even get my data to work! I am using a Nokia Lumia 920 (ATT) on ST. I used the same settings that you used and still get nothing. I have just re-upped my month so am wondering if that might have something to do with it. I don't know. I have not called them yet.
  8. sschevy010's Avatar
    Member

    Posts
    13 Posts
       #8  
    Using tfdata apn settings does not work?

    Have you tried the att.mvno apn settings?

    Internet APN Setting
    APN- att.mvno

    MMS APN Setting
    APN- att.mvno
    WAP (Url)- 66.209.11.33
    WAP Port- 80
    MMSC- http://mmsc.cingular.com
    MMSC Port- 80

    That was the old settings which may or may not work..
    Thanked by:
  9. jrdatrackstar1223's Avatar
    Member

    Posts
    684 Posts
    Global Posts
    996 Global Posts
    #9  
    I'm having the same issue with my 920, and I knew it had to be ST because I could send MMS just fine (thus, I knew I had the right settings). So far, I've only gotten the low-level idiots that keep trying to tell me that my phone settings are wrong. I guess I'll have to be persistent and try to get upper management so they can reset it. Everytime I 've had them try to reset it, they try to claim that "everything looks ok their end", and that it must be something wrong with my phone...

    I'm just ready to switch to the ATT LTE $60 GoPhone plans, especially since you get LTE with it and don't have to worry about APN and MMS settings. Plus, backup and restore will actually work, because WP8 doesn't let you manually choose an internet source....
  10. kwambe5's Avatar
    Member

    Posts
    35 Posts
    #10  
    Quote Originally Posted by sschevy010 View Post
    Using tfdata apn settings does not work?

    Have you tried the att.mvno apn settings?

    Internet APN Setting
    APN- att.mvno

    MMS APN Setting
    APN- att.mvno
    WAP (Url)- 66.209.11.33
    WAP Port- 80
    MMSC- http://mmsc.cingular.com
    MMSC Port- 80

    That was the old settings which may or may not work..
    Yes! That worked! I called and called but they kept insisting that I was a high data user and transferring me over to their automated TOS hotline. This even though I had just refilled my service which according to them is supposed to reset the data counter. I was about ready to go to ATT contract because I could not find how to get this goPhone thing going. If some one could point me in the right direction that would greatly appreciated! :)
  11. Reggae02's Avatar
    Member

    Posts
    1 Posts
    #11  
    I was able to receive text messages, but I could not send them out, and I changed the SMS on my Nokia 900. I went into my messages and selected settings and way at the bottom of the screen; ti reads SMS center number and I entered +13123139810 and then powered my phone off and then back on. I now am able to send and receive text messages. Although I am still trying to figure out my internet connection.

    I contacted Straight Talk last night and they indicated that I needed another phone for them to assist me with this issue. I guess I needed to figure out the setting with them on the line and we might get disconnected. I don't have another phone, so waiting for a friend to come by after work and lend me her phone to get the internet issue resolved now. I guess, unless I can figure this out as well today.


    Hope this helps you.
  12. tara2u's Avatar
    Member

    Posts
    1 Posts
    #12  
    I could kiss you. That damn + sign was missing in my SMS center number. I honestly rolled my eyes but changed it anyway. And my texting works. I've been fighting with this for days trying a dozen or more different combinations for my APN settings and all this time I was just missing a + sign. Thank you, Thank you, Thank you. Still can't receive MMS messages, but at least my SMS is back.

Similar Threads

  1. Does anyone have Straight Talk MMS working?
    By bradbamford in forum Nokia Lumia 620
    Replies: 8
    Last Post: 01-15-2014, 12:41 AM
  2. Samsung Focus used for Straight Talk MMS help needed!!!
    By Jesika2289 in forum Windows Phone 7
    Replies: 27
    Last Post: 09-20-2013, 09:01 AM
  3. Straight Talk MMS (T-Mobile Sim)
    By ariesking79 in forum Windows Phone 8
    Replies: 10
    Last Post: 07-31-2013, 09:06 PM
  4. Samsung Focus S - Straight Talk - MMS
    By iz0d in forum Windows Phone 7
    Replies: 18
    Last Post: 07-30-2013, 11:39 PM
  5. Straight Talk MMS not working...
    By xdaynax77 in forum Nokia Lumia 900
    Replies: 3
    Last Post: 12-13-2012, 06:21 PM

Posting Permissions