Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. Redbird1's Avatar
    Member

    Posts
    10 Posts
    Global Posts
    351 Global Posts
       #1  
    Hey all,

    I was wondering if anyone has had the following issue. I'm not too familiar with T-Mobile yet, and how it's service behaves.

    The HD7 has been great, but today it was hard getting search results, using bing or google. The pages wouldn't even partially load after entering a search parameter. Other times I got a message like "cellular data connection unavailable at this time" or "Bing Search Results Unavailable at this Time"

    The strange thing was, that certain bookmarks, like the college football scores on Yahoo Sports, worked pretty well.

    In addition, I was trying to do most searches on a Saturday afternoon.

    Is this more of a T-Mobile issue? or a Phone issue? Any thoughts? Thanks.
  2. hatsoffexpress's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    37 Global Posts
    #2  
    Try powering the device down, and restarting it. It seems as if there is a small bug which makes the phone think there is no signal when there really is, especially if you tried using data in a low signal area. Worth a try though.

    Oh...and Let's Go Pens! ;)
  3. ChevyMSU35's Avatar
    Member

    Posts
    11 Posts
    #3  
    I haven't noticed this problem myself.

    Go Wings!
  4. nrfitchett4's Avatar
    Member

    Posts
    128 Posts
    Global Posts
    165 Global Posts
    #4  
    overall, I'm not impressed with the reception on this phone, seems at least 25% worse than my hd2 for signal. I'm hoping a radio update will come soon and improve it.
  5. Redbird1's Avatar
    Member

    Posts
    10 Posts
    Global Posts
    351 Global Posts
       #5  
    Overall, I've been happy with the connection. When it's working, it's screaming fast.

    When I was at the mall on Saturday, I wasn't getting a connection, and was getting really annoyed. However, it's to be expected. No carrier is perfect. Even when I was on Verizon, home of the "best network", I would lose my data connection from time to time.

    I will try powering down from time to time.

    Voice service has been flawless so far.

    P.S. maybe we should turn this into a hockey thread!
  6. Daniel Rubino's Avatar
    Editor-in-chief

    Posts
    490 Posts
    Global Posts
    532 Global Posts
    #6  
    Quote Originally Posted by nrfitchett4 View Post
    overall, I'm not impressed with the reception on this phone, seems at least 25% worse than my hd2 for signal. I'm hoping a radio update will come soon and improve it.
    Agreed--my data performance is not as smooth, even sometimes on Wifi, compared to the Focus.
    Daniel Rubino
    Editor in chief - Windows Phone Central
    Email: daniel@wpcentral.com
    Twitter: @Daniel_Rubino
    Socl: Daniel Rubino
  7. Guy_serious's Avatar
    Member

    Posts
    29 Posts
    Global Posts
    43 Global Posts
    #7  
    Haven't noticed anything myself, except for a bit of lag when I'm using YouTube over 3g. i think that has more to do with mobile than anything.

    Early adopters usually get all the bugs and device issues anyway so I was prepared for this.

Posting Permissions