1. Miistercoool's Avatar
    i get this message when trying to allow push notifications for my a game called "Spell it" (kinda like a scrabble game) ok well this is the message i get:

    "Cannot initialize a Push Notification channel, you will not receive notifications for this application."

    now why the heck am i getting this message?? anybody else having the same or a similar problem? please help. and by the way i have the htc HD7 for t-mobile.
    06-15-2011 07:52 AM
  2. Miistercoool's Avatar
    i get this message when trying to allow push notifications for my a game called "Spell it" (kinda like a scrabble game) ok well this is the message i get:

    "Cannot initialize a Push Notification channel, you will not receive notifications for this application."

    now why the heck am i getting this message?? anybody else having the same or a similar problem? please help. and by the way i have the htc HD7 for t-mobile.

    by the way i also posted this in the general discussion...i just thought it would be a good idea to post it here as well since it could possibly be a problem with the HD7..
    06-15-2011 08:02 AM
  3. 1jaxstate1's Avatar
    Yep. I don't get any push notifications anymore. ZERO! It has something to do with endpoints not being handled correctly and what not. I'll find the to the thread where "jim" is explaining it. It sucks a big one.
    06-15-2011 08:14 AM
  4. Miistercoool's Avatar
    what sucks is i have a friend and she also has the HD7 and her notifications work fine and my brother has the Samsung Focus and he doesn't have any problems either and that's so annoying!
    06-15-2011 08:17 AM
  5. 1jaxstate1's Avatar
    Here is the link to thread on what may be causing your problems.
    http://forums.windowscentral.com/win...ion/178710.htm It's a lot. But I'm sure you're having the same issues he's describing.
    Miistercoool likes this.
    06-15-2011 08:19 AM
  6. VelJharig's Avatar
    Yup... same problem here. I started having problems after the pre-NoDo update, when I had to remove a bunch of applications to get the update to run on my Focus, and then reinstalled them afterwards (as per an MS knowledgebase article). At the moment, I can't get new apps to open a channel, despite being well within the 15 push apps limit.

    There is a good explanation for it, which is a registry issue with certain apps incorrectly adding multiple push entries, but MS doesn't have a fix other than a hard reset right now (which is somewhat unreasonable, as the problem will eventually occur again if you use the same set of un-identified problem apps). I think they need a auto-expire mechanism for push registrations, or something similar.

    http://mobilitydigest.com/the-live-t...ze+Mobility%29
    06-15-2011 08:26 AM
  7. Dave Blake's Avatar
    Threads merged
    06-15-2011 08:34 AM
  8. jimski's Avatar
    what sucks is i have a friend and she also has the HD7 and her notifications work fine and my brother has the Samsung Focus and he doesn't have any problems either and that's so annoying!
    What's happened is your phone has accumulated enough left over registry keys to clog things up, regardless of how many push/live tile apps you currently use. Rest assured that your friend and brothers phones will eventually do the same thing, assuming they have a few push/live tile apps installed and occasionally soft reset (or power off), which btw wreaks havoc with your registry keys. If you are dev unlocked I can walk you through a fix. Otherwise a hard reset is the only solution for now. Mango is hopefully going to make this issue a bad memory, but still don't understand why MS couldn't push out a patch for this beforehand. It is very frustrating, especially for developers who can't do anything to correct the issue.

    Sent from my HTC Surround using Board Express
    06-15-2011 12:00 PM
  9. Dagolara's Avatar
    I'd suggest just biting the bullet and doing a reset to get your tiles back. I did my first over the weekend to get my tiles working again and it wasn't a huge hassle as I thought it would be. All told it probably took 15 min to get accounts setup again and another 1hr or so re-installing programs. I'd suggest just making a list of games/apps before doing anything and be warned you will lose access to some apps totally that have been pulled from the marketplace (groveshark, imagewind, unlimited tagging free shazam to name a few). Also try to only re-install live tile apps that you must have so you can prolong having to deal with again. Like jimski said hopefully Mango will rectify this issue completely.
    06-15-2011 02:02 PM
LINK TO POST COPIED TO CLIPBOARD