1. pippyo03's Avatar
    I have a weirdcharging problem with my Lumia 950. Lets say I have 30%. I will put the phoneon the charger and it will begin to charge normally. Then about 2 minutes laterI will check the phone and it will be at 100%! Now this would be awesome if itwasnt a lie. Whenever it jumps to 100% the phone will stop charging thebattery because it "thinks" its at 100%. But then I take the phoneoff the charger and the percentage will drop to 35%.

    So basically thephone will charge for a short time (around two minutes) and the will jump to afalse 100% and then stop charging. This is a really frustrating problem becauseI have to constantly unplug and plug in again to get it to a full charge. And sincethis problem has started I've started to receive horrible battery life.

    Has anyone elseexperienced this issue and does anybody have a suggestion about how it can befixed?
    01-05-2016 05:44 PM
  2. ashram's Avatar
    what charger are you using?
    01-05-2016 06:01 PM
  3. dashrendar's Avatar
    Does this issue always happen? Or is it frequent or intermittent?

    Does it still happen after restarting the phone?

    Have you tried performing a full discharge and then full charge cycle?
    01-05-2016 06:07 PM
  4. pippyo03's Avatar
    I'm using the usb type c charger that was provided with the phone. This issue happens every time I plug the phone. I've restarted the phone multiple times but restarting does not help. I am trying a full discharge and charging it now. Ill keep you updated on the results
    01-05-2016 07:02 PM
  5. Alexander Long's Avatar
    As I mentioned from another thread, calibrate your battery by charge from 0% to 10% without using the phone, which would definitely help with battery issue and battery life too. But a do believe it also firmware /os issue there too.
    01-06-2016 12:37 AM
  6. Jcmg62's Avatar
    I think there's definitely an issue with battery performance on the 950. I use my phone extensively for work (5-6 hours of call time, messaging and general web browsing) and have to charge it up at least 3 times a day.

    It drops from 70% to 30% with just twenty minutes of web browsing. That ain't right.

    I've had to go out and buy a 5000ma battery pack to keep with me when travelling. It's the complete opposite of my Lumia 1520, which would take a daily hammering and still have 20-25% power left for a bit of music playing and gaming on the train home.

    I guess the only saving grace is that if it turns out to be a hardware issue the battery is easily replaced.

    I'm going to try a full battery discharge to see if it sorts the problem out.
    01-06-2016 01:05 AM
  7. dashrendar's Avatar
    I don't think it's a battery issue. I think it's a CPU governor issue. It feels like the phone goes into full performance mode when it's not at all needed, which drains the battery like crazy.

    Phone is not to supposed to heat up like you're playing a 3D intensive game when you are only browsing or talking on the phone, or even watching a video.

    I think the new firmware is supposed to address that.
    01-07-2016 08:36 AM
  8. pippyo03's Avatar
    Apparently the issue lies with continuum. I haven't had the issue for the past two days and my battery life was getting better. I hadn't plugged it into my continuum dock in about a week or so. I plugged it in last night to the dock and my 950 went back to having the same problem of jumping to 100%... That really discourages me from using the dock now if it going to contently mess up my battery.
    01-09-2016 09:20 AM
  9. Yogesh Deshpande's Avatar
    Did you manage to solve this? I am having the same problem with my phone. It does weird drops in battery percentage...I put it for charging us I the out of box charger after some time it shows 100% and when I remove the charger it shows a very low percentage like what it was before I put to charging or even lower... absolute random behavior.. The next day it may charge properly Again....totally frustrated with the phone...worst experience ever,..
    Kudu B likes this.
    02-18-2017 01:32 AM
  10. dov1978's Avatar
    I get this maybe once a week on my 950xl. It'll be at around 70/80% and I'll put it on charge and a few seconds later it'll be at 100%. So I pull the cable out and a few seconds later it'll be back to 80% or so. I find removing the battery for around 10 seconds, reinsert it then power up before putting back on charge fixes it.
    02-18-2017 02:23 AM
  11. Kudu B's Avatar
    I'm having very similar problems with my 950. when i put it on charge most of the time it will jump to 100% and when i take it off charge its back to 20% or so. have to hard reset it until it charges properly and even then might only have 50% max. i used the device recovery tool and am not using an insider build anymore as i found them too problematic. not sure if its the phone or i need to buy a new battery.
    02-18-2017 03:12 PM
  12. Kekewich's Avatar
    I've had the same problems for months, plugging the phone on charge and the meter goes straight to 100%, unplugging to find the meter drop. Random crashes as if the phone thinks the battery is flat. Has been driving me mad and making me very upset. Don't ask Microsoft for any help because they're useless!

    But I cured the problem last week. My phone now charges fine. I noticed that the battery was ever so slightly loose fitted, so I bent the three battery contacts closer together. Hey presto, instant fix
    03-11-2017 08:25 AM
  13. RealtorTechGuy's Avatar
    I think this might have actually solved my problem! Just bent the two outer contacts inwards a tiny bit, made the connection tight and phone seems to stay on even on battery. Thanks Kekewich
    Rubidad likes this.
    03-22-2017 08:25 PM

Similar Threads

  1. Replies: 2
    Last Post: 01-05-2016, 06:57 PM
  2. any bug with the new firmware??
    By aliencatos in forum Microsoft Lumia 950 XL
    Replies: 0
    Last Post: 01-05-2016, 05:40 PM
  3. Is there a fix for HTC M8 Windows overheating problems?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-05-2016, 04:55 PM
  4. Archos 50 Cesium with Windows 10 Mobile on sale in the UK and France
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-05-2016, 03:42 PM
  5. Family Safety workaront with power reset
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-05-2016, 11:35 AM
LINK TO POST COPIED TO CLIPBOARD