Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 47
Like Tree11Likes
  1. bellyer's Avatar
    Member

    Posts
    49 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    After having a fairly decent experience getting myself up and running on a 950 Dual SIM coming from a 920, I made the decision to upgrade my wife's dying 920 to a 950. She has had a few issues in the week that she has been using it, but we have worked through them all and gotten to a point where she is actually happy with the 950... until today that is. She is now facing an issue where it takes 4-5 presses of the power button to actually turn on the display and even after about that number of presses, the display does not turn on until maybe 10-20 seconds after she stops pressing the power button.

    Has anyone else seen an issue like this and, if so, do you know how to resolve it?

    Thanks in advance!
    TheChazas likes this.
  2. TheChazas's Avatar
    Member

    Posts
    393 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Yeah, indeed, that sometimes happen to me too, but very rarely, have to press few times to wake the phone.
    libra89 and BLKahuna like this.
  3. gordonfink's Avatar

    Posts
    1,402 Posts
    Global Posts
    1,417 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    I've noticed this on occasion. It seems to me that at times there is a lag, so you are really turning it on and off with multiple presses.
    libra89 and randyoaks187 like this.
  4. avi_920's Avatar
    Member

    Posts
    87 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    Happens 'occasionally' in my L 950 dual-sim variant too!
    zei20t likes this.
  5. msft-lumia-950's Avatar
    Member

    Posts
    5 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    Hi,
    I do have same sort of issue with Lumia 950
    When I press power button to unlock the phone the screen wont responds. The display remains off. After pressing the power button twice the phone becomes active for unlocking.

    This issue happens randomly. Like in a day I might encounter 5 to 10 times. And it depends on usage. Surely its not continuous ..

    Can anyone guide me in this regard. Its the defect with device ?

    Thanks in advance.
  6. msft-lumia-950's Avatar
    Member

    Posts
    5 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #6  
    I have done soft reset, hard reset and also complete reset using "Windows Device Recovery Tool"
    Updated to latest version which is "10.0.10586.164". Firmware updates are also update to date.\

    Still no luck. :-(
  7. YogeshChoure's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    Quote Originally Posted by msft-lumia-950 View Post
    Hi,
    I do have same sort of issue with Lumia 950
    When I press power button to unlock the phone the screen wont responds. The display remains off. After pressing the power button twice the phone becomes active for unlocking.

    This issue happens randomly. Like in a day I might encounter 5 to 10 times. And it depends on usage. Surely its not continuous ..

    Can anyone guide me in this regard. Its the defect with device ?

    Thanks in advance.
    .
    .
    I'm also facing same issue with my 950..
  8. YogeshChoure's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #8  
    Turn OFF the Glance screen..n It's working smoothly
  9. Kydix's Avatar
    Member

    Posts
    11 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    Same here but rarely !

    The screen is off but i see the IR led turn on. I wait few second, retry and the screen goes on
    libra89 likes this.
  10. Anks8000's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    I am also facing the same issue. On pressing the power button multiple times, the glance screen turns off and on. On performing a soft reset, the issue seems to be resolved, but then after some days, it starts doing the same thing. It is very random and not very frequent.
    I tried to switch off glance screen also, but that too doesn't help. Is this been reported in the feedback hub? Not sure if this is specific to 950.
  11. Christopher Lindsay's Avatar
    Member

    Posts
    893 Posts
    Global Posts
    915 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    I have the same issue but it only happens when the glance screen is off.
  12. Zulfigar's Avatar
    Member

    Posts
    1,633 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    Quote Originally Posted by Anks8000 View Post
    I am also facing the same issue. On pressing the power button multiple times, the glance screen turns off and on. On performing a soft reset, the issue seems to be resolved, but then after some days, it starts doing the same thing. It is very random and not very frequent.
    I tried to switch off glance screen also, but that too doesn't help. Is this been reported in the feedback hub? Not sure if this is specific to 950.
    I'm having the same issue, except on my 950 XL.
  13. Hamras Hamza's Avatar
    Member

    Posts
    15 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    +1
    Having same issue on 950xl .
    It seems like its a sort of lag.
  14. ashram's Avatar
    Member

    Posts
    1,225 Posts
    Global Posts
    1,233 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #14  
    Same issue, BUT i have Windows hello turned on, and when the screen doesn't show, the red LED still turns on, so I just position it to see my eyes and it unlocks and comes back up. The I just reset the phone and am good for a few weeks.
  15. sri kamal's Avatar
    Member

    Posts
    32 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #15  
    I have the exact same issue. It happens very frequently. I turned off the glance screen but no use tried hard and soft reset also. But firstly after seeing this post I am happy because its not specific to my hardware. So is that some thing like if we turn on glance screen it will not happen???
    libra89 likes this.
  16. Christopher Lindsay's Avatar
    Member

    Posts
    893 Posts
    Global Posts
    915 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #16  
    I'm going to return my 950 and see if a new one will have the same problem.
  17. ninwiito's Avatar
    Member

    Posts
    9 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #17  
    I am having the same issues that everybody else is having. I'm sorry but this phone is trash. I should have just stuck with my 920.
  18. RumoredNow's Avatar

    Posts
    16,586 Posts
    Global Posts
    20,235 Global Posts
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    #18  
    Anyone tried the old shim trick?

  19. cabbonizio's Avatar
    Member

    Posts
    31 Posts
    Global Posts
    87 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #19  
    I have this same issue although with another twist. When the screen finally comes back on after multiple presses of the power button, my screen seems to be very dim as if the brightness was turned low. I try to adjust the brightness after this and I can never get it back to the way it was. I have to restart the phone and all back to normal. The screen is so dim I can barely see anything very strange and I have not been able to find a pattern for this.
    I cannot explain how frustrating this is being in a situation where I have to dial into work conference, call my sons daycare, family and I literally can't get my screen to turn on. When it does, it's awfully dimmed. I am really looking forward to the firmware update for US ATT, which we're all still patiently waiting for but not sure if this will make a difference. I can't think of a worse bug I have had to deal with as long as I have owned a smartphone.
  20. B Hammer's Avatar
    Member

    Posts
    58 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #20  
    Same problem here. Tried all the same fixes as everyone else. Glance screen is off; disabled Windows Hello too. Nothing works.

    At least I'm not the only one.
  21. Zhenren Zhou's Avatar
    Member

    Posts
    35 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #21  
    I've had the problem as well, but it disappeared after the AU.
  22. Michael Bromley's Avatar
    Member

    Posts
    53 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #22  
    Originally posted by cabbonizio
    I have this same issue although with another twist. When the screen finally comes back on after multiple presses of the power button, my screen seems to be very dim as if the brightness was turned low. I try to adjust the brightness after this and I can never get it back to the way it was. I have to restart the phone and all back to normal. The screen is so dim I can barely see anything very strange and I have not been able to find a pattern for this.
    I cannot explain how frustrating this is being in a situation where I have to dial into work conference, call my sons daycare, family and I literally can't get my screen to turn on. When it does, it's awfully dimmed. I am really looking forward to the firmware update for US ATT, which we're all still patiently waiting for but not sure if this will make a difference. I can't think of a worse bug I have had to deal with as long as I have owned a smartphone.
    Happens to me but rarely, say 2-3 times over last 30 days. Screen comes back up fine after shut down /repower. Hopefully this behavior is flagged for a look by engineers, as well as the power button issue.
  23. cabbonizio's Avatar
    Member

    Posts
    31 Posts
    Global Posts
    87 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #23  
    Yeah in terms of frequency it doesn't happen that often, but always when I really really need the phone to work, not when I'm being lazy and browsing the web for killing time....LOL. Good to know we have a thread for this and hopefully it has visibility to get this resolved.
    Michael Bromley likes this.
  24. dfaris's Avatar
    Member

    Posts
    172 Posts
    Global Posts
    558 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #24  
    I noticed that after I use Groove for awhile is when I get the problem with the screen. If I do a restart and don't use groove I don't have a problem.
  25. sri kamal's Avatar
    Member

    Posts
    32 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #25  
    Added in feedback please up vote. Search with Lock button not working in feedback hub
Page 1 of 2 12 LastLast

Similar Threads

  1. Cortana on Band 2 cant reach your Phone
    By Bleak Morn in forum Microsoft Band 2
    Replies: 4
    Last Post: 04-01-2016, 08:59 AM
  2. Enter to win a Surface 3 tablet in our Windows Central Gems Day Six Sweepstakes!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 2
    Last Post: 03-05-2016, 08:27 AM
  3. Why does the camera view on Whatsapp appear as stretched?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-04-2016, 04:13 PM
  4. All bing related web pages time out in both edge and chrome
    By eastland12 in forum Ask a Question
    Replies: 0
    Last Post: 03-04-2016, 02:57 PM
  5. Is it worth updating L640 XL to windows 10?
    By Sumukh Phalle1992 in forum Microsoft Lumia 640 XL
    Replies: 0
    Last Post: 03-04-2016, 02:56 PM

Posting Permissions

";