1. Y2HBK's Avatar
    I'm constantly remoting into servers for my job. One of the biggest issues I have is remote desktop scaling. Everything is dreadfully small. If I set custom settings in RDC properties all it does is shrink the size of the full screen window - not change the scaling.

    I tried using remote desktop connection manager and adjusted the display resolution there - it does the exact same thing. I saw someone on TechNet suggested using the Windows Store remote desktop app as it handles this more appropriately. That is not an option because my company blocks access to it.

    Any ideas?
    01-13-2016 10:28 AM
  2. BLKahuna's Avatar
    Some are finding relief by using Remote Desktop Manager instead of Remote Desktop Connection. This can be found here:

    http://blogs.technet.com/b/rmilne/ar...dcman-2-7.aspx
    01-13-2016 12:06 PM
  3. orlbuckeye's Avatar
    I just change the resolution on the Surface book lower like 1920 x 1080.I use RDP with Juno Pulse to connect to my pc or servers. I change it back to 3000 x 2000 when I'm done.
    01-13-2016 02:32 PM
  4. Y2HBK's Avatar
    Some are finding relief by using Remote Desktop Manager instead of Remote Desktop Connection. This can be found here:

    Remote Desktop Connection Manager Download (RDCMan) 2.7 - 250 Hello - Site Home - TechNet Blogs
    I specified in my original post that I already tried this?

    I just change the resolution on the Surface book lower like 1920 x 1080.I use RDP with Juno Pulse to connect to my pc or servers. I change it back to 3000 x 2000 when I'm done.
    Thats a terrible workaround and its a damn shame that you have to do it. I go back and forth between my local computer and the VM all day, so i wont be "done" until I am done with work for the day.

    No one else has a viable, permanent solution?
    01-14-2016 12:56 PM
  5. lewinr's Avatar
    I think this solution should work for you without changing the resolution of your SB desktop:

    1. Connect to the remote machine using Window's standard "Remote Desktop Connection" application but under Advanced -> Display tab choose a normal resolution like 1280x768.

    2. Once you connect, click on the little icon (a screen with a sync symbol) in the uppermost lefthand corner of the window, where you find the options for maximize, minimize, etc. You'll see an option "zoom". Choose 200% for example. You'll find the right setting depending on your resolution and the resolution of the remote system.
    01-16-2016 06:49 AM
  6. michal64's Avatar
    remote desktop connection manager works fine, i use it all the time, no need to change resolution.

    go to properties of the server you have there, Remote Desktop Settings > click the "Same as client area" option.
    01-19-2016 06:10 PM
  7. hhull's Avatar
    I was having the same issue and as a work around I found adjusting the display zoom addressed my issue. mstsc.jpg
    01-20-2016 09:28 PM
  8. jhoff80's Avatar
    Unfortunately, native scaling depends on the host PC. Scaling is only officially supported on Windows 8 / Windows Server 2012 and newer's version of Remote Desktop.
    01-20-2016 09:59 PM
  9. Y2HBK's Avatar
    remote desktop connection manager works fine, i use it all the time, no need to change resolution.

    go to properties of the server you have there, Remote Desktop Settings > click the "Same as client area" option.
    No, this does not work.

    I was having the same issue and as a work around I found adjusting the display zoom addressed my issue. Click image for larger version. 

Name:	mstsc.jpg 
Views:	10 
Size:	106.6 KB 
ID:	120838
    This is what I have had to resort to. The problem is that on server 2012, the zooming throws off where the desktop thinks the cursor is. I have found using the smart scaling option works best for that.

    Hopefully they fix these issues.
    01-22-2016 08:25 AM
  10. michal64's Avatar
    sorry, i didnt replay sooner, i use remote desktop manager, what i forgot to mention is you need to uncheck display scaling

    start > type remote desktop manager > right click, open file location, when you see the file, properties, Comparability tab, and uncheck Disable display scaling on high dpi settings
    BLKahuna likes this.
    02-01-2016 07:49 PM
  11. win2000b's Avatar
    You can workaround the issue using manifest files. It makes it not scale the app.

    Remote Desktop / RDP Scaling on a Surface Book
    BLKahuna likes this.
    04-18-2016 11:32 AM
  12. BLKahuna's Avatar
    The manifest solution above works perfectly.
    Last edited by BLKahuna; 05-15-2016 at 01:20 AM.
    05-14-2016 02:39 PM
  13. Alderran1's Avatar
    Sarcastically you know what's funny? The microsoft remote desktop client for the mac works perfectly. Absolutely no scaling issue at all everything looks great on a 13" macbook with a retina display. Good job Satya we know you like supporting other platforms better than your own.
    Y2HBK likes this.
    05-15-2016 06:07 AM
  14. dd1234567's Avatar
    Thank you Michael this worked once the properties were changed. Ive been on many forum and downloaded multiple suggestions but this is first to work.
    08-09-2016 09:28 PM
  15. orlbuckeye's Avatar
    The manifest solution worked for me also.
    08-10-2016 02:02 PM
  16. rdockrey's Avatar
    Just a heads up the manifest solution doesn't work with the Anniversary update.
    08-16-2016 11:12 AM
  17. Vorlox's Avatar
    I found Remote Desktop Manager 2.7 hit or miss using that option.

    What I did find is that Remote Desktop Manager 2.2 scales beautifully by default on my Srface Pro 4 and I have been using it for several months.

    I know this is an old thread, but wanted to post the solution that worked very well for me. It's an older remote desktop client, but I have had no issues with it. Worth a shot if you are fed up with the scaling issues.
    10-28-2016 07:24 AM
  18. anam hasan's Avatar
    Great!!!
    It works for me.
    Thanks
    11-17-2016 12:14 AM
  19. netwirejohn's Avatar
    I used the manifest solution and it fixed the screen scaling in RDP for me. I just got the Surface Book yesterday.
    11-29-2016 08:34 AM
  20. DeutydaBeast's Avatar
    Sarcastically you know what's funny? The microsoft remote desktop client for the mac works perfectly. Absolutely no scaling issue at all everything looks great on a 13" macbook with a retina display. Good job Satya we know you like supporting other platforms better than your own.
    This is probably due to retina display just being a nicer terminology for downscaling, or rendering at a higher resolution than the display actually pushes out, removing aliasing. The RDP session is probably just matching to your native display res and not using downscaling.
    04-24-2017 02:56 PM

Similar Threads

  1. **Apps that don't work well when installed to SD**
    By djeire84 in forum Update 2 for Windows Phone 8.1 (GDR2)
    Replies: 7
    Last Post: 03-25-2016, 05:47 PM
  2. Battery just went to hell? .63 update the culprit?
    By peashooter14 in forum Microsoft Lumia 950 XL
    Replies: 20
    Last Post: 01-15-2016, 05:43 AM
  3. How can I put Album Art on my songs on Windows phone 8.1?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-13-2016, 12:32 PM
  4. I have an allview impera i it runs on windows 8.1 how can I update to win. 10 ?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-13-2016, 11:29 AM
  5. Hey Cortana instead of double tap to wake
    By Ken Nye in forum Cortana
    Replies: 0
    Last Post: 01-13-2016, 10:06 AM
LINK TO POST COPIED TO CLIPBOARD