Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
Like Tree1Likes
  • 1 Post By kittengirl
  1. cameradork's Avatar
    Member

    Posts
    561 Posts
       #1  
    I'm mostly happy with the 128GB Surface Pro that I picked up yesterday. I thought it would be cool if I could draw a bit in Photoshop with the nifty new Wacom tech. Turns out, no. When I click anywhere in the Photoshop interface (both CS5 and CS6), it sort of click-locks, but not in a way that keeps drawing... it puts down one dot with the brush on the canvas, and then I can still hover and move the cursor around, but it doesn't draw. It also makes it so I can't click anything else. I figured out that to release it, I could click somewhere with another pointing device (trackpad on the typepad or a BT or USB mouse). It then finishes drawing all the lines I tried to make, but when I click again with the stylus, it starts the whole process over. Needless to say, this makes the stylus useless in Photoshop. The weird part is that it only exhibits strange behavior in Photoshop (both versions), but Illustrator, Lightroom and everything else is fine (no pressure sensitivity in those apps, but it works like a mouse).

    Anyone come across anything like this on their Surface Pro?
  2. cameradork's Avatar
    Member

    Posts
    561 Posts
       #2  
    I should also mention that I plugged an external Wacom Bamboo graphics tablet it, and it works fine in Photoshop (pressure sensitivity and everything). BT Mouse, USB Mouse and trackpad on the type pad all function properly in Photoshop 5.1 and 6. So weird!
  3. stephen_az's Avatar
    Member

    Posts
    978 Posts
    Global Posts
    1,012 Global Posts
    #3  
    It is not weird at all. Photoshop has not been updated to utilize the Windows 8 touch screen interface or the internal screen initiated digitizer. Until it is updated, it is still software optimized for Windows 7 which uses external graphics tablets. It is simply a demonstration that software designed for Windows 7 prior to the release of Windows 8 does not automatically become full blown Windows 8 software. It is compatible within the existing capabilities of Windows 7. Until Adobe updates to take advantage of the touch screen and digitizer, you will probably need to wait or find someone who has put together a third party plug in.
  4. cameradork's Avatar
    Member

    Posts
    561 Posts
       #4  
    Quote Originally Posted by stephen_az View Post
    It is not weird at all. Photoshop has not been updated to utilize the Windows 8 touch screen interface or the internal screen initiated digitizer. Until it is updated, it is still software optimized for Windows 7 which uses external graphics tablets. It is simply a demonstration that software designed for Windows 7 prior to the release of Windows 8 does not automatically become full blown Windows 8 software. It is compatible within the existing capabilities of Windows 7. Until Adobe updates to take advantage of the touch screen and digitizer, you will probably need to wait or find someone who has put together a third party plug in.
    The weird part is that I haven't been able to find anyone else with this specific problem. Everyone else is upset at the lack of pressure sensitivity, but they say the digitizer works like a normal mouse. For me, it works like a glitchy mouse with a stuck button, which renders it unusable. Only in Photoshop (CS5 and CS6), though - it works like a normal mouse in Illustrator and all other programs.
  5. kittengirl's Avatar
    Member

    Posts
    137 Posts
    #5  
    That is odd - drawing with a "pencil" or "brush" seems to work OK for me in CS6. There are other annoyances, but the tools seem to work fine (well, that's the few I've tested, anyway, one of which is drawing on a blank canvas.)
  6. cameradork's Avatar
    Member

    Posts
    561 Posts
       #6  
    Quote Originally Posted by kittengirl View Post
    That is odd - drawing with a "pencil" or "brush" seems to work OK for me in CS6. There are other annoyances, but the tools seem to work fine (well, that's the few I've tested, anyway, one of which is drawing on a blank canvas.)
    Yeah, that's what I thought... I'm going to try uninstalling and reinstalling
  7. cameradork's Avatar
    Member

    Posts
    561 Posts
       #7  
    Uninstalled all of Creative Cloud and CS5.5 from the Pro and downloaded the trial for Ps CS6 standalone. Same exact issue. Wonder if it's this specific unit :(
  8. pdch's Avatar
    Member

    Posts
    244 Posts
    Global Posts
    324 Global Posts
    #8  
    Quote Originally Posted by cameradork View Post
    The weird part is that I haven't been able to find anyone else with this specific problem. Everyone else is upset at the lack of pressure sensitivity, but they say the digitizer works like a normal mouse. For me, it works like a glitchy mouse with a stuck button, which renders it unusable. Only in Photoshop (CS5 and CS6), though - it works like a normal mouse in Illustrator and all other programs.
    I just tested on mine. Sensitivity works fine, just have to make sure you have the options enabled to use pen pressure for opacity and thickness turned on, otherwise it ignores it. I'm using Cs6. Make sure you have installed the touch extensions.
  9. cameradork's Avatar
    Member

    Posts
    561 Posts
       #9  
    Quote Originally Posted by pdch View Post
    I just tested on mine. Sensitivity works fine, just have to make sure you have the options enabled to use pen pressure for opacity and thickness turned on, otherwise it ignores it. I'm using Cs6. Make sure you have installed the touch extensions.
    Oh, interesting - going to try that now. I did a complete system restore, and now the pen works with Photoshop as expected. Must have been a bad image or driver conflict or who knows what :)
  10. cameradork's Avatar
    Member

    Posts
    561 Posts
       #10  
    Quote Originally Posted by pdch View Post
    I just tested on mine. Sensitivity works fine, just have to make sure you have the options enabled to use pen pressure for opacity and thickness turned on, otherwise it ignores it. I'm using Cs6. Make sure you have installed the touch extensions.
    I was able to find the option in the brushes panel for shape dynamics, and turned on "always use pen pressure for opacity" (doesn't seem to do anything on the Pro), but haven't found the one for thickness.

    *edit* - Found the Touch App Plugins on Creative Cloud - Installing now.
    Last edited by cameradork; 02-11-2013 at 12:59 AM.
  11. Daker3's Avatar
    Member

    Posts
    1 Posts
    #11  
    I was having the same issue and couldn't figure it out until now. You didn't have to do a system restore. I disable "Hold to Right Click" and had the issue. Once I reactivated it, it worked! Sans pen pressure of course.
  12. cameradork's Avatar
    Member

    Posts
    561 Posts
       #12  
    Quote Originally Posted by Daker3 View Post
    I was having the same issue and couldn't figure it out until now. You didn't have to do a system restore. I disable "Hold to Right Click" and had the issue. Once I reactivated it, it worked! Sans pen pressure of course.
    Interesting. I hadn't messed with any settings and was having that issue. Then I started trying different combinations with the pen and nothing seemed to fix it. After the restore (which I'm guessing put it back to default) it worked. The restore process was really painless - all my data on this computer is in Dropbox or Skydrive, so I just wiped it without worrying about losing anything and the whole process took maybe 30-40 minutes. If I'm feeling brave, I might try messing with the settings again to see if I can recreate that problem :)
  13. kittengirl's Avatar
    Member

    Posts
    137 Posts
    #13  
    Quote Originally Posted by pdch View Post
    I just tested on mine. Sensitivity works fine, just have to make sure you have the options enabled to use pen pressure for opacity and thickness turned on, otherwise it ignores it. I'm using Cs6. Make sure you have installed the touch extensions.
    I still can't get the sensitivity to work. Downloaded the touch plugin and everything. Maybe I'm missing a setting somewhere. I think there are enough of us who would love step by step instructions that maybe you should put together a tutorial or something!
    Thanked by:
    cameradork likes this.

Similar Threads

  1. Strange Problem with notification/status area of screen
    By RellD05 in forum Windows Phone 7
    Replies: 5
    Last Post: 03-20-2012, 08:28 PM
  2. Problem with lock
    By inster in forum Windows Phone 7
    Replies: 12
    Last Post: 01-02-2012, 09:51 AM
  3. Problems with Frequent Zune Lock Ups
    By rmmoore80 in forum Windows Phone 7
    Replies: 9
    Last Post: 11-04-2011, 11:52 AM
  4. Strange camera problem
    By davekr#WP in forum Samsung Focus
    Replies: 3
    Last Post: 04-19-2011, 03:52 PM
  5. Strange problem with network 'Title'?
    By netko drugi in forum Windows Phone 7
    Replies: 0
    Last Post: 03-31-2011, 03:30 AM

Posting Permissions