Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 29
  1. fonzman78's Avatar
    Member

    Posts
    38 Posts
    Global Posts
    53 Global Posts
       #1  
    Just downloaded a firmware update today. No problems installing the update but now my pen doesn't work. Anyone else having this problem?
  2. garyjk's Avatar
    Member

    Posts
    41 Posts
    #2  
    others have reported some issues. rebooting a number of times or shutting it down for a while and turning it back on might correct it.
    same with the surface pro system aggregate firmware showing a yellow bang in device manager. waiting a while after shutting down has corrected that issue, too.
    Thanked by:
    rdubmu 
  3. rmstern53's Avatar
    Member

    Posts
    35 Posts
    #3  
    Ditto!
  4. fonzman78's Avatar
    Member

    Posts
    38 Posts
    Global Posts
    53 Global Posts
       #4  
    Quote Originally Posted by garyjk View Post
    others have reported some issues. rebooting a number of times or shutting it down for a while and turning it back on might correct it.
    same with the surface pro system aggregate firmware showing a yellow bang in device manager. waiting a while after shutting down has corrected that issue, too.
    Yep, rebooting a couple times fixed the problem. Pen is functional again. Thanks.
    Thanked by:
    rdubmu 
  5. rmstern53's Avatar
    Member

    Posts
    35 Posts
    #5  
    Quote Originally Posted by fonzman78 View Post
    Yep, rebooting a couple times fixed the problem. Pen is functional again. Thanks.
    I turned mine off for 2 minutes and now it is fine, thanks for the tip!!
    Thanked by:
    rdubmu 
  6. StarLog's Avatar
    Member

    Posts
    73 Posts
    #6  
    Where did you find the update
  7. cameradork's Avatar
    Member

    Posts
    561 Posts
    #7  
    Mine did the same. Reboot fixed it. I also got the number pad back for putting in my PIN when the keyboard was disconnected - woo hoo!
  8. StarLog's Avatar
    Member

    Posts
    73 Posts
    #8  
    Where did you find the update
  9. cameradork's Avatar
    Member

    Posts
    561 Posts
    #9  
    Quote Originally Posted by StarLog View Post
    Where did you find the update
    Start>Settings>Change PC Settings>Windows Update
  10. VineRider's Avatar
    Member

    Posts
    126 Posts
    #10  
    Mine kept rebooting while trying to install the firmware update. Finally it did boot up, but checking via control panel for installed updates, it said the firmware update failed. I then checked for updates again, but it would not find the firmware update. In device manager, I had the same error on the aggregator. My solution was to do a system refresh, then check for updates. I deselected all but the system firmware, and it installed fine. Now in the process of installing all the other updates.

    Update - all other updates installed correctly. This solved my issue
    Last edited by VineRider; 03-12-2013 at 11:01 PM.
  11. cameradork's Avatar
    Member

    Posts
    561 Posts
    #11  
    Quote Originally Posted by VineRider View Post
    Mine kept rebooting while trying to install the firmware update. Finally it did boot up, but checking via control panel for installed updates, it said the firmware update failed. I then checked for updates again, but it would not find the firmware update. In device manager, I had the same error on the aggregator. My solution was to do a system refresh, then check for updates. I deselected all but the system firmware, and it installed fine. Now in the process of installing all the other updates.

    Update - all other updates installed correctly. This solved my issue
    wow, that sucks. Thanks for documenting the workaround, though, in case anyone runs into this in the future.
  12. trublsom's Avatar
    Member

    Posts
    1 Posts
    #12  
    I lost usage of my digitizer/pen after the latest update. I had to reboot a couple of times, The 3rd reboot I did, I did a cold boot (left off for over 10seconds from a shut down) then my pen started to work again.
  13. #13  
    I'm having the same problem. Updated "non critical" as well. Tried to go back to previous restore point. Nothing has worked yet.

    Update...
    Completely shut down for several minutes. Booted and now everything works fine. Not a very satisfying solution (still can't explain what happened), but this is what worked for me.
    Last edited by ONEJourneySteve; 03-15-2013 at 10:13 AM. Reason: Updated info...fixed
  14. cameradork's Avatar
    Member

    Posts
    561 Posts
    #14  
    Quote Originally Posted by ONEJourneySteve View Post
    I'm having the same problem. Updated "non critical" as well. Tried to go back to previous restore point. Nothing has worked yet.

    Update...
    Completely shut down for several minutes. Booted and now everything works fine. Not a very satisfying solution (still can't explain what happened), but this is what worked for me.
    The digitizer appears to be partly controlled by the firmware since it works in Ubuntu, so maybe it needed a full shutdown to reset both the FW and Win8 drivers to get them working with each other?
  15. xweb10's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    532 Global Posts
    #15  
    Let me ask this: When you ran the windows update, was your Surface plugged in? Mine was plugged in and I had the same issue with the stylus not working. Unplugged from power, rebooted, and the stylus was back in business.
  16. cameradork's Avatar
    Member

    Posts
    561 Posts
    #16  
    Quote Originally Posted by xweb10 View Post
    Let me ask this: When you ran the windows update, was your Surface plugged in? Mine was plugged in and I had the same issue with the stylus not working. Unplugged from power, rebooted, and the stylus was back in business.
    Mine was plugged in. Stylus stopped working after the update, I rebooted (still plugged in) and it fixed it. I think it has more to do with the reboot.
  17. xweb10's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    532 Global Posts
    #17  
    Quote Originally Posted by cameradork View Post
    Mine was plugged in. Stylus stopped working after the update, I rebooted (still plugged in) and it fixed it. I think it has more to do with the reboot.
    Interesting. A reboot did nothing for me when plugged in.
  18. cameradork's Avatar
    Member

    Posts
    561 Posts
    #18  
    Quote Originally Posted by xweb10 View Post
    Interesting. A reboot did nothing for me when plugged in.
    maybe it needed two? always hard to tell with MS updates - I recently restored a computer to factory with Win7 and it took something like 14 reboots and checking of Windows Updates to fully get it back up to date... it's like it doesn't know there's a new update until the one directly before it is installed.
  19. Gravity oXo's Avatar
    Member

    Posts
    28 Posts
    Global Posts
    29 Global Posts
    #19  
    I saw a post on Microsoft Answers about the stylus issue. I can't find the post now, but the response from them was basically that they're looking into it, and if you have the problem to click on your Name/Avatar in the top-right of the Start screen. Click "lock". Wait 10 seconds, then log back in. This worked for me. Hope that helps anyone else having issues.
    Thanked by:
  20. jmerrey's Avatar
    Member

    Posts
    1,626 Posts
    Global Posts
    1,638 Global Posts
    #20  
    Quote Originally Posted by Gravity oXo View Post
    I saw a post on Microsoft Answers about the stylus issue. I can't find the post now, but the response from them was basically that they're looking into it, and if you have the problem to click on your Name/Avatar in the top-right of the Start screen. Click "lock". Wait 10 seconds, then log back in. This worked for me. Hope that helps anyone else having issues.
    This solution just worked for me as well.
  21. Gravity oXo's Avatar
    Member

    Posts
    28 Posts
    Global Posts
    29 Global Posts
    #21  
    Has anyone noticed a drop in battery life since this update? I'm wondering if it has to do with the updated WiFi stuff? My Pro would typically easily make it through my work day (not constant use, just note taking, occasionally playing my turn in Skulls of the Shogun, and web browsing). After this update, it seems it can barely make it through the day. Even with less use.

    Has anyone else noticed this?

    EDIT: Just wanted to follow up on this. My battery life issue was NOT related to the update. I didn't realize I had the GameFly desktop app minimizing to the taskbar. It was running constantly. Surprising how much battery it was draining. After modifying the preferences to keep if from minimizing to the taskbar, all is well. :)
    Last edited by Gravity oXo; 04-17-2013 at 12:12 PM. Reason: Found solution to my problem.
  22. #22  
    A solution to the pen was to simply disconnect the keyboard, check if the pen works, reconnect keyboard if it does.
  23. robinlawrie99's Avatar
    Member

    Posts
    1 Posts
    #23  
    The same thing happened to me. After installing the update my Pro wouldn't turn on - black screen. Two hours with a Microsoft tech assistant failed to fix it, and he advised me to exchange the unit for a new one. I did, but after a second update my new Pro failed to recognize either the stylus or the type cover. Numerous reboots and two more hours with another tech person failed to fix the problem, and she advised me to exchange the keyboard and pen. I took the whole thing back and got my money back. Maybe Microsoft will fix the problems and I'll buy another Pro one day.
  24. craigrmsmith's Avatar
    Member

    Posts
    1 Posts
    #24  
    I'm having this issue. Unplug keyboard - pen works fine. Plug it back in.. no pen input. Really frustrating
  25. VikingSOS's Avatar
    Member

    Posts
    1 Posts
    #25  
    I had the same problem with pen not working after 8.1 upgrade when the keyboard is plugged in. To resolve
    Uninstall the Wacom drivers app called ISD tablet ( or something like that ) from control panel . The pen will start working immediatelty after the uninstall.

    You can install the latest drivers from Wacom Feel Driver | Wacom Americas if you like.
    Good luck.
    Thanked by:
Page 1 of 2 12 LastLast

Similar Threads

  1. Nokia Music not working anymore
    By aimulaidni in forum Nokia Lumia 920
    Replies: 4
    Last Post: 04-10-2013, 01:21 AM
  2. Native Messenger Chat not working anymore?
    By btbam91 in forum Windows Phone 7
    Replies: 1
    Last Post: 01-20-2013, 01:19 PM
  3. Replies: 4
    Last Post: 12-30-2012, 12:41 AM
  4. Slacker Update/Removed from Marketplace/New one from ATT/Not working
    By MichaelBanning in forum Windows Phone Apps
    Replies: 1
    Last Post: 11-03-2011, 01:53 PM
  5. foursquare does not work anymore
    By emko in forum Windows Phone Apps
    Replies: 4
    Last Post: 03-16-2011, 04:53 PM

Posting Permissions