Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 15 of 15
  1. Antwan3k's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    20 Global Posts
       #1  
    I'm easily able to remotely access my desktop using my Surface RT with the Remote Desktop app on my home network (home WiFi) but I have no luck accessing my desktop via the Remote Desktop app when i'm not at home and using my AT&T mobile hotspot. I've tried to enter a search for my home IP address as well as the name of the PC and nether can be found. am I missing something or is this simply not possible?

    to my knowledge, I have all the remote access permissions set up correctly on the desktop and like I said, I have no problem linking up over the local network. simply want to be able to have the same access when i'm not at home. i'm running regular Windows 8.
  2. #2  
    Make sure you know what your IP address is. Go to google and type in what is my ip. Google should tell you or there are a bunch of links that will tell you. Second, make sure you forward the correct port to you computer you want to access. TCP 3389.
    Thanked by:
  3. narv's Avatar
    Member

    Posts
    259 Posts
    #3  
    Make sure your router will port forward port 3389. I had to open it on my router before I got it to work
    Thanked by:
  4. Antwan3k's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    20 Global Posts
       #4  
    Thank you so much.. Ok, here's a dumb question: how do you forward the TCP 3389?
  5. Stig's Avatar
    Member

    Posts
    100 Posts
    Global Posts
    434 Global Posts
    #5  
    Quote Originally Posted by Antwan3k View Post
    Thank you so much.. Ok, here's a dumb question: how do you forward the TCP 3389?
    If you Google 'port forward' and the make/model of your router you should find instructions.
    Thanked by:
  6. Antwan3k's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    20 Global Posts
       #6  
    Ok, thanks again
  7. narv's Avatar
    Member

    Posts
    259 Posts
    #8  
    Like said above, google your router type for instructions. However some routers are from your ISP and port forwarding is disabled in the control panel.. For something like that you'd need to call the ISP. But chances are higher you have a D-link or Linksys router which should be easy to setup via the control panel. You can also check your computer's IP address with a site like What Is My IP Address? Lookup IP, Hide IP, Change IP, Trace IP and more... to make sure you have the correct one.... There is a *chance* your IP address may change as it's dynamic.. but restarting your computer want necessarily change your IP address.. If you plan to be traveling a lot and want to access your PC remotely.. you may want to look into a static IP address or some other options that keep track of your machine's IP address if it changes.
    Thanked by:
  8. Antwan3k's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    20 Global Posts
       #9  
    I can't wait to get home and try out these tips.. I really appreciate the help
  9. jaimeastin's Avatar
    Member

    Posts
    361 Posts
    Global Posts
    377 Global Posts
    #10  
    Is this even secure to remote desktop without VPN or such? I VPN to my home network or use the windows home server https method...
  10. NickA's Avatar
    Member

    Posts
    509 Posts
    Global Posts
    2,478 Global Posts
    #11  
    Quote Originally Posted by jaimeastin View Post
    Is this even secure to remote desktop without VPN or such? I VPN to my home network or use the windows home server https method...
    It can be locked down further by doing some Mac Address and IP Filtering on your router. I always change the default port as well from something other that 3389.
  11. sportex's Avatar
    Member

    Posts
    121 Posts
    #12  
    I would like to access my desktop with my 8x as well as my Rt using the 3 network. How would I go about it???
    Last edited by sportex; 02-10-2013 at 02:45 AM.
  12. Captain_J's Avatar
    Member

    Posts
    13 Posts
    #13  
    I had mine set up and working well for a while but my ISP blocked my access. From my understanding, there is no way around it using Remote Desktop.
  13. Antwan3k's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    20 Global Posts
       #14  
    ok, I've done everything step-by-step but my PC will not allow me to change the port forwarding to TCP 3389.
    I get this failure message:

    The specified port(s) are being used by other configurations. Please check your configurations of Remote Management, Port forwarding, Port Triggering, UPnP Port Mapping table, RIP, and Internet connection type
    any ideas?
  14. Antwan3k's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    20 Global Posts
       #15  
    Finally got it working!!!!. the latest firmware on my netgear router was the problem. I went back to the previous version and everything worked with no problems. thx to everyone for the advice.. also, this website helped out a lot too.. step-by-step instructions:

    Your Complete Guide to Using Remote Desktop on the Microsoft Surface and Windows 8 Operating Systems

Similar Threads

  1. Fastest Remote Desktop app (like Splashtop for iPhone)
    By joopajoo in forum Windows Phone Apps
    Replies: 1
    Last Post: 06-19-2014, 05:22 PM
  2. What is the company app store, how do you set one up?
    By the_tyrant in forum Windows Phone 8
    Replies: 1
    Last Post: 12-11-2012, 02:30 AM
  3. Potential for Surface RT to run Windows 8 Pro
    By Lundon44 in forum General Tablet Discussion
    Replies: 20
    Last Post: 10-18-2012, 02:06 PM
  4. How do you pay for the apps?
    By jalb in forum Windows Phone 7
    Replies: 3
    Last Post: 03-13-2011, 07:34 AM
  5. The best twitter app for windows phone 7
    By mark300 in forum App Spotlight
    Replies: 32
    Last Post: 03-03-2011, 12:16 AM

Posting Permissions