Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
Like Tree4Likes
  • 2 Post By Mellifluous
  • 2 Post By Mike Dimmick
  1. Mellifluous's Avatar
    Member

    Posts
    178 Posts
    Global Posts
    180 Global Posts
       #1  
    I had to revert back to 8.0 on my Surface RT because when logged in, CRM Dynamics was showing a "mobile express" version of the site after logging in, compared with the full version you get on RT 8.0 and normal Windows 8 etc. The site was basically unusable since it lacked all of its normal functionality.

    I had a chat with Microsoft support and they said this was something they were working on, they had had a few complaints of IE11 giving people mobile versions of sites.

    Has anyone else had similar issues with 8.1?
  2. explosive0's Avatar
    Member

    Posts
    312 Posts
    Global Posts
    316 Global Posts
    #2  
    Quote Originally Posted by Mellifluous View Post
    I had to revert back to 8.0 on my Surface RT because when logged in, CRM Dynamics was showing a "mobile express" version of the site after logging in, compared with the full version you get on RT 8.0 and normal Windows 8 etc. The site was basically unusable since it lacked all of its normal functionality.

    I had a chat with Microsoft support and they said this was something they were working on, they had had a few complaints of IE11 giving people mobile versions of sites.

    Has anyone else had similar issues with 8.1?
    Same issue with Outlook Web Access. IE 11 defaults to (with no option to change) to the mobile version.
  3. hotphil's Avatar
    Member

    Posts
    462 Posts
    #3  
    Yep happens with a few adult sites too

    Or so I'm told.
  4. Mellifluous's Avatar
    Member

    Posts
    178 Posts
    Global Posts
    180 Global Posts
       #4  
    Quote Originally Posted by explosive0 View Post
    Same issue with Outlook Web Access. IE 11 defaults to (with no option to change) to the mobile version.
    After a little bit of research. I worked out there is a simple fix to my issue, it will probably work for you!

    1. Navigate to the website that isn't displaying properly.
    2. In Internet Explorer (desktop), tap and hold on the bar at the top (or right click).
    3. Tap on "Menu bar" so it's highlighted and there is a tick by it. A menu with File, Edit, View, Favourites, Tools and Help should appear.
    4. Go to tools and open "Compatibility View Settings". "Add this website" should have the domain of the site you've visited already filled, so click "Add".
    5. Close the windows then refresh the website that wasn't displaying properly. It should hopefully now display as it should.
  5. smbishop's Avatar
    Member

    Posts
    13 Posts
    #5  
    Thank you! This worked for me.
  6. Mike Dimmick's Avatar
    Member

    Posts
    1 Posts
    #6  
    IE 11 sends a User-Agent string designed to look a lot more like Firefox/Chrome/Safari, so that web sites stop serving it content designed for IE6 that doesn't work properly now that IE implements many more of the W3C standards. They've put 'like Gecko' into the string - a lot of websites use this to detect one of the other browsers. It's quite likely that badly-coded websites or web front-ends are doing the same thing that caused all the problems in the early 2000s when IE6 basically had no competition: using the User-Agent string to decide what content to send to the browser. At a guess, some piece of the User-Agent string is making the server code think that you're using an iPhone.

    Sites and web applications should instead be using feature tests to decide whether to use a feature, and not assuming that the presence of any one feature implies the presence of another.

    The 'immersive' (formerly-known-as-Metro) version of IE11 doesn't have a Compatibility View button, but the 'desktop' version does, and any change you make in the desktop version is reflected in the immersive one.

    (Posted in IE11 Preview/Windows 7)
    Thanked by:
    hotphil and Phil Kingston like this.
  7. #7  
    you're the man, Mellifluous! thanks!
  8. DarthMengon's Avatar
    Member

    Posts
    30 Posts
    Global Posts
    31 Global Posts
    #8  
    i think this issue has been resolved by yesterdays updates, could you test it ?
  9. Moacir Zotelli's Avatar
    Member

    Posts
    1 Posts
    #9  
    Hey, thank you very much. It has solved the issue for me!
  10. I_newbie's Avatar
    Member

    Posts
    3 Posts
    Global Posts
    4 Global Posts
    #10  
    Can I change the website from normal view to mobile view on my surface RT? Cause alot of website in my country are full of advertise but the mobile version don't. I just want to see the news on those but the advertise are too much and annoying. Or any way to block those advertise?
  11. Guzzler3's Avatar
    Developer

    Posts
    949 Posts
    #11  
    If you are feeling courageous, I can show you how to change the user agent string, as another way to force ALL websites to not give you their mobile version.

    WARNING: You need to modify registry to do this, but I'll try to make it as painless as possible

    1. Start Notepad.exe
    2. Paste the following into Notepad:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent]
    @="Mozilla/5.0"
    "Platform"="WOW64"
    "Version"="Windows NT 6.3"

    3. Save the file as "RT-user-agent-set.reg"
    4. Double click the above file, and allow the following program to make changes to the registry.
    5. Exit all instances of IE (or just reboot to make sure)
    6. Go to any web site you know that always shows the mobile version, it should display the "normal" version. This will carry to either IE 11 App or Desktop Program.

    Now, if you want to go back to the default user agent string in RT:
    1. Open Notepad.exe
    2. Paste the following into Notepad:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent]
    @=""
    "Platform"=-
    "Version"=-

    3. Save the file as "RT-user-agent-clear.reg"
    4. Double click the file, and again allow it make changes to the registry.
    5. Quit all instances of IE (or reboot just to make sure).
    6. Go to any web site that shows the mobile version, and should be back to the mobile version. This will carry over to either the IE App or IE Desktop Program.

    The reason I showed the process of creating .reg files, is that you can change back an forth with just a simple double click of a file. Just keep the files somewhere safe and easily accessible
    Guz

    iPhone 3G (broken)
    Blackberry 6320 (retired)
    Lumia 810 (current)

Similar Threads

  1. Twitter mobile site not showing images properly in browser
    By Asrialys in forum Windows Phone 8
    Replies: 8
    Last Post: 05-24-2014, 06:08 PM
  2. Volume issue in Lumia 520
    By API_Rock in forum Nokia Lumia 520
    Replies: 8
    Last Post: 04-13-2014, 12:37 AM
  3. Creating playlists in Windows Explorer for my Lumia 1020
    By jeffskent in forum Nokia Lumia 1020
    Replies: 6
    Last Post: 08-31-2013, 01:17 AM
  4. Thanks for the access point update..fix the error
    By eugie in forum General Microsoft News and Discussion
    Replies: 3
    Last Post: 08-26-2013, 05:17 AM

Posting Permissions