Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 16 of 16
  1. Olof7's Avatar
    Member

    Posts
    15 Posts
       #1  
    So I just got a Lumia 520 and it won't let me use it... It is just stuck at the 'low battery' screen with the red battery. I've had it plugged in for several hours, and it just won't start. Is the device faulty?
    Thanks in advance!
  2. Martsicky's Avatar
    Member

    Posts
    1,130 Posts
    #2  
    I had the same issue with my 820 two times.. Try it: unplug charger-> turn off the phone-> remove battery-> wait few seconds-> insert battery again-> plug the charger and phone will turn on automatically:) Let me know if it works.
  3. Olof7's Avatar
    Member

    Posts
    15 Posts
       #3  
    Unfortunately it does not seem to work :( but thanks for your help! :)
  4. Martsicky's Avatar
    Member

    Posts
    1,130 Posts
    #4  
    Well, try to charge it by plugging into PC. If it doesn't work, I have no solution at the moment. I will take a look over other topics or other websites to find something. Personally I would suggest you to contact your local Nokia Care/Nokia account on Twitter/Facebook. If nothing works, you should visit nearest Nokia Care service. But I believe there is an solution, and we will find it. :-)
  5. Olof7's Avatar
    Member

    Posts
    15 Posts
       #5  
    Yeah, connecting it to the PC did not work, big surprise haha :P
  6. Martsicky's Avatar
    Member

    Posts
    1,130 Posts
    #6  
    I'm unable to help, thought that my trick with removing battery will work for you too :) I'm sorry, I suggest you to contact local Nokia Care service. If your battery is not working properly, they should replace it in 10-20minutes, depending on battery availability, amount of reports/clients. Good luck! :-)
  7. Olof7's Avatar
    Member

    Posts
    15 Posts
       #7  
    Ok! Well thanks a lot anyway! :)
  8. rakesh1995's Avatar
    Banned

    Posts
    391 Posts
    Global Posts
    399 Global Posts
    #8  
    Quote Originally Posted by Olof7 View Post
    So I just got a Lumia 520 and it won't let me use it... It is just stuck at the 'low battery' screen with the red battery. I've had it plugged in for several hours, and it just won't start. Is the device faulty?
    Thanks in advance!
    how can battery be red? its default white colour i think you are using a battter app. such app get updated per 30 min. dont worry your phone is ok its getting charged
  9. homosapiens's Avatar
    Member

    Posts
    4 Posts
    #9  
    Try removing the microsd card. I had this problem with my L620 and new microsd solved the problem.
  10. Martsicky's Avatar
    Member

    Posts
    1,130 Posts
    #10  
    Quote Originally Posted by rakesh1995 View Post
    how can battery be red? its default white colour i think you are using a battter app. such app get updated per 30 min. dont worry your phone is ok its getting charged
    Nah... He meant that he cant switch on his phone, because just after NOKIA's logo shows on screen, red battery indicator appears, and phone switches off. (that means that battery was totally discharged or faulty hardware/software, makes phone unable to turn on.)
  11. Raver Rain's Avatar
    Member

    Posts
    27 Posts
    Global Posts
    28 Global Posts
    #11  
    Quote Originally Posted by Martsicky View Post
    Nah... He meant that he cant switch on his phone, because just after NOKIA's logo shows on screen, red battery indicator appears, and phone switches off. (that means that battery was totally discharged or faulty hardware/software, makes phone unable to turn on.)
    he need to go to nokia care
  12. Alex A70's Avatar
    Member

    Posts
    1 Posts
    #12  
    Had the exact same issue. Am getting the phone replaced. Not quite sure what the issue is. The connection with the USB works as it kind of powers up. Maybe an issue with the battery connection. Hopefully not a software issue or my phone replacement won't help.
  13. styles90's Avatar
    Member

    Posts
    1 Posts
    #13  
    Please my lumia520 wont start. Anytime i put it on, it would show NOKIA and then switch off again. So what could be the problem? Is it crashed?
  14. #14  
    I had the same problem. I took my battery out for about one minute. Replaced it. Then plugged my phone up to the computer using the USB cord and it came on! Thank goodness!
  15. missjoso's Avatar
    Member

    Posts
    2 Posts
    #15  
    Thank you. it really helped me.
  16. missjoso's Avatar
    Member

    Posts
    2 Posts
    #16  
    Thank you. it really helped me.

Similar Threads

  1. new windows phone for verizon????
    By malachijd in forum HTC Trophy
    Replies: 45
    Last Post: 12-13-2011, 11:28 AM
  2. New Windows Phones in Canada?
    By Steener13 in forum Windows Phone 7
    Replies: 5
    Last Post: 11-06-2011, 09:49 PM
  3. Replies: 2
    Last Post: 10-06-2011, 07:12 PM
  4. AT&T announces new Windows Phone lineup
    By Curtieson in forum Upcoming & Rumored Devices
    Replies: 33
    Last Post: 09-21-2011, 07:32 AM
  5. Fujitsu officially announces their new Windows Phone.
    By Winterfang in forum Windows Phone 7
    Replies: 14
    Last Post: 07-27-2011, 05:21 PM

Posting Permissions