We made some changes

Our new forums are here!

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 35
Like Tree16Likes
  1. Rosie Khan's Avatar
    Member

    Posts
    15 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    hi my lumia 520 is about two months old and was running well, few days back the battery got low and phone powered off, i started to charge it but the charging sign would not show up only the 'nokia" screen was there then i opened back lifted the battery replaced it again to resume charging but the problem did not fix and now as i charge it or press the start button it vibrates the "nokia" screen comes then the light blue screen with nothing on it then screen goes blank, when the phone was working there used to b "windows phone " on the blue screen, then came the home screen with tiles, i think it is not booting please do help! i tried to press start and vol down button together but same thing happens.
  2. WorzelGummage's Avatar
    Member

    Posts
    1,059 Posts
    Global Posts
    1,062 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Sometimes, Lithium-ion batteries have a nasty habit of refusing to charge if they are allowed to drain completely. If this has happened to yours then you may have to buy another battery. However, try leaving it plugged in for a few hours to see if it does charge back up again. If it doesn't, then you will have to get a new battery.
  3. Rosie Khan's Avatar
    Member

    Posts
    15 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #3  
    thanks, i got the same battery charged by a universal charger phone still did not boot, i even tried a new battery actually i think there is windows booting problem, any more advice please, thanks!
  4. Vinay Nadar's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    facing same problem....did u find a solution....?

    plz share
  5. Pavitra Kavali's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    my phone is not start up it wil display only windows phone it is continuesly looping
  6. R Gopalan's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #6  
    i have the same problem !! can u please tell me how did u resolve it if u did ??
  7. walter1832's Avatar
    Member

    Posts
    180 Posts
    Global Posts
    218 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    Are you holding down VOL DOWN and PWR button until you feel a vibration? It should be for about 10-15 seconds.
  8. peelfox's Avatar
    Member

    Posts
    2 Posts
    Global Posts
    1 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #8  
    Yes, I have the same problem. My phone was working fine, took out battery to change a sim card, then it would not start. Charged it for overnight still nothing.. Tested battery & it has virtually no power. Only screen I get is picture on battery charging. Help!
  9. Jeanetta Monfort's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    My phone was looping too. i had put in a new sim and a memory card. I took the memory card back out and it started working fine.
  10. nick juniper's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    i am having same problem atm.... except im not at home so i cant check to see if it will charge... it happened with my samsung windows phone... so kinda terrified atm... someone please tell me exactly what they did to fix it
  11. Kalash Chaudhary's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    hey i have the same problem if u got the solution please reply me
  12. Sunny Pathak's Avatar
    Member

    Posts
    1 Posts
    Global Posts
    2 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    You should try and take out the memory card. Although it all depends. It works, sometimes it doesn't. I think it's a software and not a hardware issue.
  13. laxinitup34's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    Quote Originally Posted by Sunny Pathak View Post
    You should try and take out the memory card. Although it all depends. It works, sometimes it doesn't. I think it's a software and not a hardware issue.
    I just had the same problem where my phone wouldn't fully boot. And coincidentally it was immediately after I had reinstalled the micro sd card. The sd card had been in the phone for about 3 months with ZERO problems. The only thing I added to the card today was a 1:48 video. I tried removing the sd card and booting the phone without it installed and it has worked fine since. The sd card however must have been damaged in the process of transferring data, because it will not work in my asus tf300t tablet either.
  14. Chriz09's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #14  
    I have the same problem and my lumia is 2 months old,I took out the sd card to do something put it back on tried turning it on didn't it displayed nokia then blue screen took it to the vodashop and was told there might be charges involved.I think it's kinda weird tha so many people have the same problem with new lumia cellphones
  15. Barracuda7772's Avatar
    Member

    Posts
    144 Posts
    Global Posts
    2,667 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #15  
    For everyone here, I had a similar issue and found the issue was due to a loose battery connectors I found while the battery was in i wedged a small piece of folded paper between the phone and the right side of the battery (make sure it's the right side). As I've found the 520 has poor quality battery receivers. This trick solved all reboots and failing to charge for me.... No issues ever since. Hope this helps even a few of you

    Sent from my Nexus 7 using Tapatalk
  16. Adam Chinery's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #16  
    I have the same problem - I only get the word "Nokia" on the black screen when I first turn it on, and it just stays there or goes off and then comes on again! I've tried the thing above, did it take a few goes to get it in the right place or do you literally just wedge it in? Thanks
  17. Kunalya's Avatar
    Member

    Posts
    146 Posts
    Global Posts
    147 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #17  
    Dear Friends,
    same Problem Got mee too, asked to nokia center , as suggested to reset like this and helped me a lot... got my windows phone written on blue screen....
    All you need to do is to reset your phone by soft reset. Setting---->About Section-----> Reset Phone.
    While resetting phone don't try to charge phone or take out battery, neither it wont work....
  18. NYRbeezer's Avatar
    Member

    Posts
    27 Posts
    Global Posts
    49 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #18  
    Quote Originally Posted by Kunalya View Post
    Dear Friends,
    same Problem Got mee too, asked to nokia center , as suggested to reset like this and helped me a lot... got my windows phone written on blue screen....
    All you need to do is to reset your phone by soft reset. Setting---->About Section-----> Reset Phone.
    While resetting phone don't try to charge phone or take out battery, neither it wont work....
    Uhhh... if the phone won't start and turn on, how do you expect people to do this?
  19. mrimozinoh's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #19  
    how u fixed it? it happening to me ryt now
  20. Deepak Kumar20's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #20  
    all of guys and girls who are facing this problem can hard reset their lumnia phones. going to site Mobile recovery website
  21. Dan Hamm's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #21  
    Quote Originally Posted by Barracuda7772 View Post
    For everyone here, I had a similar issue and found the issue was due to a loose battery connectors I found while the battery was in i wedged a small piece of folded paper between the phone and the right side of the battery (make sure it's the right side). As I've found the 520 has poor quality battery receivers. This trick solved all reboots and failing to charge for me.... No issues ever since. Hope this helps even a few of you
    This totally worked on my 520. Thanks!!!!
  22. Anuja Seereeram's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #22  
    this was happening to me aswell and i bought a new battery and it worked fine but one day the battery was low and it fell and the battery fell out and it has started again
  23. Ragupathi's Avatar
    Member

    Posts
    55 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #23  
  24. Rosie Khan's Avatar
    Member

    Posts
    15 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #24  
    Resetting the phone solved the problem but all data formats
  25. Dolly17's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #25  
    Thank You so much! It did work.
Page 1 of 2 12 LastLast

Similar Threads

  1. Nokia Lumia EU ROM GDR2+Amber Download Link
    By VegaNovus in forum Nokia Lumia 920
    Replies: 226
    Last Post: 12-28-2015, 01:53 PM
  2. WTS: Nokia Lumia 920 (white) with Charging Plate (black)
    By photobriangray in forum Marketplace Archive
    Replies: 7
    Last Post: 09-04-2013, 10:07 AM
  3. Is it risky to buy a Lumia 925 from another country?
    By Raymond29 in forum Nokia Lumia 925
    Replies: 5
    Last Post: 08-29-2013, 01:16 PM
  4. Lumia 520 offline runtastic
    By ho0lee0h in forum Nokia Lumia 520
    Replies: 2
    Last Post: 08-07-2013, 03:31 AM
  5. Sold
    By sdc1 in forum Marketplace Archive
    Replies: 1
    Last Post: 08-06-2013, 02:38 PM

Posting Permissions

";