Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By bigpaulc
  1. bigpaulc's Avatar
    Member

    Posts
    8 Posts
       #1  
    Hi

    I got a new Lumia 520 a few days ago and have a weird issue with the screen.

    It seems that the last few columns of pixels on the right side get shown on the left side of the screen.

    For example, on the left I can see a tiny part of the text which should be over to the far right.

    It's almost like the screen is shifted over to the right a few pixels, causing it to appear on the left.

    Any one got any ideas how to fix this? Or should I just return it?

    Thanks
  2. Osama Adam's Avatar
    Member

    Posts
    3 Posts
    #2  
    Welcome to windows phone, That's not a bug or faulty screen or anything. It's just how the UI of Windows phone works.
  3. bigpaulc's Avatar
    Member

    Posts
    8 Posts
       #3  
    So when you press a "p" or backspace or enter when entering text you also see the edge of the keys on the left hand side?

    I'm looking for videos, but I can't see anything which matches what I've got here...
  4. bigpaulc's Avatar
    Member

    Posts
    8 Posts
       #4  
    I tried taking a screenshot of my lock screen, but it came out normal.

    The very right edge of the screen is being shown on the very left side. That can't be normal surely!
  5. bigpaulc's Avatar
    Member

    Posts
    8 Posts
       #5  
    Here's what my lock screen looks like (right edge displayed on left):

    lock.jpg

    Surely that's not normal?
  6. Mr osi's Avatar
    Member

    Posts
    27 Posts
    #6  
    I would suggest restarting soft and hard, though it does sound like a possible hardware issue and if that's the case return it.
    Thanked by:
  7. bigpaulc's Avatar
    Member

    Posts
    8 Posts
       #7  
    Quote Originally Posted by Mr osi View Post
    I would suggest restarting soft and hard, though it does sound like a possible hardware issue and if that's the case return it.
    A soft reset fixed it! Took me 1 minute.

    Thanks very much Mr osi!!
    Rob Betts likes this.

Similar Threads

  1. Replies: 63
    Last Post: 11-16-2013, 12:26 PM
  2. Lumia 820 screen Broken, warranty?
    By SaiKiran7474 in forum Nokia Lumia 820
    Replies: 3
    Last Post: 08-27-2013, 12:34 PM
  3. Anyone know how to control Ringtone from start screen?
    By Moosebear in forum Nokia Lumia 710
    Replies: 2
    Last Post: 08-26-2013, 12:22 PM
  4. Email button dissapeared from Start screen, Pls help!
    By arislgr in forum Nokia Lumia 925
    Replies: 2
    Last Post: 08-26-2013, 03:28 AM
  5. Is it possible to change app language?
    By chenhogi in forum Windows Phone 8
    Replies: 4
    Last Post: 08-26-2013, 02:48 AM

Posting Permissions