Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By Corepc
  1. zukirin's Avatar

    55 Posts
    Whenever I attempt to use internet explorer through any means (wifi, or network) the pages would try to load but nothing ever shows up and it stops loading at when the green bar is just about to get full.

    I got the phone yesterday at Walmart and using an existing plan if that means anything. Thanks.
  2. Corepc's Avatar

    1,333 Posts
    Global Posts
    1,335 Global Posts
    Power off the phone, then power back on see if that helps. If does not

    Reset the phone from settings-about-
    Thanked by:
    Laura Knotek likes this.
  3. zukirin's Avatar

    55 Posts
    I ended up just resetting it like you said, and now it works. Thanks!
  4. tgp
    tgp is offline
    tgp's Avatar

    3,248 Posts
    Global Posts
    4,083 Global Posts
    I got a 521 just tonight at Walmart (2 of them actually), and I had the exact problem you did. No data on WiFi or cellular, and I couldn't even sign in to my Microsoft account. I'm also using an existing plan. I tried rebooting but it didn't help. Thankfully a reset worked!

Similar Threads

  1. Internet Sharing Issues
    By wptrial in forum Nokia Lumia 710
    Replies: 26
    Last Post: 05-14-2014, 12:48 PM
  2. Internet issues over cell network.
    By 9204life in forum Nokia Lumia 920
    Replies: 14
    Last Post: 01-09-2013, 06:36 PM
  3. Replies: 43
    Last Post: 12-15-2012, 01:08 PM
  4. issue with internet sharing on my radar 4g
    By en0x#AC in forum Windows Phone 7
    Replies: 3
    Last Post: 03-30-2012, 02:41 PM
  5. O2 mobile internet issue...
    By IanLorenc in forum Windows Phone 7
    Replies: 2
    Last Post: 03-19-2012, 09:31 AM

Posting Permissions