1. germcevoy's Avatar
    The graph from battery widget linked below shows the problem clearly. My first 18 or so hours with my 620. Any ideas what could cause a 60%-0 battery loss in 5 minutes? And in a similar vein why does the device think it is at capacity after only 5 minutes on charge? The battery stats within settings mirror the readings from battery widget. Losing confidence in the device very quickly.

    I have been sure to use the charger that came with the phone. I do have another unused 620 waiting for return so I might try and swap the batteries. As I type it does seem to be doing a more gradual charge.

    Any similar issues?


    https://skydrive.live.com/redir?resi...KyPunKT-aLLAI0
    02-17-2013 07:44 AM
  2. jiayit's Avatar
    It went down as quick as it came back, probably a display issue or something.

    And I find that I actually enjoyed my phone more when I don't OCD over my battery life.
    02-17-2013 07:47 AM
  3. germcevoy's Avatar
    The phone died when it reached zero so unlikely to be a readout issue.
    02-17-2013 07:58 AM
  4. germcevoy's Avatar
    Just discovered that my 620's have different battery's. They are both BL-4J but the O2 one is black and the sim free one is grey. More interestingly though the sim free model is rated at 1320mah compared to the 1300 on the O2 phone. Strange. It was the 1320mah giving me the above problems though. It charged normal from 0-30% then immediately hit 100%.

    Have switched the battery's now and will continue to monitor.
    02-17-2013 08:18 AM
  5. TheLuminis620's Avatar
    If both battery act similarly, you may want to try reset the phone. If the same thing occurs, something is very wrong with the phone. Just try a reset of both battery act the same...
    02-17-2013 09:10 AM
  6. germcevoy's Avatar
    Things discharging normally with the replacement battery. Hoping it continues.
    02-17-2013 12:45 PM
  7. jiayit's Avatar
    I think I know why.. Did you turn on Battery Saver mode at about 60%? Since battery apps plot graphs by running in the background, maybe you turned on battery saver, so it stopped running in the background (and thus it thinks your phone has 0 juice left), and then when you plug your phone in to charge, battery saver is turned off, it then detects your battery is at 100%.
    02-18-2013 04:24 AM
  8. germcevoy's Avatar
    Had considered this but as mentioned above the battery readout in the phone settings matched those on the app and the phone actually died when at zero.

    Glad to report though that things are running normal with the other battery. Phone has been off the charge for 13 hours now and after a day of moderate use I am on 24%. I'm more than happy with this performance from a 1300mah cell.
    02-18-2013 04:03 PM
  9. TheLuminis620's Avatar
    Glad to report though that things are running normal with the other battery. Phone has been off the charge for 13 hours now and after a day of moderate use I am on 24%. I'm more than happy with this performance from a 1300mah cell.
    Apart from one guy somewhere in this forum who were disgusted by the 1300mah battery pack (he didn't have neither tried the Lumia 620 anyway), I am feeling more than happy as I didn't expect the phone to last the whole day. Now normally I can get in the region of 15-24 hours everyday without a problem ;)
    02-18-2013 06:29 PM
  10. germcevoy's Avatar
    Battery still going well. On a moderate/heavy day I get around 15 hours which is more than sufficient to get me from morning when I leave the house until evening when going to bed. On light days it has powered right through to the next day. Longest life yet is 1 day 7 hours.

    Brilliant for the battery size considering I'm always using 3g/H and wifi at home.
    02-27-2013 05:49 AM
  11. peanutbutterbug's Avatar
    Take the battery out and put it back in. It solved my problem with it going from 100% to 10% in a matter of minutes.
    03-02-2013 10:34 AM

Similar Threads

  1. Battery issue with Arrive running Mango??
    By AlexanderMatthews in forum HTC Arrive / 7 Pro
    Replies: 15
    Last Post: 01-05-2012, 02:04 PM
  2. Anyone NOT having battery issues?
    By trmnta82 in forum Nokia Lumia 800
    Replies: 31
    Last Post: 12-13-2011, 02:37 PM
  3. Battery issues
    By isolde in forum LG Optimus 7
    Replies: 4
    Last Post: 11-22-2011, 02:03 PM
  4. Battery issues
    By Snow in forum Windows Phone 7
    Replies: 3
    Last Post: 10-15-2011, 07:15 AM
LINK TO POST COPIED TO CLIPBOARD