We made some changes

Our new forums are here!

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 52
Like Tree4Likes
  1. Ashley Davies1's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    A few months back I broke my phone's screen while walking uphill, having it smash on a rock after falling out of my pocket. I got it repaired at a stall in my local town (They did a shabby job of it though, and the antennae seems to be damaged since I barely ever have any signal) and since then it's worked acceptably. (Although it only ever seemed to recognise firmer presses or from my thumbs (I'm guessing it's thermal or something?)

    However this morning I woke up and it wanted me to update it, bearing in mind that the update requires me to press the touchscreen to begin, so it was definitely working previously.

    A few minutes later, the update finished and it booted onto a different wallpaper to usual. The buttons on the side still work fine; volume, wake up, etc, however the entire touchscreen is dead. It doesn't vibrate when I touch the windows/back/search buttons and it does not respond at all- not even the slightest, to presses or gestures.

    Is this a hardware problem that coincidentally occured the same time as the update; or has the update broken my phone?

    Any suggestions to repair this would be greatly appreciated! Thanks
  2. DBDev's Avatar
    Member

    Posts
    2,387 Posts
    Global Posts
    2,394 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    I don't know, but I think it sounds more like a hardware issue, but you could try a hard/soft reset and see if it helps.How to hard reset the Nokia Lumia 620 | The Hard Reset
  3. Ashley Davies1's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #3  
    Did a hard reset; same troubles.

    Is it likely to be possibly a loose ribbon cable or something?
  4. Pulserider's Avatar
    Member

    Posts
    173 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    Sorry to hear about your trouble. Maybe take it back to the place that repair it to maybe test another screen with your phone? Normally these kind of repair centers like to use compatible hardware that don't last long.
  5. Haamernus's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    I think it's due to the new Amber update. This update doesn't like anything but genuine digitizers.

    The same thing has happened to me. It worked fine after I replaced the digitizer then I performed the update and now it's totally unresponsive. I am looking into flashing the rom to an older version. Perhaps it will kick in then.
  6. Ashley Davies1's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #6  
    Haamernus, can you give an update on whether that helps? (And possibly any information on what rom you used =D) Thanks
  7. Carl Edwards3's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    My daughter's phone has the same problem. Someone on the official nokia forum told me that obviously the 3rd party digitizer I used for a repair a few weeks ago just happened to fail at the exact moment that the update was done... that's just, like, really likely isn't it...? Has anyone found a way around this yet?
  8. Ashley Davies1's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #8  
    Quote Originally Posted by Carl Edwards3 View Post
    My daughter's phone has the same problem. Someone on the official nokia forum told me that obviously the 3rd party digitizer I used for a repair a few weeks ago just happened to fail at the exact moment that the update was done... that's just, like, really likely isn't it...? Has anyone found a way around this yet?
    Were they a Nokia representative or just a random forumer?

    Hope someone comes out with a solution for this soon; glad to know I'm not the only person :P
  9. Carl Edwards3's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    Quote Originally Posted by Ashley Davies1 View Post
    Were they a Nokia representative or just a random forumer?

    Hope someone comes out with a solution for this soon; glad to know I'm not the only person :P
    A random forumer with 21,000 posts or so. Was thoroughly unsympathetic - basically was taking the p*ss because I'd decided to save a few quid by replacing the screen myself instead of taking it to a nokia care place. Said there was no way that people could expect Nokia to ensure that the operating system would work with every 3rd party part out there. I'm currently having a very slow (updated every 4 hours or so) dialogue with nokiahelp via twitter.
    Ashley Davies1 likes this.
  10. pk808's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    I've the same problem as Ashley Davies1.
    I had some online support from Nokia through Facebook: they advised to do a hard reset.
    After I did: no response, they advised to sent the phone to the Nokia Online Repair Service because it is in it guaranty period.
    Well, i'm afraid they don't except the guaranty, because I replaced the touchscreen after a nasty drop.
    Anyone a successful solution yet? Or sent the phone to Nokia Online Repair Service?
  11. DAAAAN's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    Damn, same problem here....

    New digitizer (cheap one, total repair cost me 9 euro) everything working fine -> updated it 30 mins ago and the touchscreen died....

    How do we downgrade?
  12. Carl Edwards3's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    I'm in the middle of a conversation with nokia care on live chat. They're saying they've never heard of this before. The phones cannot be downgraded. The only thing is to take it to an official licensed repairer and let them diagnose it.
  13. DAAAAN's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    Aight, I solved it !

    Luckily I didn't trow out my previous (factory) digitizer. Although it had a huge crack, I was always able to use to bottom half of the screen. So I reopened my phone, hooked up the original digitizer and entered my PIN (which is entered on the bottom half) and backupped all my previous data to the PC.

    Then I downloaded the original factory firmware ROM, which is;
    Variant ID : 7159782251
    Varian Name : RM-846 CV NL VAR261764 13040 001 Black v2 Default
    Product Code : 059R872
    Software Version : 1030.5603.1304.0002
    (you can download it on http://www.mrcrab.net/Nokia-Product-...ctCode=059R872 , and yes it does have almost every language)

    After that, follow the flash guide on Manually Flash GDR2 ROM on Lumia 620 and use the above ROM instead of the Amber one used in the guide.

    The amber update definitely ****s up non-official digitizers because it works like normal when you downgrade to the original version.
  14. boylucifer's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #14  
    Found this thread because I've got the same problem - can you tell me which file it is that I should be downloading as there seems to be a fair few of them there.
  15. Ashley Davies1's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #15  
    =( care suite doesn't pick up my phone- Guess I can't flash it without unlocking my phone (Correct me if I'm wrong which I probably am; worst part is I'm stuck in the setup option so I can't even unlock it even if the digitizer did work)
    stuff nokia; going HTC or samsung next time, got to put up with a broken phone for a 1.5 yr longer contract


    Edit:
    nevermind; just read the flashing page correctly... Lumia 620 and RM-846 aren't listed in my Open Product list :'(

    Edit2:
    urgh I'm so impulsive; just looked and found an update page... Next time I should spend a little longer looking before posting ^_^

    Edit3:
    The update download servers are soooooo slow :'(
    Last edited by Ashley Davies1; 09-27-2013 at 03:12 PM.
  16. Ashley Davies1's Avatar
    Member

    Posts
    6 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #16  
    Phone successfully flashing now =) Will post results of it afterwards.

    Thanks DAAAAN :D

    Edit:
    Yep, working perfectly now. Definitely not a hardware problem. Thanks everyone
  17. eugie's Avatar
    Member

    Posts
    264 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #17  
    Dont flash ur phone, use it dry screen and ur fingers so that it will not freeze..avoid sweaty fingers use cover not rubber.,,, leather or cotton
  18. DAAAAN's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #18  
    Quote Originally Posted by Ashley Davies1 View Post
    Phone successfully flashing now =) Will post results of it afterwards.

    Thanks DAAAAN :D

    Edit:
    Yep, working perfectly now. Definitely not a hardware problem. Thanks everyone
    You are welcome :-)
  19. Steve Slater's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #19  
    Could someone please link me the update page that allows the 620 to show up on Care Suite. I'm struggling to find it.
  20. moon_fire's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #20  
    Many thanks to Daaan for sharing his findings with us
  21. moon_fire's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #21  
    I installed the most recent software and followed the steps instructed in the tutorial.
    But I'm stuck on finding my device's code -see first attachment.
    What's strange is that if i choose the refurbish option then the product code is shown -the second attachment. Any help on this?
    Attached Thumbnails Attached Thumbnails product-code.jpg   refurbish.jpg  
  22. moon_fire's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #22  
    I followed the steps as they were described although the tutorial isn't that foolproof as it should! Thanks again!
  23. Geert Callebaut's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #23  
    I always get:
    C:\ProgramData\Nokia\Packages\Products\RM-846\5AB43B31_RM846_059R872_1030.5603.1304.0002_016.vpl has invalid signature.

    Help :-)
    Last edited by Geert Callebaut; 10-07-2013 at 08:12 AM.
    Terfas Farok likes this.
  24. Iggor's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #24  
    you need to rename files in this folder

    Quote Originally Posted by Geert Callebaut View Post
    I always get:
    C:\ProgramData\Nokia\Packages\Products\RM-846\5AB43B31_RM846_059R872_1030.5603.1304.0002_016.vpl has invalid signature.

    Help :-)
  25. Karan Arora1's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #25  
    I am also getting the same error "invalid signature",
    How to rename it ? What should be the new name ?

    Thanks :)
Page 1 of 3 123 LastLast

Similar Threads

  1. Samsung Ativ S broken wi-fi and bluetooth after updates.
    By darkjamzi in forum Samsung ATIV S
    Replies: 14
    Last Post: 02-27-2014, 08:33 AM
  2. [HELP] Phone stuck at gears spinning after GDR2 update.
    By Ayush Upadhyay in forum Nokia Lumia 620
    Replies: 11
    Last Post: 09-24-2013, 08:45 AM
  3. Windows Phone 8.1 update with Cortana due early next year
    By Jump Jet in forum Nokia Lumia 920
    Replies: 14
    Last Post: 09-22-2013, 04:27 AM
  4. Does the 620 record video with stereo sound?
    By Sebsweden in forum Nokia Lumia 620
    Replies: 1
    Last Post: 09-20-2013, 08:33 AM
  5. "My EE" app not working after update?
    By Racing Snake in forum Nokia Lumia 920
    Replies: 9
    Last Post: 09-20-2013, 05:25 AM

Posting Permissions

";