Get ready for beta!

Prepare for Halo Wars 2 Blitz Mode beta: Everything you need to know!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. prat23's Avatar
    Member

    Posts
    4 Posts
    Global Posts
    6 Global Posts
       #1  
    Hi all,

    Just bought the nokia 800 a couple of days ago and already ran into a major problem: my phone only works on 3g HSPA, if the 3g signal becomes very low as is usual for my area, it sits there with no service at all instead of switching to 2g. Other phones get full 2g signals on the same network sitting right beside it.

    1. I've already tried to reset the phone which i hated after all the logins in different apps.
    2. tried ringing it from another phone (as suggested online) but no luck
    3. tried changing the highest connection speed under mobile network settings to 2g (E) only, but then it neither gets 2g nor 3g signals (no service).
    4. tried different sim cards but its the same.
    5. tried making a call but as expected- nothing.

    Can anybody throw some light on the issue? I've come across threads with no service problems but not anything with this particular issue.

    Thanks :)
  2. Squachy's Avatar
    Member

    Posts
    504 Posts
    #2  
    Is your phone unlocked?
    and what carrier are you on?
  3. prat23's Avatar
    Member

    Posts
    4 Posts
    Global Posts
    6 Global Posts
       #3  
    Thanks for the reply Squachy, however, i have returned the phone now with utter sadness and got a refund. And i am wary of buying one again owing to other reports of no service for the phone... which is sad because i really liked it.
  4. l33tish's Avatar
    Member

    Posts
    7 Posts
    #4  
    Tbh this sounds like you have not got a correct regions phone.
    Aka your in the USA using T-mobile which uses a band only on 800's for the USA, not EU which dont support the band and instead support another.
    The band I think affects 2G reception but not 3G if you say were EU and got a USA model by mistake.
    Its a pity you dont have it still as its possible to check on the box I think.

Posting Permissions