Get ready for beta!

Halo Wars 2 Blitz: Game modes, beginner's tips, and more

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. AWpeteC's Avatar
    Member

    Posts
    1 Posts
       #1  
    Help,
    I have Data Connection switched ON.
    WiFi switched OFF. (works realy fast through WiFi)
    Tried roaming ON and OFF
    I cannot connect to internet through O2 ( I have 1Gig limit and not used any yet).
    Anyone else have this trouble?.
    Otherwise I think the phone is great.
  2. jfa1's Avatar
    Member

    Posts
    2,564 Posts
    Global Posts
    2,647 Global Posts
    #2  
    have you checked to be sure your settings are correct?
  3. zhani's Avatar
    Member

    Posts
    7 Posts
    #3  
    Any update ? I have the same problem and frustrated. I use the phone for business and about to smash it against the wall.
  4. jiayit's Avatar
    Member

    Posts
    302 Posts
    Global Posts
    338 Global Posts
    #4  
    Quote Originally Posted by zhani View Post
    Any update ? I have the same problem and frustrated. I use the phone for business and about to smash it against the wall.
    Careful, the wall might collapse on you.

    Have you tried rebooting your phone, removing the sim card, etc?
  5. zhani's Avatar
    Member

    Posts
    7 Posts
    #5  
    I tried everything in vain. I have restored factory settings even and re-installed the software. I am an ex-Nokia employee and has been holding on the symbian since forever.
  6. nidO#WN's Avatar
    Member

    Posts
    11 Posts
    #6  
    I briefly had this problem with my 820 (also on O2 UK) and solved it by correcting the access point in use - Under Settings > Access Point the device picks up 4 sets of access point info with my O2 sim, being "O2 - UK Prepaid", "O2 - UK", "TESCO", and "giffgaff" - Although i'm on a contract my access point had defaulted to "O2 - UK Prepaid" which would not provide me with a data connection, I simply altered this to "O2 - UK" and have had no problems since.
  7. zhani's Avatar
    Member

    Posts
    7 Posts
    #7  
    I have only one access point unfortunately on my SIM. It was working fine for 2 weeks :(
  8. zhani's Avatar
    Member

    Posts
    7 Posts
    #8  
    I think very soon ill smash it against the wall. That was unthinkable with Symbian.
  9. zhani's Avatar
    Member

    Posts
    7 Posts
    #9  
    Cant we do some advanced troubleshooting to this thing?
  10. SinisterDuck's Avatar
    Member

    Posts
    120 Posts
    Global Posts
    123 Global Posts
    #10  
    You should take the phone in to have it troubleshooted . . . troubleshot . . . have them look at it. It doesn't sound like something that can be fixed here.
  11. zhani's Avatar
    Member

    Posts
    7 Posts
    #11  
    I don't think so. I know exactly where ill be taking it :)

Similar Threads

  1. Data Connection (and other) Issues with Quantum
    By zr2s10 in forum LG Quantum
    Replies: 4
    Last Post: 09-30-2011, 02:33 AM
  2. No signal, means no data connection?
    By jeff4L in forum HTC HD 7 / 7s
    Replies: 6
    Last Post: 04-20-2011, 02:58 AM
  3. Issues with data connection
    By Redbird1 in forum HTC HD 7 / 7s
    Replies: 6
    Last Post: 11-22-2010, 06:35 PM

Posting Permissions