1. Robbie95's Avatar
    Hi all! Got my brand new lumia 820 a few days ago, happy with it so far. Only problem is the network signal strength, its not very good most the time. What happens is i'll get 3 bars of signal and it will drop down to 1 back up to 2 then no signal then back to 3 bars? I have a cheap Samsung PAYG phone on the same network and the signal is really good! At my mums house where the signal is supposed to be excellent which it is (on the Samsung) my lumia barely gets 2 bars of signal and regularly get 'no service'

    Anyone else had these problems?
    01-12-2013 08:52 AM
  2. J Hisham's Avatar
    Have you tried to take out the sim card and rubbing the chip, then putting it back in?
    01-12-2013 09:04 AM
  3. Robbie95's Avatar
    no, its a new sim but i'll try it
    01-12-2013 09:40 AM
  4. 11B1P's Avatar
    Is the phone in a case or naked?
    01-12-2013 09:43 AM
  5. Robbie95's Avatar
    Its got a silicone case, but it does it when its off aswell

    Just cleaned the sim, no difference
    01-12-2013 09:49 AM
  6. J Hisham's Avatar
    Just cleaned the sim, no difference
    Maybe you can try to do a soft reset on the phone. Not sure of the method on the 820, though. On the 920, you'd need to hold down the volume down button + power button until the phone turns off and vibrates. Not sure if it's the same method with the 820.
    01-12-2013 10:10 AM
  7. acousticpoem's Avatar
    I have the same problem. On o2 and signal is never very stable and often people say my voice breaking up yet they are very clear to me. Old Nokia C7 never had this problem on same network
    Last edited by acousticpoem; 01-12-2013 at 10:31 AM.
    01-12-2013 10:16 AM
  8. budney's Avatar
    Different OSes and manufactures can calibrate signal bars differently. I would only worry about the issue like in the case of acousticpoet where calls are breaking up and/or dropping.
    Sent from my RM-824_nam_att_101 using Board Express
    01-12-2013 09:58 PM
  9. adamski777's Avatar
    what it will be is your cheapo pay as you go phone will be on 2G, whereas the likelihood is that your 820 is on 3G with poor reception. if you want to make sure go to settings, mobile network and change the highest connection speed option to 2G and you will get the same reception as the PAYG handset
    01-13-2013 07:07 AM
  10. Perus's Avatar
    I hate to be pessimistic about this issue but I truly believe it's something wrong with the antenna design of the 820. It's not about the bars but more the signal received by the phone. I've compared the 820 with the GS3 and IP5 and most of the time the signal strength on 3G is about 10db worse on the 820 :( and that's with the same SIM and location too.

    /Per
    01-13-2013 08:07 AM
  11. budney's Avatar
    I hate to be pessimistic about this issue but I truly believe it's something wrong with the antenna design of the 820. It's not about the bars but more the signal received by the phone. I've compared the 820 with the GS3 and IP5 and most of the time the signal strength on 3G is about 10db worse on the 820 :( and that's with the same SIM and location too.

    /Per
    How do you get to see the signal level in db on the 820?
    Sent from my RM-824_nam_att_101 using Board Express
    01-13-2013 11:41 AM
  12. Robbie95's Avatar
    what it will be is your cheapo pay as you go phone will be on 2G, whereas the likelihood is that your 820 is on 3G with poor reception. if you want to make sure go to settings, mobile network and change the highest connection speed option to 2G and you will get the same reception as the PAYG handset
    So what your suggesting is that the signal bars on my phone represent 3G coverage, but not 2G (calls, text etc) I dont have the option to turn on 2G only 3G/4G so I cant really test this. I know it isnt the network so if this becomes a problem then its getting sent back to Nokia.
    01-13-2013 02:21 PM
  13. Perus's Avatar
    How do you get to see the signal level in db on the 820?
    Sent from my RM-824_nam_att_101 using Board Express
    In field test mode available on some roms by dialing ##3282# and then pick wcdma for 3G measurements. See picture.
    imageuploadedbywpcentral-fo1358142866.042273.jpg

    Note! Please be careful in those menus and it could also be that you're comparing 2G with 3G signal strength as previous poster mentioned.

    Good luck!

    /Per
    Last edited by Perus; 01-14-2013 at 01:21 AM.
    budney likes this.
    01-13-2013 11:54 PM
  14. budney's Avatar
    In field test mode available on some roms by dialing ##3282# and then pick wcdma for 3G measurements. See picture.


    Note! Please be careful in those menus and it could also be that you're comparing 2G with 3G signal strength as previous poster mentioned.

    Good luck!

    /Per
    Ah ok! I can't get there on my AT&T 820. :-(
    01-14-2013 10:44 AM
  15. adamski777's Avatar
    on my 820 you dial ##3282 (without the final # at the end). be careful though, I was playing around with this and my wifi stopped working, luckily I remembered what I changed and put it back.
    budney likes this.
    01-14-2013 11:52 PM
  16. Sahar_Lumia's Avatar
    Hi,
    I have the same prob with my lumia 920. no signal, sometimes only 1 or 2. The problem is that it was fine foe one month then suddenly it happened !
    03-31-2013 01:40 AM
  17. Perus's Avatar
    Issue solved by returning the device and bought a new 820 from another store a month later. It might have been a lemon or a first batch issue. Signal reception on 3G/UMTS on par now :)
    04-11-2013 05:28 AM
  18. cyb0rg9000's Avatar
    apparently verizon has locked down the field test. can't view all the stats including the dB checker. any apps out there that can check the decibel levels?
    09-11-2013 02:00 PM

Similar Threads

  1. Replies: 2
    Last Post: 01-03-2013, 12:33 PM
  2. Possible problem with Lumia 822 pre-order.
    By kiteless in forum Windows Phone 8
    Replies: 6
    Last Post: 11-13-2012, 02:38 PM
  3. Replies: 11
    Last Post: 02-24-2012, 02:11 PM
  4. WiFi Antenna Problems - Now with pictures
    By HeyCori in forum HTC TITAN
    Replies: 2
    Last Post: 12-05-2011, 10:04 PM
  5. Replies: 16
    Last Post: 06-09-2011, 06:20 PM
LINK TO POST COPIED TO CLIPBOARD