1. Muralidharan Nandagopan's Avatar
    I had a problem with lumia 820. Battery was shown as 20% and it said good bye -switched off while using. When switched on again it showed battery symbol to charge the phone. I dont know how the **** it happened.Does any one has the same problem ???
    02-17-2013 12:19 PM
  2. Microsoftjunkie's Avatar
    I had a problem with lumia 820. Battery was shown as 20% and it said good bye -switched off while using. When switched on again it showed battery symbol to charge the phone. I dont know how the **** it happened.Does any one has the same problem ???
    I had a similar problem pre-portico with my 8x. The battery bar always showed different readings when I would cut off and on the phone.

    Do you have Portico?
    02-17-2013 12:24 PM
  3. johnfishcurtis's Avatar
    Having problems with my 920. Plug it into the charger when about 20%, the screen does its usual dim after a few seconds and then turns off. The phone is actually turning itself off and needs a soft reset to turn on.
    02-17-2013 12:25 PM
  4. Muralidharan Nandagopan's Avatar
    Yep.. Phone is up to date now
    Last edited by Muralidharan Nandagopan; 02-17-2013 at 01:07 PM.
    02-17-2013 12:43 PM
  5. Microsoftjunkie's Avatar
    Yep.. Phone is up to date now
    Did you hard reset after Portico or Completely drain, to the point of no response from pushing the power button?
    02-17-2013 01:14 PM
  6. Muralidharan Nandagopan's Avatar
    I just now bought it 6 hours back... it showed 32% .. Then i surfed for sometime downloaded few apps... showed 20% .. but switched off . now i left it for charging
    02-17-2013 01:46 PM
  7. eReS's Avatar
    where did you check remaining percentage? in the system menu or in the external application?
    02-18-2013 03:56 AM
  8. Muralidharan Nandagopan's Avatar
    external application- Battery saver .. But even the system menu showed the same
    02-18-2013 11:48 AM
  9. Ixolite's Avatar
    Had something similar. I think the battery indicator is somewhat off when near full and near empty - it can stay at 100% for couple hours before it starts dropping, and similarly, it can show about 20% when in reality it is nearly depleted.

    Last time it happened to me phone turned off and when I turned it back on the battery indicator just stayed at 0% until charged for about half an hour or so.

    I do have the battery saving turned on in system settings tho not sure if it has anything to do with this.
    02-18-2013 02:35 PM

Similar Threads

  1. Replies: 14
    Last Post: 11-27-2012, 04:23 PM
  2. Replies: 9
    Last Post: 11-15-2012, 12:06 AM
  3. Possible to switch off LTE?
    By tronious in forum Nokia Lumia 920
    Replies: 0
    Last Post: 11-11-2012, 08:07 PM
  4. Battery really overheated, and it was a religous experience...
    By snowmutt in forum Samsung Focus S 4G
    Replies: 6
    Last Post: 10-16-2012, 03:29 PM
  5. Can you switch off LTE?
    By Mr_pither in forum Nokia Lumia 900
    Replies: 5
    Last Post: 03-28-2012, 10:33 AM
LINK TO POST COPIED TO CLIPBOARD
";