1. sdoca's Avatar
    Hi,

    I updated my Lumia 820 last night to 8.0.10211.204 and now my battery is draining super fast. I haven't installed any new apps or manually changed any settings (maybe the update did something I'm not aware of). Before the update, I would normally have 50% battery left at the end of day before plugging it in to charge overnight. It isn't even noon yet and I'm down to 21%.

    Anyone else experience this after upgrading? Any thoughts on what's sucking my battery dry so fast?

    Thanks!
    03-27-2013 01:01 PM
  2. fwaits's Avatar
    Try a reboot and see if the problem goes away. Sometimes after an update OS/app I've seen some oddities, but a reboot usually squares it away.
    03-27-2013 01:08 PM
  3. sdoca's Avatar
    I did a reboot, but did another one. It's charging now, so won't really be able to see if that clears it until tomorrow when it "starts fresh". I did notice that it was running hot as well before the reboot and it's cool now. So hopefully that solves the issue.
    03-27-2013 02:09 PM
  4. GraemeT's Avatar
    I've been running this version on my 820 for a while and haven't experienced your problem. Do a soft reset, perhaps?
    03-27-2013 03:14 PM
  5. carborg's Avatar
    I updated the phone to the 1308 firmware update and Battery is nice, which firmware are you on?
    04-01-2013 12:39 AM
  6. Luiskp's Avatar
    Hi Guys!

    My L820 gets 40% Batt drain in the night when I'm not using it! (from 10 p.m. to 6 a.m.) Even gets discharged (same rate) when doesnt have a SIM card, so there is no data or anything.

    Any ideas?

    I have also a Xperia P, and without SIM gets discharged like 3% all day.
    04-01-2013 10:03 AM
  7. palandri's Avatar
    Threads merged
    Luiskp likes this.
    04-01-2013 10:18 AM
  8. carborg's Avatar
    Hi Guys!

    My L820 gets 40% Batt drain in the night when I'm not using it! (from 10 p.m. to 6 a.m.) Even gets discharged (same rate) when doesnt have a SIM card, so there is no data or anything.

    Any ideas?

    I have also a Xperia P, and without SIM gets discharged like 3% all day.
    Did you disable some background task ? Go to system, swipe left to "applications", tab background task and select which you do not allow.

    Also, "Location" on our device is also a heavy juice eater... try turn it off when you do not use it.
    04-03-2013 08:13 PM

Similar Threads

  1. Replies: 3
    Last Post: 01-16-2013, 10:56 AM
  2. Replies: 3
    Last Post: 01-03-2013, 07:03 PM
  3. Update on battery drain issue with Portico
    By xenoglyph in forum Nokia Lumia 920
    Replies: 3
    Last Post: 12-23-2012, 04:40 AM
  4. Battery Drains from 71% to 14% Overnight!
    By generalsu in forum Nokia Lumia 920
    Replies: 28
    Last Post: 12-20-2012, 02:11 AM
  5. Replies: 5
    Last Post: 11-20-2012, 12:16 AM
LINK TO POST COPIED TO CLIPBOARD