Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

2015 machine in 2017?

Surface 3 still holds its own in 2017

Let Kodi cut your cord

You should be using Kodi for Windows 10

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. mikejones2000's Avatar
    Member

    Posts
    19 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    I'm having trouble getting my phone to connect to my wireless router at home. No matter what I try it says "invalid password." I even tried removing the password from my router. I can connect to other wifi just fine, my laptop is still connecting no problem. Any other ideas?

    Router is Linksys WRT54GL
  2. Blkacesvf41's Avatar
    Member

    Posts
    1,167 Posts
    Global Posts
    60 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Quote Originally Posted by mikejones2000 View Post
    I'm having trouble getting my phone to connect to my wireless router at home. No matter what I try it says "invalid password." I even tried removing the password from my router. I can connect to other wifi just fine, my laptop is still connecting no problem. Any other ideas?

    Router is Linksys WRT54GL
    Have you tried changing your router's security settings? Some devices just won't play nice with WPA settings but will work just fine with WPA2. I had to do this change when I got my Nexus 7, so it's worth the shot.
  3. mikejones2000's Avatar
    Member

    Posts
    19 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #3  
    I was using WPA2 already. I tried WEP and WPA and even disabled security but got the same message.
  4. WinDude's Avatar
    Member

    Posts
    18 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    My advice, although admittedly a bit of a pita, is to disable wep/wpa, and filter on MAC addresses. Added benefit is you do not have any SSL overhead, and don't have to remember any passwords. It's pretty easy to do on most wireless routers.
  5. jg45's Avatar
    Member

    Posts
    4 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    I have had this happen a couple of times. Rebooting the phone seems to take care of it for me.
    mikejones2000 likes this.
  6. Blkacesvf41's Avatar
    Member

    Posts
    1,167 Posts
    Global Posts
    60 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #6  
    @mikejones
    After changing the security settings, did you try connecting any of your other devices to the network? Did it connect? I'd try after changing the security settings to reboot both your phone and the router and start fresh.
  7. falconrap's Avatar
    Member

    Posts
    356 Posts
    Global Posts
    893 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    Quote Originally Posted by WinDude View Post
    My advice, although admittedly a bit of a pita, is to disable wep/wpa, and filter on MAC addresses. Added benefit is you do not have any SSL overhead, and don't have to remember any passwords. It's pretty easy to do on most wireless routers.
    This leaves the network vulnerable to sniffers that can pick up the MAC address, which can then be used to spoof a device and get access to the network. Not a great idea, unless you live in the boonies and don't anticipate any hackers living near you.
  8. mikejones2000's Avatar
    Member

    Posts
    19 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #8  
    Quote Originally Posted by jg45 View Post
    I have had this happen a couple of times. Rebooting the phone seems to take care of it for me.
    thanks, this did the trick. Leaving the security off is out of the question, I live in an apartment with dozens of people that could possibly connect. I did try that just to see if I could connect though.
  9. 1martini's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    I've reset the wireless network, rebooted the router, changed the passwords and network keys, tried both WPA and WPA-2 and rebooted my phone multiple times. The phone still tells me that the phone can't reach the Wi-Fi network. I've never had any trouble connecting any devide (iPhone, laptops, Kindle products, Android) to this wireless network. So freaking frustrated! Any assistance would be much appreciated.
  10. Lee B's Avatar
    Member

    Posts
    142 Posts
    Global Posts
    231 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    Does this phone connect to other secure WiFi networks? If it does, there must be something going wrong with the handshake. If not, it sounds like a bad phone. I haven't had any problem with WiFi connectivity, and best I can tell it's not a common problem, so it could well be hardware related.
  11. Marcos Hidalgo's Avatar
    Member

    Posts
    102 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    I'm having the same problem with a belkin router. Weird thing is it was working fine up until the afternoon now all the HD7's, iPod Touch 4, and laptops can connect with no problem. I've rebooted several times but no luck.

Similar Threads

  1. Replies: 0
    Last Post: 05-01-2012, 06:55 AM
  2. Replies: 15
    Last Post: 11-22-2011, 11:30 AM
  3. Connect to wireless network using certificate
    By mapexvenus in forum Windows Phone 7
    Replies: 1
    Last Post: 11-07-2011, 11:26 AM

Posting Permissions