Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. RedV412's Avatar
    Member

    Posts
    6 Posts
    Global Posts
    14 Global Posts
       #1  
    I got one of these and if you can stand the bulk it works great for protection but I plan to return after I get back because the back button is less responsive at times and I can't figure it out. Doesn't happen when I take the case off, ever. Tried putting a folded piece of paper under the phone to see if it was a gap on the screen protection but doesn't seem to help.

    Anyone have one and notice it on the 822? Ideas? Probably swap for Incipio if I don't figure it out.
  2. #2  
    That's really odd. I didn't have any such problem with the OtterBox I have. I've switched to the Incipio Feather case for now, though.
    - Rich


    WPCentral.com | WPCentral Store | Mobile Nations Forum Rules

    Join Bing Rewards and get rewarded - and get me a few bonus points!
  3. #3  
    Quote Originally Posted by RedV412 View Post
    I got one of these and if you can stand the bulk it works great for protection but I plan to return after I get back because the back button is less responsive at times and I can't figure it out. Doesn't happen when I take the case off, ever. Tried putting a folded piece of paper under the phone to see if it was a gap on the screen protection but doesn't seem to help.

    Anyone have one and notice it on the 822? Ideas? Probably swap for Incipio if I don't figure it out.
    I have that exact same problem, so I just turned on high sensitivity
  4. RedV412's Avatar
    Member

    Posts
    6 Posts
    Global Posts
    14 Global Posts
       #4  
    Thanks, that seems to work! Heard the battery drains faster with that setting but so far it works fine for me.
  5. mbar9607's Avatar
    Member

    Posts
    18 Posts
    Global Posts
    919 Global Posts
    #5  
    call otterbox and let them know of the issue

Similar Threads

  1. Power button not working
    By NejcZ in forum Samsung Omnia 7
    Replies: 6
    Last Post: 05-25-2013, 10:43 PM
  2. Physical Keybaord, Some Buttons Not Working?
    By jiffffy pop in forum Dell Venue Pro
    Replies: 4
    Last Post: 09-22-2012, 07:14 AM
  3. Camera button not working after tango
    By hossiam in forum Nokia Lumia 900
    Replies: 6
    Last Post: 08-04-2012, 10:07 AM
  4. Random data pauses/freezes/not working?
    By yeahbuddy78 in forum HTC TITAN II
    Replies: 9
    Last Post: 06-17-2012, 03:17 PM

Posting Permissions