Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1. jfa1's Avatar
    Member

    Posts
    2,330 Posts
    Global Posts
    2,409 Global Posts
       #1  
    Pocketnow says that the Nokia Lumia 900 with ATT LTE is at the FCC for approval. It also states that the 1700 band used for LTE may also be able able to carry HSPA* on that band as well opening the door for TmO as well.
    Your smartphone is only as smart as YOU let it be!
  2. toyotast165's Avatar
    Member

    Posts
    97 Posts
    Global Posts
    1,007 Global Posts
    #2  
    awesome!
  3. invisik's Avatar
    Member

    Posts
    66 Posts
    Global Posts
    83 Global Posts
    #3  
    The T-mobile scenario is interesting.... I still think I want LTE though.

    -m
  4. toyotast165's Avatar
    Member

    Posts
    97 Posts
    Global Posts
    1,007 Global Posts
    #4  
    At&t rep told me that they don't plan on updating to lte in my area till 2014. Lte is not exactly a selling point for me. Plus if its unlocked you won't have to deal with at&t's pathetic updating process

    -- Sent from my Palm Pre3 using Forums
  5. jfa1's Avatar
    Member

    Posts
    2,330 Posts
    Global Posts
    2,409 Global Posts
       #5  
    Supposedly noy in my area until sometime late 2012 or first half of 2013. Nice to have but not if Apollo backwards compatability is still in doubt. They need to clear that up nobody is going to want to buy a current device on contract and be without Apollo updated device for a year to a year and a half.
    Your smartphone is only as smart as YOU let it be!
  6. jimski's Avatar
    Member

    Posts
    2,254 Posts
    Global Posts
    2,259 Global Posts
    #6  
    Not going to stop me. And of so (which I am sure it isn't) it would give me, and several million other 900 users something to complain about for 18 months. Not a pretty picture.


    Sent from my HTC Surround using Board Express
    Nokia Lumia 900 - OS: 7.10.8112.7 - Firmware: 2175.1002.8112.12084
    HTC Surround - OS: 7.10.8107.79 - Firmware: 2250.21.40500.502
  7. #7  
    Quote Originally Posted by jfa1 View Post
    Supposedly noy in my area until sometime late 2012 or first half of 2013. Nice to have but not if Apollo backwards compatability is still in doubt. They need to clear that up nobody is going to want to buy a current device on contract and be without Apollo updated device for a year to a year and a half.
    Think how we must feel in Canada. Here you have to sign a 3-year term to get a decent subsidy

Posting Permissions