The king is back baby!

Resident Evil 7: Biohazard Review — a series risen from the dead

Fitness Apps

Keep your New Year's fitness resolutions with these great Windows 10 apps!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

Get ready for beta!

Halo Wars 2 Blitz: Game modes, beginner's tips, and more

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. gtbuzz's Avatar
    Member

    Posts
    163 Posts
       #1  
    I just had to figure out how to do this again and it was confusing, so I figured I'd post it to help people out.

    A while back on my Focus I noticed that when I would delete emails, they wouldn't show up in the trash on Gmail. I believe this has to do with the general philosophy behind Gmail in that email archival takes precedence over deletion. So, by default, when you delete mail, it gets archived (essentially the inbox label gets taken off and you can find those messages in All Mail instead of Inbox in Gmail) instead of sent to trash. Seems like it's that way on other platforms too, but I think iOS added an option for deletion/archival in iOS5.

    That happens to drive me nuts because if I think it's worthy of trash, I never want to see it again. To fix this behavior, on your phone, go to m.google.com and you'll see a list of mobile products. Select the Sync product.

    Within Sync, you'll see a list of devices. This page seems a little buggy in that I've never figured out how to delete an old device and identifying devices seems to be a little tricky. If you've only got one Windows Phone, it's pretty easy. If you have multiples or have had multiples, it can get a little confusing (I've had the Dell Venue Pro, Focus and now the L900). They're all listed as Windows Phone. The way you tell them apart is by the "Last sync" date, which is not the date that gmail last synced with that device, but instead when that device was first hooked up to Google services.

    Select the device you want to change, and you'll see options for enabling send mail as as well as, delete email as trash. There are also options for syncing additional calendars within there as well, as I don't think it does it by default.

    Kind of dumb that the "fix" is so hard to find (and not very well published either), but there it is. I hope that saves someone else from the many hours of frustration I had.
    shalgrim and karmamule like this.
  2. diegosalinas's Avatar
    Member

    Posts
    43 Posts
    Global Posts
    52 Global Posts
    #2  
    THANK YOU!

    This was driving me nutty all this time.

    I will try these steps tonight.
  3. CHPro's Avatar
    Member

    Posts
    28 Posts
    #3  
    Quote Originally Posted by diegosalinas View Post
    THANK YOU!

    This was driving me nutty all this time.

    I will try these steps tonight.
    Thank you, will save me a few hours of searching when I get mine sunday. I HATED this on my iphone. I stopped deleting them and would just hit move and select trash.
  4. Dorknight's Avatar
    Member

    Posts
    23 Posts
    Global Posts
    104 Global Posts
    #4  
    I tried this twice, to make sure I had it working, and it's not working. :mad:

    This is quite annoying... anyone else notice it not working?
  5. karmamule's Avatar
    Member

    Posts
    190 Posts
    Global Posts
    681 Global Posts
    #5  
    Quote Originally Posted by Dorknight View Post
    I tried this twice, to make sure I had it working, and it's not working. :mad:

    This is quite annoying... anyone else notice it not working?
    It worked for me, though I had to trigger a sync again before it actually did the delete over on the gmail inbox.
  6. Dorknight's Avatar
    Member

    Posts
    23 Posts
    Global Posts
    104 Global Posts
    #6  
    I got it to work. I was using an 'Advanced Setup' account, for this very reason before the fix. I had to delete that one, and just enabled Email syncing on my normal Google account, which I was using just for calendar and contacts. :)
  7. Jakoh's Avatar
    Member

    Posts
    531 Posts
    Global Posts
    532 Global Posts
    #7  
    you never really quite delete them. they remain on Google's magnetic tapes somewhere for them to be summoned by warrants.
  8. wamsille's Avatar
    Banned

    Posts
    544 Posts
    Global Posts
    693 Global Posts
    #8  
    Quote Originally Posted by Jakoh View Post
    you never really quite delete them. they remain on Google's magnetic tapes somewhere for them to be summoned by warrants.
    Or you could live out your life online like Eric Schmidt had said at one point and just never put anything out on the internet you don't want people to know about.

Posting Permissions