We made some changes

Our new forums are here!

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 27
  1. dcrogers25's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Am I the only one who hasn't had any data issues and battery is phenomenal. I have had ZERO issues. Just curious
  2. jimski's Avatar
    Member

    Posts
    2,254 Posts
    Global Posts
    2,259 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    My data is working perfectly. And still a little too soon on battery, but so far it appears to be providing the 7 hours talk/uptime it claims to. Need another week for definitive info. But leaps and bounds over my Surround and its teeny 1230mAh battery.

    Sent from my Lumia 900 using Board Express
  3. Laura Knotek's Avatar

    Posts
    25,685 Posts
    Global Posts
    47,788 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    I picked up my device on Monday morning, and I have not had any data issues since then. I am in Cleveland, OH, which still only has HSPA+, not LTE.
  4. Laura Knotek's Avatar

    Posts
    25,685 Posts
    Global Posts
    47,788 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    Quote Originally Posted by jimski View Post
    My data is working perfectly. And still a little too soon on battery, but so far it appears to be providing the 7 hours talk/uptime it claims to. Need another week for definitive info. But leaps and bounds over my Surround and its teeny 1230mAh battery.

    Sent from my Lumia 900 using Board Express
    I really cannot comment on "talk time", since I rarely talk on the phone.

    However, I have not had battery issues despite streaming audio and Netflix.
  5. jimski's Avatar
    Member

    Posts
    2,254 Posts
    Global Posts
    2,259 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    Quote Originally Posted by lak611 View Post
    I really cannot comment on "talk time", since I rarely talk on the phone.

    .
    Nor do I. But I have found that "talk" and "screen on time" consume about the same amount of power. So 7 hours is 7 hours. What I have not had a a chance to analyze (cause I am using the pone so much) is idle time. When the screen is off. That can make or break battery performance. Should only be 1-2% per hour idle.

    Sent from my Lumia 900 using Board Express
  6. the_thunderbird's Avatar
    Member

    Posts
    153 Posts
    Global Posts
    341 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #6  
    So far so good for me, into the end of day three with Rogers.

    Data is good, pictures are solidly okay, phone is uber responsive and an absolute pleasure to use. And even just look at on my desk at work! :)
  7. mdelacoma's Avatar
    Member

    Posts
    51 Posts
    Global Posts
    85 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    Battery life is excellent for me.

    As for the data issue, I haven't had any problems except in the ESPN app. For example, when I load the app and press on a score for one of the games in progress it takes me to the live feed. When I hit the back arrow to go back to the scores page I often (actually almost always) get a message that says something to the effect of 'data is slow right now' and asks to 'press here' to reload. It's fine once I do though

    Other than that I am extremely pleased with this phone. Especially since I'm getting $100 off my AT&T bill (smile)
  8. iskoisko's Avatar
    Member

    Posts
    11 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #8  
    everything on my Lumia 900 is 100% fine. i get the battery drained quickly every time I'm at home, and I'm pretty sure it has to do with the Microcell that I have. everything else is fine and working and I'm enjoying the phone so much. i gave up my iPhone 4s for the Nokia Lumia 900 and imho, it's so worth it!
  9. TMavC5's Avatar
    Member

    Posts
    650 Posts
    Global Posts
    846 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    No problem here.

    Sent from my Lumia 900 using Board Express
  10. toyotast165's Avatar
    Member

    Posts
    111 Posts
    Global Posts
    1,021 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    my only problem so far is data from WiFi locking up, took a couple days to start screwing with me, ah well the update is a coming. Battery life has been awesome, I can make it a full day! I cannot remember a phone that did that for me...if I even ever had one at all
  11. NorCalGuy's Avatar
    Member

    Posts
    9 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    I received my phone on Friday as a pre-order and have had no problems with anything
  12. hasasimo's Avatar
    Member

    Posts
    1,916 Posts
    Global Posts
    2,122 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    So far, so good. I use my Lumia 900 on an MVNO, getting HSPA+ speeds. I was worried about battery life earlier today, but my phone soldiered on and here we are at 3am, still got 15% left. It's been 1 day and 2 hours since my last charge according to the battery saver screen. Still too early to judge battery for certain though.

    My only issue is not being able to use MMS, but that has to do with the OS, not the handset. There's no way to customize MMS settings in WP7 and the only third party app that would do it, Nokia Network Setup, has been taken down :(

    Wifi got slow at one point at work but our network is hit or miss. I don't think it was the phone. It didn't completely stop, just started going slower.

    As for data issues, I don't think anyone on an MVNO is having the issue. Only people using their Lumias on AT&T.
  13. tbonecopper's Avatar
    Member

    Posts
    117 Posts
    Global Posts
    229 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    No problems myself. Getting used to the quirks of WP7 :P

    While I've had a HTC Surround since they were released, it wasn't my main phone... my previous phone, iPhone 4 is a lot diff.

    I can't say I have issues with the Lumia tho. I love it thus far. AT&T needs to turn on LTE in Jacksonville, FL tho!!!!
  14. choover's Avatar
    Member

    Posts
    17 Posts
    Global Posts
    21 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #14  
    zero issues with mine. Battery is lasting 8am to 11pm (hitting about 20% at 11pm) all while I'm using the phone a lot since it's still new to me.

    zero issues with data

    Phone has been stellar! A much better experience then android so far.
  15. Blackwood504's Avatar
    Member

    Posts
    153 Posts
    Global Posts
    157 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #15  
    Have any of you had the "pocket to camera" fuction work 100% of the time? Also can you use voice command through your headset?
  16. LordGreylock's Avatar
    Member

    Posts
    152 Posts
    Global Posts
    197 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #16  
    Mines been working great. I did notice after restarting the phone it didn't want to connect to Wifi right away. Other than that no other problems and the battery has been great, on par if not better than my iPhone 4S battery.
  17. jlw17's Avatar
    Member

    Posts
    64 Posts
    Global Posts
    79 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #17  
    Mine's been working like a dream!
    Preordered and got mine on Friday. Been using it in the Knoxville,TN and Williamsburg,KY areas
    =]
  18. AndreaCristiano's Avatar
    Member

    Posts
    346 Posts
    Global Posts
    388 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #18  
    Mine is 100% like it should!
  19. larrynj's Avatar
    Member

    Posts
    278 Posts
    Global Posts
    305 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #19  
    No issues here on day 7! :)


    Quote Originally Posted by Blackwood504 View Post
    Have any of you had the "pocket to camera" fuction work 100% of the time? Also can you use voice command through your headset?
    What is pocket to camera?
  20. CDG
    CDG is offline
    CDG's Avatar
    Member

    Posts
    304 Posts
    Global Posts
    2,003 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #20  
    Everything is as it should be on mine.
  21. MrTimSmith's Avatar
    Member

    Posts
    67 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #21  
    Mine works perfectly. No complaints.
  22. Blackwood504's Avatar
    Member

    Posts
    153 Posts
    Global Posts
    157 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #22  
    Quote Originally Posted by LarryNJ View Post
    No issues here on day 7! :)




    What is pocket to camera?
    That's when you hold the camera button down, while the phone is sleep/standby, to start the camera with out having to unlock your phone. It should take a second for the phone to vibrate then the the camera opens and you snap your pictures or video.

    For me it may work 2 out 5 times...Same thing with voice dialing from an headset, only it never works. Seems like the phone doesn't recongize any inputs from the head set unless the phone is awakened.
  23. larrynj's Avatar
    Member

    Posts
    278 Posts
    Global Posts
    305 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #23  
    Quote Originally Posted by Blackwood504 View Post
    That's when you hold the camera button down, while the phone is sleep/standby, to start the camera with out having to unlock your phone. It should take a second for the phone to vibrate then the the camera opens and you snap your pictures or video.

    For me it may work 2 out 5 times...Same thing with voice dialing from an headset, only it never works. Seems like the phone doesn't recongize any inputs from the head set unless the phone is awakened.
    oh..I just tried mine, it woks good not hooked up to anything. Tried it with the USB plugged into my computer and nothing.
  24. TMavC5's Avatar
    Member

    Posts
    650 Posts
    Global Posts
    846 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #24  
    Well damn. My data just now stop working. I'm using my hotspot mobile from work to write this message. Grrrr

    Sent from my Lumia 900 using Board Express
  25. iLumia's Avatar
    Member

    Posts
    2 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #25  
    Everything is cool on mine. (And, if it's good for The Woz, it's good for me!)
Page 1 of 2 12 LastLast

Posting Permissions

";