1. Jomon's Avatar
    My 2nd 900 seem to be much worse than my first :

    1) Data connection lost on day 4 (fixed with the update)
    2) Dead or stuck pixel on screen
    3) Buttons acting up or "sticking" and doing a long press
    4) Can't send and receive text messages (update did not fix this)
    5) Slight but very noticeable hissing sound when streaming audio

    I still love you Nokia.
    04-16-2012 03:38 PM
  2. leosoybean's Avatar
    Did you mess with the "SMS center number" setting for your messaging??
    04-16-2012 03:43 PM
  3. The def star's Avatar
    Honestly no phone is perfect. I went through 3 HTC HD7's when it was first launched till I got one that didn't have any issues with it. The OS is that good that I was willing to stick it out till I got the hardware to compliment the OS. So far with the Lumia I'm still on the 1st one but even if I had to return it to get another one it's no big deal.
    04-16-2012 03:47 PM
  4. Jomon's Avatar
    Did you mess with the "SMS center number" setting for your messaging??
    Nope. Not at all.
    04-16-2012 03:48 PM
  5. Jomon's Avatar
    Honestly no phone is perfect. I went through 3 HTC HD7's when it was first launched till I got one that didn't have any issues with it. The OS is that good that I was willing to stick it out till I got the hardware to compliment the OS. So far with the Lumia I'm still on the 1st one but even if I had to return it to get another one it's no big deal.
    I'm hoping 3rd time will be the charm for me. My local store received a new shipment today (they ran out of stock last week) so I'm hoping this new batch won't have any bad phone. My cousin's and brother's 900 are working flawlessly so I just have to keep trying till I get a good one.
    04-16-2012 03:51 PM
  6. ejb222's Avatar
    Nope...mine works flawlessly...since day one.
    04-16-2012 04:08 PM
  7. davep1982's Avatar
    1.) Happened to me within minutes of activating.

    2.) Haven't had that problem.

    3.) While rare, when it happens its annoying.

    4.) I can.

    5.) That's the sound of the speaker blowing your mind away. You'll get used to it.

    To answer the question: Nope.
    04-16-2012 04:36 PM
  8. jbjtkbw007's Avatar
    I'm actually pretty lucky I guess, but then again, the pains of being early adopters. It's not just mobile devices. TV's, cars, other gadgets, you name it. Can happen anywhere. It's the risk you take.

    Luckily....I'm good. Nothing going on here but the rent (or the monthly service charge in this case.)
    04-16-2012 04:41 PM
  9. bevt's Avatar
    Yes, disappointing. We've had data issues and a lot of trouble using the phone for an echo problem. You can't really back up the phone (unreal with how important phones are to us these days). It is a fledgling OS on a new piece of hardware. I don't think the betaphone marketing was a good idea when you have so many bugs to work out yourself.
    04-16-2012 05:49 PM
  10. Osz's Avatar
    Nope. I am very happy with my Lumia 900.
    04-16-2012 06:13 PM
  11. jimski's Avatar
    No issues. Enjoying my L900

    Sent from my Lumia 900 using Board Express
    04-16-2012 06:16 PM
  12. Frenzytom's Avatar
    I think the word is "early adopter" not beta tester. :)

    My 2nd 900 seem to be much worse than my first :

    1) Data connection lost on day 4 (fixed with the update)
    2) Dead or stuck pixel on screen
    3) Buttons acting up or "sticking" and doing a long press
    4) Can't send and receive text messages (update did not fix this)
    5) Slight but very noticeable hissing sound when streaming audio

    I still love you Nokia.
    04-16-2012 07:50 PM
  13. cckgz4's Avatar
    No thank goodness

    Sent from my Lumia 900 using Board Express
    04-16-2012 07:52 PM
  14. nokia4life's Avatar
    I'm actually pretty lucky I guess, but then again, the pains of being early adopters. It's not just mobile devices. TV's, cars, other gadgets, you name it. Can happen anywhere. It's the risk you take.

    Luckily....I'm good. Nothing going on here but the rent (or the monthly service charge in this case.)
    definitely with cars just go to the 2011 charger forums my R/T had all kinds of electrical issues we have had recalls on the door handles but still to good to let go lol... early adopters are beta testers.
    04-16-2012 07:54 PM
  15. hellomiggy's Avatar
    The best thing one can do, if you feel is weird. Is to restore your Device. I restored my iPhone even after doing a fresh upgrade from a Windows machine to a Mac Machine. When I restored with Windows it felt very glitchy. When I restored with a Mac, it felt very smooth.

    Just restore it, or get a new device, like The Ring, "7 DAY'S", but with this one. 30 DAY'S!
    04-17-2012 12:37 PM
  16. jonathanrn's Avatar
    My wife's phone just had a frozen pixel appear a few days ago. We are still within the 30 days at this point. I tried some 'get your stuck pixel unstuck app in the marketplace, but it didn't work (unsurprisingly). What is Nokia's dead pixel policy? The last time I had this problem was maybe 6 years ago and each manufacturer allowed a certain number of them before they would accept it as a return. Do you think I would get stuck with a return fee?

    Jonathan
    04-23-2012 09:16 PM
  17. pecuevasb's Avatar
    I updated and still can get any data connection. Everything else works fine, but I can't get data. I want to believe it's that I never switched to an LTE plan and just activated the micro-SIM? I don't want to exchange it.
    04-24-2012 01:52 AM
  18. nascarnate326's Avatar
    Years ago when iPhone launched seems like I got a new one every two weeks because they were just junk. Finally got one that did MOST things good and kept it for a while.

    Very happy with my phone so far.
    04-24-2012 06:03 AM
  19. quek9's Avatar
    All three phones have been working flawlessly.
    04-24-2012 07:48 AM
  20. invertme's Avatar
    My 2nd 900 seem to be much worse than my first :

    1) Data connection lost on day 4 (fixed with the update)
    2) Dead or stuck pixel on screen
    3) Buttons acting up or "sticking" and doing a long press
    4) Can't send and receive text messages (update did not fix this)
    5) Slight but very noticeable hissing sound when streaming audio

    I still love you Nokia.

    1) Fixed so quickly and the hundred dollar credit make me overlook this one.
    2) Manufacturing problems happen. That's unavoidable - just return the phone for a new one
    3) That does seem to be a legit bug - I hope it's fixed soon!
    4) This is probably a carrier issue. I would have them look into it
    5) I don't have this at all - weird...

    Probably best to swap out your phone for a new one and have the carrier check your texting plan.

    Except for lag issues my 900 is perfect. :) I am sure Nokia will make everything right for you.
    04-24-2012 08:09 AM
LINK TO POST COPIED TO CLIPBOARD