Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. TMavC5's Avatar
    Member

    Posts
    609 Posts
       #1  
    Anyone have this BT headset? I want your opinion with Lumia 900. Please chime in ... Thanks!

    Price dropped almost 40 dollars on this one, seen here on Amazon.

    Amazon.com: Jawbone ERA Headset - Midnight - Retail Packaging: Cell Phones & Accessories

    Thanks
  2. jhoff80's Avatar
    Member

    Posts
    1,083 Posts
    Global Posts
    8,062 Global Posts
    #2  
    I have one and it works fine. However, there's only one actual button. This means you can't control your music with it.

    Secondly, it doesn't have volume buttons, so you just hold the button for a while and the volume slides up and down, which is pretty annoying.

    Finally, if you're using TellMe with it, you have to hold the button for a second, and then it'll make a special beep to signify it sent the command, and then it takes another second, and then you get the TellMe prompt.
    Thanked by:
    TMavC5 
  3. jbjtkbw00#AC's Avatar
    Member

    Posts
    319 Posts
    Global Posts
    636 Global Posts
    #3  
    I don't have this one, but I have the Icon which is very similar. Works fairly well. Can't complain.
  4. tombeck's Avatar
    Member

    Posts
    2 Posts
    #4  
    I have these two devices and they don't like each other at all. Either the sound I hear is very choppy, or the sound the other person hears is very choppy, or neither of us hears anything at all. Sometimes it works just fine, but a lot of times it doesn't, so that I hesitate to use the headphone, as often this means I have to hang up and call back without the headset because communication is impossible. I haven't found a solution yet.

Posting Permissions