1. kregstrong's Avatar
    I'm starting to have those data problems again, where it won't connect, this sucks. any suggestions? I've already done the update

    Sent from my Lumia 900 using Board Express
    04-19-2012 05:16 PM
  2. nokia4life's Avatar
    take it back to a corp store and exchange it i don't know what else to say i didn't have the data problems before or after the update. but sounds like you need to exchange the device if it still has issues afterwards.
    04-19-2012 06:41 PM
  3. danwc's Avatar
    I too was fine before the update and all messed up now. Emails not sending,not being received. I went in to store today and they tried a new sim. That hasn't helped. All seemed to work if I keep WiFi off, but just found out I wasn't receiving texts. Will go back and exchange for a new one. Trying hard to make peace with phones limitations (read: lackluster camera), just when I think I have, this data issue rears its head. Seems to be getting worse. Noticed it tuesday for first time and today.it has been really bad.

    Sent from my Lumia 900 using Board Express
    04-19-2012 06:50 PM
  4. mihesq's Avatar
    Never had data problems before the update, but now I have them all the time, very frustrating. Also have had GPS issues. Not good.

    This is weird, my phone was showing no connection, and I was not connected to a WiFi, yet I was able to post this message.
    04-19-2012 08:57 PM
  5. henilp89's Avatar
    im now having data issues AGAIN damn it after the update. i already swapped my phone once and i updated my new one as soon as their software update came out. it seems to work fine after i reboot the phone for 30 minutes maybe but after 30-45 minutes, data stops working again. i took it back to my at&t store today and they told me that they dont have any left in stock, i can get another phone or check back again tomorrow..
    this really sucks man..
    04-19-2012 09:26 PM
  6. rdubmu's Avatar
    Just a couple of things to check:

    1. Do you have the battery saver on, you can tell by looking at the battery meter icon at the top.
    2. Go into setting for your email, do you have it set up (as items arrive)? Also which email are you not receiving, is it hotmail?
    04-19-2012 10:46 PM
  7. rdubmu's Avatar
    Also it may be an issue with your sim card and not your phone. Maybe see if they can swap out your sim card to see if it will work :)

    Do you also have the correct data plan (4g LTE), this also can cause issues.

    Hope this helps!
    04-19-2012 10:47 PM
  8. jimski's Avatar
    I too was fine before the update and all messed up now. Emails not sending,not being received. I went in to store today and they tried a new sim. That hasn't helped. All seemed to work if I keep WiFi off, but just found out I wasn't receiving texts. Will go back and exchange for a new one. Trying hard to make peace with phones limitations (read: lackluster camera), just when I think I have, this data issue rears its head. Seems to be getting worse. Noticed it tuesday for first time and today.it has been really bad.

    Sent from my Lumia 900 using Board Express
    Fyi, texts come over your voice channel. Turn off WiFi and data, and you still get texts.

    Sent from my Lumia 900 using Board Express
    rdubmu likes this.
    04-19-2012 10:49 PM
  9. rdubmu's Avatar
    Fyi, texts come over your voice channel. Turn off WiFi and data, and you still get texts.

    Sent from my Lumia 900 using Board Express
    I am thinking this is your sim card. Also another trick with Data, put it in airplane mode then take take it out of airplane mode, it registers with the network, and hopefully will make it work :)
    04-19-2012 11:04 PM
  10. DalekSnare's Avatar
    My phone was fine until the update; now I have to switch to and from airplane mode in every LTE area or it stays on HSPA+ forever, even when there are 5 bars of LTE available.

    I never had an issue with no data at all or email though, before or after.
    04-20-2012 12:03 AM
LINK TO POST COPIED TO CLIPBOARD