Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 12 of 12
Like Tree2Likes
  • 1 Post By dkp23
  • 1 Post By socialcarpet
  1. J4rrod's Avatar
    Member

    Posts
    541 Posts
    Global Posts
    544 Global Posts
       #1  
    I do not own a Lumia 900. I was so excited for it before it's launch, and honestly, visiting these forums so much has diminished my love for it greatly. I'm not sure if it's just a lot of people on here complain about little things, and the "bugs" aren't bad and/or affect a very small percentage of the phones (on here, it seems it affects a lot, but that could be because good phones aren't reported on here nearly as much), or what, but I'm getting discouraged.

    So, help me feel better. From what I understand, the following are the "bugs" (post-update):

    Vibration rattle: okay, so whenever someone mentions this, is this what they're talking about?

    - If so, I can confirm that neither my sister's nor my girlfriend's 900 does that. It doesn't sound amazing when it vibrates, but definitely not that.

    Back button/Start button misreads: read where people say that when they tap back/Start, the phone reads that it held it and brings up Tell Me/multitasking.

    - This happens an unforgiveable amount on my Focus S. Never once happened with OG Focus. Does this actually happen on the 900 guys?

    Camera:

    - Okay, so from my own personal experience, I do not think the camera is bad. It's not as good as my Focus S in good-light, however, in low-light conditions sans flash (and oftentimes with flash), it does take better, clearer pictures than my Focus S. It seems to be able, without flash, to use what light is in the room in low-light conditions better. Do you guys think that we think the camera is "bad" because of the Zeiss name on it? Like, what if Nokia didn't put that name on it, do you guys think anyone would really even talk about the camera?

    Camera/volume controls while screen is off: Issue where the volume controls/camera-unlock feature does not work consistently when screen is locked.

    - I can confirm that this is definitely an issue. I tested it with both 900s (gf's and sister's) and both only unlocked with camera button 50% of the time. I have not tested for volume controls, is it the same case with that?

    I'm hoping to compile a list after this discussion is done to send to Nokia US. So, discuss.
  2. dkp23's Avatar
    Member

    Posts
    1,412 Posts
    Global Posts
    1,441 Global Posts
    #2  
    There is a sticky
    jbjtkbw00#AC likes this.
  3. J4rrod's Avatar
    Member

    Posts
    541 Posts
    Global Posts
    544 Global Posts
       #3  
    Quote Originally Posted by dkp23 View Post
    There is a sticky
    That's 100 pages long and a jumbled mess. I'm wanting a straightforward list, that way it will be easier to send it to Nokia.
  4. smoledman's Avatar
    Member

    Posts
    1,275 Posts
    Global Posts
    1,308 Global Posts
    #4  
    The only bug I've had so far is a blank screen on unlock. Pressing the home button again fixed it. This only happened one time.
  5. jbjtkbw00#AC's Avatar
    Member

    Posts
    319 Posts
    Global Posts
    636 Global Posts
    #5  
    Other than there being a dedicated area for this already, the irony is a thread on bugs from a non-owner. No offense, but I work in wireless too and have access to many devices. Doesn't warrant me taking the lead on something like this, however, or starting a separate thread.

    Just sayin.....
  6. socialcarpet's Avatar
    Banned

    Posts
    1,893 Posts
    Global Posts
    1,966 Global Posts
    #6  
    I haven't had a single problem with my Lumia 900. Its been excellent. You will see griping and complaining about any product on the internet. If you read enough forum post about anything, you'd never buy anything.

    Sent from my Lumia 900 using Board Express
    jbjtkbw00#AC likes this.
  7. J4rrod's Avatar
    Member

    Posts
    541 Posts
    Global Posts
    544 Global Posts
       #7  
    Lol, not sure what you're point is. I'm a potential owner, trying to make an informed decision. I wasn't aware that was a bad thing?

    Quote Originally Posted by jbjtkbw007 View Post
    Other than there being a dedicated area for this already, the irony is a thread on bugs from a non-owner. No offense, but I work in wireless too and have access to many devices. Doesn't warrant me taking the lead on something like this, however, or starting a separate thread.



    Just sayin.....

    Sent from my Samsung Focus S using Board Express.
  8. jbjtkbw00#AC's Avatar
    Member

    Posts
    319 Posts
    Global Posts
    636 Global Posts
    #8  
    Quote Originally Posted by J4rrod View Post
    Lol, not sure what you're point is. I'm a potential owner, trying to make an informed decision. I wasn't aware that was a bad thing.
    OK.

    Not a bad thing. Just extra work. Perhaps compiling the information from the already created thread would be more beneficial towards your overall goal vs. recreating the wheel.
  9. PhilR8's Avatar
    Member

    Posts
    216 Posts
    Global Posts
    263 Global Posts
    #9  
    There seem to be 900 owners falling all over the spectrum here: people who have had no problems, people who have had lots of problems, and people whose experience falls somewhere in between those two extremes.

    My experience has been closer to the "lots of problems" side of the spectrum. My device doesn't rattle (the vibrate does sound different than any other phone I've every owned, but I wouldn't describe it as a rattling sound) and my back button has only misread a tap as a hold once or twice. So I don't think my device has those issues.

    However, I am plagued with several others, such as:

    Poor camera performance that includes the pink spot. I'll have to check out some other Lumia 900s on display to see if mine is actually any different, or that the camera is what it is and different people have different definitions of what "poor" means to them. But I can say that the camera on my 900 is not as good as the camera on my fiancee's Epic 4G Touch (Galaxy SII on Sprint).

    Flaky WiFi performance. There is a thread about this, but this seems to be something that is affecting only some 900 owners. Probably not even a majority, but there is an issue with some 900s, including mine.

    Camera shutter button wakes device from sleep some days and not others, seemingly without rhyme or reason. Again, there is a thread dedicated to this issue and not everyone is experiencing it. I wasn't experiencing it, until one day I was. Now, without making any deliberate changes, the problem has disappeared. Hopefully for good.

    Overall I'm very happy with the device and I'm a dyed-in-the-wool WP7 power user. But there are definitely some issues with the 900 that do exist. There are some on this forum that think that since they themselves are not experiencing any issues, that there are no issues for anyone and that people are lying. Let me tell you plainly: I am not lying about any of the issues described above.
  10. charlyee's Avatar
    Member

    Posts
    304 Posts
    Global Posts
    1,843 Global Posts
    #10  
    I am overall very happy with mine. The only issue i have is purple instead of grey in auto under low light conditions.

    Sent from my Lumia 900 using Board Express
    The SmartPhone Parade (2006-Now)
    QTEK 9100 > Samsung Blackjack > Treo 750 > Treo Pro > BB 9700 > Xperia X10 > Motorola Atrix > HTC Vivid > Lumia 900 > Lumia 820
  11. psonio7's Avatar
    Member

    Posts
    8 Posts
    Global Posts
    16 Global Posts
    #11  
    I haven't had any of the issues on the bug list. Got the phone 3 days after launch. Green dot on the box. WiFi works great, phone is solidly built. The back button works fine. Only slight gripe is crappy camera in low light conditions, I'm hoping its fixed in a software update.
  12. jinfluence's Avatar
    Member

    Posts
    13 Posts
    #12  
    Mine is great other than the back button issue. Happens just about everytime I play something over the speaker.

Posting Permissions