We made some changes

Our new forums are here!

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 5 of 5
  1. idahoprime's Avatar
    Member

    Posts
    53 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    I'm on my 3rd 900, a white one this time. My 2 previous cyan's pulled in all my Facebook contacts and all the profile pics. But when I set up this new phone, hardly any of the pics are showing up in my contacts list, maybe 20% of them. Weird. Any suggestions? Should I remove and re link my Facebook account?? Anyone else having this problem? Thanks
  2. TMavC5's Avatar
    Member

    Posts
    650 Posts
    Global Posts
    846 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Quote Originally Posted by idahoprime View Post
    I'm on my 3rd 900, a white one this time. My 2 previous cyan's pulled in all my Facebook contacts and all the profile pics. But when I set up this new phone, hardly any of the pics are showing up in my contacts list, maybe 20% of them. Weird. Any suggestions? Should I remove and re link my Facebook account?? Anyone else having this problem? Thanks
    It takes a bit for it to sync.
  3. idahoprime's Avatar
    Member

    Posts
    53 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #3  
    Quote Originally Posted by TMavC5 View Post
    It takes a bit for it to sync.
    Well, i hear you, but the pics synced immediately with my first 2 phones. and like i said, i have SOME fb pics, just not many at all...
  4. idahoprime's Avatar
    Member

    Posts
    53 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #4  
    Ok nevermind. I unlinked and relinked my Facebook account in the people hub and it solved the problem. All my contacts have profile pics now. Thanks
  5. davidvkimball's Avatar
    Member

    Posts
    8 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    Quote Originally Posted by idahoprime View Post
    I'm on my 3rd 900, a white one this time. My 2 previous cyan's pulled in all my Facebook contacts and all the profile pics. But when I set up this new phone, hardly any of the pics are showing up in my contacts list, maybe 20% of them. Weird. Any suggestions? Should I remove and re link my Facebook account?? Anyone else having this problem? Thanks
    Actually, yes. I am having this problem as well. When I go to a profile in my People hub, even when I allow it to load more, it does not load their profile picture. I have had the Lumia 900 for several weeks now, and it never took that long on my LG Quantum's people hub.

    Any reason for this?

Posting Permissions

";