Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
  1. Nemesis-X's Avatar
    Member

    Posts
    70 Posts
    Global Posts
    129 Global Posts
       #1  
    Is there a way to enable my lumia to get the latest updates directly from Nokia and bypass Rogers completely?
  2. pdjcrawford's Avatar
    Member

    Posts
    45 Posts
    #2  
    Quote Originally Posted by Nemesis-X View Post
    Is there a way to enable my lumia to get the latest updates directly from Nokia and bypass Rogers completely?
    I was able to force the update today for my Rogers Lumia 900. Here's how I did it, based largely on readings here at wpcentral:

    1) put phone on airplane mode -- WiFi and cellular data disabled
    2) disable WiFi on PC/laptop
    3) connect to PC/laptop via ethernet cable
    4) connect to Zune, allow connection to phone
    5) click on "Phone", then "Settings"
    6) click on "Update", and about 1 second after the search for update starts yank out ethernet cable
    7) phone displays that update is available if you have timed it right (I assumed it would be the PC informing you but it was the phone itself)
    8) reconnect ethernet cable to PC/laptop
    9) perform Zune "Update" again and you'll see the update to 8112
    10) follow the 10 step on-screen update process for 8112
    11) the last step of 8112 update is a scan for further updates which will find 8773
    12) follow the 9 step on-screen update process for 8773 (you don't have to "force" this update)
    13) you're done -- the whole process probably takes 50-55 minutes

    Hope it helps. Happy updating to those who don't want to wait for the natural roll-out to reach them.
  3. Nemesis-X's Avatar
    Member

    Posts
    70 Posts
    Global Posts
    129 Global Posts
       #3  
    Well I got it on the first try but when I pressed update the 2nd time it went sour and I can't get back there again. So close : (
  4. pdjcrawford's Avatar
    Member

    Posts
    45 Posts
    #4  
    Try again from start. After plugging the ethernet cable back in just click any other menu item then click "Update" again. Good luck.
  5. Nemesis-X's Avatar
    Member

    Posts
    70 Posts
    Global Posts
    129 Global Posts
       #5  
    It keeps giving me the "Can't check for updates right now. Please try again later" message.
  6. Loiselle's Avatar
    Member

    Posts
    216 Posts
    Global Posts
    270 Global Posts
    #6  
    What if your phone already has 8112?
    Cingular (2001-2003) - Nokia 5190 > Nokia 3360
    Nextel (2003-2007) - i1000+ > i90c > i720 > i830 > i275 > i860 > i870
    AT&T (2007 to Present) - Treo 680 > iPhone 8GB > iPhone 3G 16GB > Moto Q9h Global >
    iPhone 3G 16GB > iPhone 3GS 16GB > HTC Inspire 4G > Samsung Focus > HTC HD7S >
    Nokia Lumia 900 > Nokia Lumia 920 > Nokia Lumia 1520
  7. pdjcrawford's Avatar
    Member

    Posts
    45 Posts
    #7  
    Quote Originally Posted by Nemesis-X View Post
    It keeps giving me the "Can't check for updates right now. Please try again later" message.
    I assume this is after you did the initial check, yanked the connection, and tried to reconnect (ie. after steps 6,7 and during 8 above)? I got that message when I didn't give the connection time to re-establish before trying again to "Update".
  8. Nemesis-X's Avatar
    Member

    Posts
    70 Posts
    Global Posts
    129 Global Posts
       #8  
    I checked, it's 8107.

    Yep, that is after I yanked the connection and tried a reconnect. I'll try again after giving it time to re-establish.
  9. rc2080's Avatar
    Member

    Posts
    32 Posts
    #9  
    Tango should be out for Rogers already.. shouldn't it? I got mine last Thursday.

    Just give it a bit more time.. they might be rolling it out to people in waves for whatever reason.
  10. Nemesis-X's Avatar
    Member

    Posts
    70 Posts
    Global Posts
    129 Global Posts
       #10  
    Success! Managed to get it to update but it did not find the 8773 update so 8112 only for now. Thanks for the help.
  11. Exoma's Avatar
    Member

    Posts
    91 Posts
    #11  
    Got the update working using that method earlier this morning!

    Noticeable things:

    - Purple Hue STILL a problem
    - No visual changes
    - Waste of time

    This is NOT Tango. This is just a minor update. :)
  12. the_thunderbird's Avatar
    Member

    Posts
    141 Posts
    Global Posts
    315 Global Posts
    #12  
    I updated a few hours ago to 8773. The purple hue seems to be gone for me, and the screen is noticably brighter. I will update if this doesn't continue through the day tomorrow.

    And I got my hundred dollars from Rogers today (I bought outright) so it has been a great Lumia day.
  13. rc2080's Avatar
    Member

    Posts
    32 Posts
    #13  
    How did you get the $100 back? Rogers was totally adamant about not giving me any money back if I bought outright..
  14. the_thunderbird's Avatar
    Member

    Posts
    141 Posts
    Global Posts
    315 Global Posts
    #14  
    I just Tweeted them and got it. Really the long delay is my fault because of an insane work schedule. Regardless I just said I should get it because I didn't return it, and they agreed.

    Further information am declaring my keyboard colouring fixed :)
    Thanked by:
    rc2080 
  15. Bernard Wei's Avatar
    Member

    Posts
    2 Posts
    #15  
    Works for me, updating from 8107 to 8112 now. Thanks :)
  16. Xsever's Avatar
    Member

    Posts
    442 Posts
    Global Posts
    575 Global Posts
    #16  
    This never fixed the purple hue for me. That can't be fixed with an OS update. It needs a firmware update.
  17. rc2080's Avatar
    Member

    Posts
    32 Posts
    #17  
    Quote Originally Posted by the_thunderbird View Post
    I just Tweeted them and got it. Really the long delay is my fault because of an insane work schedule. Regardless I just said I should get it because I didn't return it, and they agreed.

    Further information am declaring my keyboard colouring fixed :)
    Yeah, I just tried that with their Twitter account too and they said that they don't know how you got your $100 back :/
  18. hossiam's Avatar
    Member

    Posts
    28 Posts
    Global Posts
    38 Global Posts
    #18  
    Quote Originally Posted by Exoma View Post
    Got the update working using that method earlier this morning!

    Noticeable things:

    - Purple Hue STILL a problem
    - No visual changes
    - Waste of time

    This is NOT Tango. This is just a minor update. :)
    I am new to this but i fixed my purple hue by putting screen brightness to high instead of auto.....I know you probably knew about this but it is a nice short term fix.
  19. Xsever's Avatar
    Member

    Posts
    442 Posts
    Global Posts
    575 Global Posts
    #19  
    Quote Originally Posted by Hossiam View Post
    I am new to this but i fixed my purple hue by putting screen brightness to high instead of auto.....I know you probably knew about this but it is a nice short term fix.
    Putting it on medium will fix it too.
  20. the_thunderbird's Avatar
    Member

    Posts
    141 Posts
    Global Posts
    315 Global Posts
    #20  
    Quote Originally Posted by rc2080 View Post
    Yeah, I just tried that with their Twitter account too and they said that they don't know how you got your $100 back :/

    PM if you'd like the details :)

Posting Permissions