The king is back baby!

Resident Evil 7: Biohazard Review — a series risen from the dead

Fitness Apps

Keep your New Year's fitness resolutions with these great Windows 10 apps!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

Get ready for beta!

Halo Wars 2 Blitz: Game modes, beginner's tips, and more

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. sinime's Avatar
    Retired Moderator

    Posts
    4,168 Posts
    Global Posts
    5,604 Global Posts
       #1  
    I was having an issue with my new Lumia 900 and think I found the problem, which may not be the phone at all. Just thought Id share this in case anyone else comes across this issue.

    Problems (not sure if you would describe it as over-sensitive or phantom fingers):
    1) Sporadic keyboard. Sometimes keys would not register that they were pressed on the virtual keyboard and at other times, multiple key presses on multiple keys would register at the same time. Impossible to type anything.
    2) Zoom instead of scroll. Id be scrolling through a web page and find that while scrolling the screen would sometimes jump from scrolling to zooming in or out. It was as if there was a second phantom finger on the screen.
    First thought was dirty screen, but cleaning did not fix. Thought maybe it needed to reboot, but that did not necessarily fix the problem.

    Solution?:
    Changed the wall charger. The wall charger I was using was a 5V, 1amp (cheap aftermarket POS) wall charger I had been using just fine on my iPhone and should work just fine on the Lumia, but it did not. At first I didnt realize that issue only appeared when it was charging from one particular charger because I would plug it in and not mess with it immediately. Today when I realized what was going on, I swapped out the cable a couple of times to no avail and finally swapped out the wall charger which cleared the issue right up. With the bad charger, I could open a text message and type normally, plug in the cable for sporadic keyboard response, and unplug the phone for the keyboard to immediately work normally. I dont know if the wall charger is giving the wrong voltage/amperage or maybe just unsteady voltage, but I think I have found a new home for it in the trash.

    Hope this helps someone else out there. The issue seems to be fixed, but I'll be sure to update this post if not!
  2. sinime's Avatar
    Retired Moderator

    Posts
    4,168 Posts
    Global Posts
    5,604 Global Posts
       #2  
    Lol, seems to be charging faster too!

    Sorry for double post, but board express pro can't handle long posts, much less editing them ;)

    Sent from my Lumia 900 using Board Express
  3. Julius Simon's Avatar
    Member

    Posts
    1 Posts
    #3  
    This was what happened to me. I thought the phone was just buggy
  4. juliusgy's Avatar
    Member

    Posts
    4 Posts
    #4  
    Honestly my phone feels like a totally different device
    Sent from my Lumia 900 using Board Express

Posting Permissions