1. JUSTQUAN2's Avatar
    Now that we all had a good day to use the Lumia on att network, what do you think of the battery life thus far?

    I pulled mine(920) off the charger at 8:10am, moderate use of texting, couple calls, videos, music playing .... At 5:20 I still have 41% left. I assume heavy use I would have killed it a couple hours ago. I feel the battery life is excellent for moderate everyday use. ๐Ÿ˜Š
    11-10-2012 05:22 PM
  2. Landsharkk's Avatar
    Now that we all had a good day to use the Lumia on att network, what do you think of the battery life thus far?

    I pulled mine(920) off the charger at 8:10am, moderate use of texting, couple calls, videos, music playing .... At 5:20 I still have 41% left. I assume heavy use I would have killed it a couple hours ago. I feel the battery life is excellent for moderate everyday use. ๐Ÿ˜Š
    I'm honestly surprised that people think that's excellent battery life. Before the mango update (WP7.5), my Samsung Focus would last 3 full days with moderate use. Now we seem to be stuck with maybe a full 12 hours with moderate use. I'm actually disappointed.
    11-10-2012 05:25 PM
  3. InnocuousScreenname's Avatar
    Six hours of heavy use, fourty percent batter left. With my normal usage, I'm sure I'll be able to get through a couple of days before full battery drain.

    I plug my phones in every night for a charge anyway, so battery life will not be an issue.
    11-10-2012 05:29 PM
  4. JUSTQUAN2's Avatar
    I'm honestly surprised that people think that's excellent battery life. Before the mango update (WP7.5), my Samsung Focus would last 3 full days with moderate use. Now we seem to be stuck with maybe a full 12 hours with moderate use. I'm actually disappointed.

    Coming from Galaxy note 1.... ITS FANTASTIC. LBVS
    11-10-2012 05:39 PM
  5. dinkatoid's Avatar
    I charged my phone overnight (as it came partially charged, like most do) and unplugged it about 8 am this morning. I was on a call for over an hour and have had moderate use all day between texts and playing with the new phone, and I am not at 79% battery life. I am sure I can make it 2 days easy at this pace.

    Granted, I did set my email to push and have turned the screen brightness to low (I'm a nerd, I don't go outside).
    11-10-2012 05:42 PM
  6. JUSTQUAN2's Avatar
    I charged my phone overnight (as it came partially charged, like most do) and unplugged it about 8 am this morning. I was on a call for over an hour and have had moderate use all day between texts and playing with the new phone, and I am not at 79% battery life. I am sure I can make it 2 days easy at this pace.



    Granted, I did set my email to push and have turned the screen brightness to low (I'm a nerd, I don't go outside).

    How did you set your email to push?
    11-10-2012 06:08 PM
  7. dkp23's Avatar
    took mine off at around 9 or so and had 59% at 1pm, i was like wtf! never had this type of drain on my 900 with heavy internet use, i didnt even use it on LTE that much since i had wifi at home for most of the four hours .

    Hopefully this is just a first cycle thing. we'll see through the next week.
    11-10-2012 06:12 PM
  8. dkp23's Avatar
    How did you set your email to push?
    go to the email icon and go to settings, it should be under sync settings an dyou can choose manual, ever so and so minutes every so and so hours or as items arrive. just put as items arrive, you will get email notifications as the emaisl come.
    11-10-2012 06:14 PM
  9. Gken's Avatar
    I dunno, my samsung focus had to be recharged every day, which is why I don't find it hard to believe my monster lumia 920 has to also. I also have my screen auto set to high brightness and high contrast mode on since......black tiles and white background look bombdiggity on the white gloss Lumia 920. Seems to last the whole day so far. O yeah plus I have high sensitivity one, a bunch of live tiles on the home screen. THe monstrous screen probably plays a big role, but still again batteries are hit and miss.

    I interested to know how you change email to manual, I don't even have an option on sync settings. Kind of weird considering the OS should be relatively the same.
    Last edited by Gken; 11-10-2012 at 08:05 PM.
    11-10-2012 07:10 PM
LINK TO POST COPIED TO CLIPBOARD