Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
Like Tree1Likes
  • 1 Post By eortizr
  1. spaulagain's Avatar
    Member

    Posts
    1,213 Posts
       #1  
    I first got a white 920 but it had the vibration issue. So I went back and swapped for a black one. This one has vibration issue as well. But I noticed that the screen on the black has an extra bevel around the edges. So the screen is not edge to edge with the polycarbonate unibody.

    Anyone else notice this on their black 920?
  2. kebnt's Avatar
    Member

    Posts
    41 Posts
    #2  
    I noticed this as well. I didn't take a close enough look at the other colors to see if there was this extra bevel on those, only noticed it after I took it out of my pocket later in the day and saw some debris caught in the bevel
  3. B T C's Avatar
    Member

    Posts
    157 Posts
    #3  
    Are you saying the phones don't share the same design across colors?
  4. #4  
    So thats why coming from an N9 , the black looks a bit strange to me. Because i am so accustomed to the curve screen gradully going into the body of the phone
  5. eortizr's Avatar
    Member

    Posts
    224 Posts
    Global Posts
    228 Global Posts
    #5  
    You guys are crazy. The bevel is there in all colors

    Sent from my RM-820_nam_att_100 using Board Express
    Thanked by:
    socialcarpet likes this.
  6. Landsharkk's Avatar
    Member

    Posts
    280 Posts
    #6  
    My Red Lumia 920 has the black bevel around the screen edge.
  7. Chippius_nl's Avatar
    Member

    Posts
    7 Posts
    #7  
    It is the same. In the review from wpcentral for example you can see the white has it also.
  8. igoramadas's Avatar
    Member

    Posts
    100 Posts
    #8  
    Quote Originally Posted by eortizr View Post
    You guys are crazy. The bevel is there in all colors

    Sent from my RM-820_nam_att_100 using Board Express
    I second that.
  9. AbsoluteZerow's Avatar
    Member

    Posts
    91 Posts
    Global Posts
    109 Global Posts
    #9  
    lol, I'm laughing at all these paranoid threads. People really need to calm down and simply enjoy the phone, as a phone. This isn't a $30,000 car that has rattles, dings, etc. This is a phone... calm it down people!
    ___________________________________

    Lumia 925 w/ 8.1 on T-Mobile
    Xbox One: AbsoluteZerow

  10. VagrantWade's Avatar
    Member

    Posts
    1,399 Posts
    Global Posts
    1,411 Global Posts
    #10  
    Almost the entire front is black for all colors. So yes, the little bezel hugging the curved glass is there on all of them.
  11. Beltelmel's Avatar
    Member

    Posts
    87 Posts
    Global Posts
    180 Global Posts
    #11  
    Quote Originally Posted by spaulagain View Post
    I first got a white 920 but it had the vibration issue. So I went back and swapped for a black one. This one has vibration issue as well. But I noticed that the screen on the black has an extra bevel around the edges. So the screen is not edge to edge with the polycarbonate unibody.

    Anyone else notice this on their black 920?
    By "extra" are you saying that yours has two bevels?
  12. socialcarpet's Avatar
    Banned

    Posts
    1,893 Posts
    Global Posts
    1,966 Global Posts
    #12  
    Quote Originally Posted by johnnyfiive View Post
    lol, I'm laughing at all these paranoid threads. People really need to calm down and simply enjoy the phone, as a phone. This isn't a $30,000 car that has rattles, dings, etc. This is a phone... calm it down people!
  13. spaulagain's Avatar
    Member

    Posts
    1,213 Posts
       #13  
    Quote Originally Posted by VagrantWade View Post
    Almost the entire front is black for all colors. So yes, the little bezel hugging the curved glass is there on all of them.

    Ok. I couldn't remember seeing it on the white one I had. But that could have been just the contrast between screen and white body.

    I'm not being paranoid or anything, just curious because my 800 didn't have that.

Posting Permissions