XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

2015 machine in 2017?

Surface 3 still holds its own in 2017

Let Kodi cut your cord

You should be using Kodi for Windows 10

Leader of the pack

HP's Spectre x360 15 just might be the best all-around laptop

New or refurbed?

Is a refurbed Surface right for you?

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 30
Like Tree3Likes
  1. Aki11p2's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Hello,

    Is anybody else not receiving text messages from iphone users? I switched from an iphone 4 and although I turned off imessages in settings, whenever my friends try and text me it still sends the message as an imessage and I never receive it.

    It seems like other people are having the same issue who also switched from an iphone.

    Searching the apple support forums it seems like there is no concrete fix for this.

    Anyone else experience this or have any luck?
  2. VagrantWade's Avatar
    Member

    Posts
    1,400 Posts
    Global Posts
    1,412 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Strange. My co-worker is using a 4S and I got his texts fine over the weekend to my 920. And I switched from an iPhone 4.
  3. Landsharkk's Avatar
    Member

    Posts
    308 Posts
    Global Posts
    319 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    I wonder if it's something on AT&T's back-end, like something needing to be changed when you go from an iPhone to non-iPhone specifically.
  4. Pontifex's Avatar
    Member

    Posts
    55 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    I'm glad I'm swithing number then :) I even went for a number that ended with 920 XX XXX 920
  5. 920920's Avatar
    Member

    Posts
    3 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    I had the same issue with not receiving any texts from iphone users. Turned out at&t had removed my text plan after the upgrade. Simply login to your att account and check your plan.
    Also, check this link
    Fix the iMessage Bug So You Can Still Get Messages If You Switch to Android from iPhone
  6. TrunkMonkey44's Avatar
    Member

    Posts
    6 Posts
    Global Posts
    7 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #6  
    I had the same problem. For me it was because my Microsoft default login had my chat status set to Offline - apparently set in Messenger ages ago or something? I don't know. But as soon as I changed that in the Messaging window (the little person icon) I was able to receive texts.

    A side note - I couldn't send/receive pics or video and that had to be resolved by AT&T with a reset on their end.

    TM
  7. TenTwelve's Avatar
    Member

    Posts
    514 Posts
    Global Posts
    522 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    I had a problem with iMessage messages switching from an iPhone. You've got to pull the old sim out of the iPhone and leave wifi off.
  8. Landsharkk's Avatar
    Member

    Posts
    308 Posts
    Global Posts
    319 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #8  
    Quote Originally Posted by TrunkMonkey44 View Post
    I had the same problem. For me it was because my Microsoft default login had my chat status set to Offline - apparently set in Messenger ages ago or something? I don't know. But as soon as I changed that in the Messaging window (the little person icon) I was able to receive texts.

    A side note - I couldn't send/receive pics or video and that had to be resolved by AT&T with a reset on their end.

    TM
    Interesting. I'm set to 'offline' and I'm receiving txt's just fine.
  9. TrunkMonkey44's Avatar
    Member

    Posts
    6 Posts
    Global Posts
    7 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    Quote Originally Posted by Landsharkk View Post
    Interesting. I'm set to 'offline' and I'm receiving txt's just fine.
    You're right. I just set myself to Offline and got a text. It must have been a timing thing then, because I couldn't get messages before. I had someone standing there with me sending texts and they wouldn't go through until I made the chat status change.

    I wonder what it was? I turned iMessage off on my iPad and my old iPhone, but was still having the problem.

    TM
  10. ibbyj's Avatar
    Member

    Posts
    297 Posts
    Global Posts
    515 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    Sometimes it helps if the person sending clears your old text convo that was used with imessage.
  11. John Ober's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    I got a new 920 and had the same problem. I found the solution. Have the person sending you the text turn there imsg off send you a text then turn imsg back on. you will now be able to recieve txt msgs from them. It is an apple operating system issue. Not a problem with your phone.
    Duvi and Laura Knotek like this.
  12. Duvi's Avatar
    Retired Moderator

    Posts
    3,035 Posts
    Global Posts
    20,036 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    Quote Originally Posted by John Ober View Post
    I got a new 920 and had the same problem. I found the solution. Have the person sending you the text turn there imsg off send you a text then turn imsg back on. you will now be able to recieve txt msgs from them. It is an apple operating system issue. Not a problem with your phone.
    Was just coming in to say this. Best/Easiest workaround I know of, for now.
  13. JW888's Avatar
    Member

    Posts
    152 Posts
    Global Posts
    165 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    That could only happened to iphone, not other devices..........that why I never use iphone, by the way, is not the best phone, any way.
  14. John Puttman's Avatar
    Member

    Posts
    2 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #14  
    So my wife is on an iphone 4. I had an iphone 4 and switched to the 920. We tried turning the iMessage off and sending the text message. The message came through. She turned the iMessage on her phone back on and it switched back to trying to send me iMessages. She had to delete my contact and re-add it to get the messages to go through when she has the iMessages setting turned on.

    UPDATE -- This worked for a couple of messages, then they stopped coming through. I had her delete the contact an try to send a text just to my phone number. It is getting sent directly back to her.

    UPDATE -- So I am on hold with AT&T tech support. They asked me to have my wife reset her iPhone back to factory settings...you know get rid of all her contacts and apps and pictures etc. REALLY? I have probably 50+ contacts on iPhones, some are business contacts. That really can't be the solution.

    UPDATE -- So now AT&T contacted Apple and guessed that my wife and i were sharing an apple ID between our two phones - this is correct. They say that since there is still an iPhone listed under my apple ID, even though I deleted the registration for my iPhone in my apple account, that the apple system will still try to send iMessages to my number instead of text messages.
    Last edited by John Puttman; 01-09-2013 at 02:16 PM. Reason: Update
  15. philpeeps's Avatar
    Member

    Posts
    487 Posts
    Global Posts
    657 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #15  
    Did you disable iMessage on your old phone prior to switching?
  16. John Puttman's Avatar
    Member

    Posts
    2 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #16  
    No - I didn't disable iMessage prior to switching :(
  17. philpeeps's Avatar
    Member

    Posts
    487 Posts
    Global Posts
    657 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #17  
    Quote Originally Posted by John Puttman View Post
    No - I didn't disable iMessage prior to switching :(
    Then it will continue to happen with anyone that you used iMessage with previously. Apple should have a way of disabling it without the device.
  18. Maddy Alberdi's Avatar
    Member

    Posts
    1 Posts
    Global Posts
    2 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #18  
    didnt work
  19. Laura Knotek's Avatar

    Posts
    25,654 Posts
    Global Posts
    47,718 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #19  
    Quote Originally Posted by Maddy Alberdi View Post
    didnt work
    https://discussions.apple.com/thread...rt=75&tstart=0
  20. WPmunkey's Avatar
    Member

    Posts
    304 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #20  
    You can try a PW reset. You can try to unregister the iPhone at supportprofile.apple.com. If those don't work after a day or two and you can't get back to that iPhone, you may have to wait 40 days or so for your number to expire
  21. MSTopher's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #21  
    I had the same issue where I could not receive Imessages and they would reroute to another person with an Iphone. I could receive messages with Imessages turned off. It turns out that the phone number is connected to the Iphone through the Icloud as well. If an Iphone user gets another number it is supposed to auto update to the new number, but that is not always the case. I went through all the hassle of calling AT&T and Apple. The easiest solution for me was to just request a new number and give an explanation of why I should not have to pay for it.
  22. drendannon's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #22  
    Hey,

    I'm not sure how many people will still be reading this but I thought that I'd put all the information I've gathered into one place for everyone else to find.

    First things first. I had an iPhone, it was good at what it did, but I didn't like how limited it was so when I got a new phone I moved to an Android device. It was a quiet couple of days...

    I learned that Apple, with it's imessage function, actually highjacks your texts to other Apple device users and sends them through your 3G/wifi connection and their servers to the other users. They completely bypass the typical SMS route which could be nice if you were still paying for your texts individually, but who really is nowadays? Anyways, once you've sent any apple user a message like this you're in the system and you've gotta get out before it's going to work for you on another device.

    To be able to receive texts/picture messages/etc. on your non-Apple device you'll need to go to https://supportprofile.apple.com/MySupportProfile.do sign in, find your old device(s) and Unregister them by clicking on the "x" beside them and then the "Unregister" button.
    Make sure you do this for each device linked to that phone number!
    After you've done this you'll have to wait. Some people have said that it was only a few minutes, it took closer to two days for my account to be fixed.

    Another workaround that I've heard works is to have each of your friends go into your contact info and either delete it and start again, or change your contact number from an iPhone to "Mobile" then restart their devices... and wait till it takes effect.

    I understand that this is a VERY frustrating problem and I hope this helps!

    -J

    PS - Please don't hate on your new phones because they aren't working. Hate on Apple for knowing about this problem for a year and not fixing it yet because it sometimes gets people to give up their other devices and come back to them... Shady.

    EDIT:
    PPS - If you got a new number and are having the problem it's probably because the person that had the number before you had an Apple. If that's the case you're outta luck. You're not going to be able to get Apple to modify that random strangers' account, and there's nothing your service provider can do because your phone is working the way it "should" be. Just ask for a new # and if you can, specify one that hasn't been used before so you know that it's clean and fresh!
    xboxonthego3 likes this.
  23. gojojo21's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #23  
    This is so stupid anyone is having to go through this. I've talked to att, apple, deactivated my number from the support profile, changed my password and even gone as far as to have my apple account deleted altogether and four weeks later still nada! I was really missing my iPhone when I first switched but after all this I will never go back. I shouldn't have to contact all my contacts to determine if they have iPhones and walk them through this process. Well I hope someone can come up with additional advice. Also I've had the same number for 15 years and should not have to get a new number. Is this happening to only att folks?
  24. Ker759's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #24  
    Quote Originally Posted by gojojo21 View Post
    This is so stupid anyone is having to go through this. I've talked to att, apple, deactivated my number from the support profile, changed my password and even gone as far as to have my apple account deleted altogether and four weeks later still nada! I was really missing my iPhone when I first switched but after all this I will never go back. I shouldn't have to contact all my contacts to determine if they have iPhones and walk them through this process. Well I hope someone can come up with additional advice. Also I've had the same number for 15 years and should not have to get a new number. Is this happening to only att folks?
    Hey all I I think I figured out the solution to this. It may work for some but not for all. Go to Settings....swipe left (this should bring you to applications)....select messaging and turn off the chat backup. This seemed to fix the issue for me. Hope it helps
  25. mrhappi79's Avatar
    Member

    Posts
    10 Posts
    Global Posts
    21 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #25  
    If I never registered my iPhone what options do I have? It doesn't appear registered under my apple ID.
    Last edited by mrhappi79; 05-15-2014 at 11:56 PM.
Page 1 of 2 12 LastLast

Posting Permissions