1. Roy Keren's Avatar
    Hey guys,

    I set my gmail account, been getting emails but can not make it work both ways:
    I read the email on my phone, even delete it then go to my computer an hour later and it is still there.

    On my iPhone I didn't need to do any special configuration to make it work, what am I doing wrong? :@

    Thanks,
    Roy.
    11-14-2012 08:44 AM
  2. NickA's Avatar
    I have that issue sometimes as well. It's like two way sync isn't working.

    I set my GMail up as Outllook (Exchange) and it seems to work better now. After doing that, open the browser on your 920,. and go to m.google.com/sync and set your messages to be deleted instead of archived.

    I"ve also found that if I push/hold on an unread message, and delete it, it doesn't delete on the web client. But if I open the message, and then delete it, it works right away.
    11-14-2012 08:48 AM
  3. kanundra's Avatar
    Do you have it setup as a Gmail account or an Outlook account? I have my Gmail accounts setup as Outlook and they work great.
    11-14-2012 09:32 AM
  4. NickA's Avatar
    Do you have it setup as a Gmail account or an Outlook account? I have my Gmail accounts setup as Outlook and they work great.
    Or basically what I just said in post #2 :)
    11-14-2012 09:34 AM
  5. kanundra's Avatar
    Or basically what I just said in post #2 :)
    I read your first and last paragraphs, but somehow missed the middle one :blush:
    11-14-2012 09:40 AM
  6. NickA's Avatar
    I read your first and last paragraphs, but somehow missed the middle one :blush:
    That's ok. That's the story of my life!
    11-14-2012 09:41 AM
  7. Roy Keren's Avatar
    Hey guys,

    Thanks for your replies.
    Sorry for my ignorance but how can you set a Gmail account as an Outlook account?
    Outlook account setup asks for domain, server etc which I don't really know about my Gmail account.
    I tried to set it up as "other account" but it automatically recognizes it as Gmail...

    Thanks again,
    Roy.
    11-14-2012 11:24 AM
  8. hhiryu's Avatar
    11-16-2012 09:08 AM
  9. txbosox's Avatar
    Roy, to setup your gmail as an Outlook account just go through the sign in portion under a new Outlook account as you normally would for your gmail account info (email/password). Then try to sign in, it'll throw an error saying it can't sign in and then show the username and domain fields below the original fields. Add @gmail.com to the username it's provided (it should be your full email address) and then ignore the domain field. Sign in again. It should throw another error giving the option for "advanced" now, tap it. It should show you an option for a server, type in "m.google.com" and make sure the SSL box is checked (think mine was on by default and I didn't scroll to look for it). Let it sync up and it'll behave more like the gmail you know. It's still not a perfect workaround though.

    Short version :)
    email: fulladdress @gmail.com
    password: password
    username: fulladdress @gmail.com
    domain: [leave blank]
    server: m.google.com
    SSL?: Yes/Check
    11-16-2012 10:09 AM
  10. hasasimo's Avatar
    Just so the OP knows, I'm sure this is a very temporary issue. Email syncing on WP7.5 was absolutely flawless, best I've tried on any OS, including iOS.

    Let's hope the first WP8 update is on the horizon.
    11-16-2012 10:25 AM
  11. Laura Knotek's Avatar
    Just so the OP knows, I'm sure this is a very temporary issue. Email syncing on WP7.5 was absolutely flawless, best I've tried on any OS, including iOS.

    Let's hope the first WP8 update is on the horizon.
    I have not had any issues with Gmail on WP7.5 either. However, I did set up my Gmail account as Exchange ActiveSync, not IMAP.
    11-16-2012 10:29 AM
  12. Sun_dog's Avatar
    You are describing a POP3 email setup where you have an option/box checked to keep the original emails on the server. I transitioned my company from crappy Network Solutions pop3/imap email to Exchange Online and it went from what you're describing to push email like you are expecting. At the very least, change it to imap (you'll probably have to set it up again).
    11-16-2012 10:49 AM
  13. blehblehbleh's Avatar
    Hey guys,

    I set my gmail account, been getting emails but can not make it work both ways:
    I read the email on my phone, even delete it then go to my computer an hour later and it is still there.

    On my iPhone I didn't need to do any special configuration to make it work, what am I doing wrong? :@

    Thanks,
    Roy.
    Out of curiosity what was your syncing interval when you had Gmail setup as Google on your phone?
    11-16-2012 02:59 PM
  14. eallan's Avatar
    My email syncing still seems to be pretty shoddy. I'm set up as exchange with gmail too.
    12-09-2012 11:27 PM
  15. VisceralMonkey's Avatar
    I can't believe there isn't some kind of native gmail app :(
    12-09-2012 11:52 PM
  16. sakahn's Avatar
    I have gmail sync at 15 min. Works perfectly fine on both Wifi and Cellular data.
    12-10-2012 12:30 AM
  17. iusti's Avatar
    Hi guys,

    I've recently bought a Nokia 920. I am not very familiar with WP8..and imagine that I use a google account for my personal emails, events (callendar) etc.
    Yet, I do not manage a all to add a Google account - I keep receiving the error message "Google account info is incorrect - Update your account info from..." and here it gives me 2 hints: ...from m.google.com or imap.gmail.com:993:1.

    Maybe this discussion is already on the forum, yet I couldn't find anything directly linked to my issue.

    Thanks in advance if you have any advice.
    12-12-2012 09:59 AM
  18. loprojoe's Avatar
    iusti, did you ever find an answer to this? Just got a 920 myself...having exact same problem. Will post back here if I find any info...thanks in advance if you have an answer!
    Last edited by loprojoe; 01-01-2013 at 07:17 PM. Reason: clarify who the reply is directed to
    01-01-2013 07:14 PM
  19. iusti's Avatar
    Hi there,
    Sorry, I was away on holiday. I have found the solution on discussions.nokia.com.
    Thus, if you have an application-specific passwords enabled on your google account... you will need to generate one for your phone, as your normal password will not work with this setting enabled. Once you do that, it will work just fine. Too bad this is not explicit for all the users.
    Best Regards,
    iusti
    01-07-2013 03:27 AM
  20. Linh Pham's Avatar
    My problem is GMail on Lumia 920 is kinda silly: I simply cannot make my Lumia display JUST the Priority Inbox, it can only show a normal inbox which, in my case, is way too messy to go through. Any solution?
    01-07-2013 09:20 PM
  21. ShadowHash's Avatar
    I'd like to configure gmail as exchange account but i'll loose contacts sync. Any other way to make push work better using a gmail account wiht m.google.com ?
    02-26-2013 02:00 PM
  22. jarala60's Avatar
    Mine is set up as exchange and it syncs my contacts as well. there is a place in the 'sync settings' for you to select what you want to
    sync: mail, contacts, calendar, and tasks.
    02-26-2013 10:15 PM
  23. V KalyanSuman Kande's Avatar
    Thanks that Application specific password helped in setting up my gmail in Lumia 820
    'Application-specific password required'. - Gmail Help
    03-04-2013 02:40 AM
  24. rangu's Avatar
    Thank you!
    03-28-2013 12:26 PM
  25. jfa1's Avatar
    I can't believe there isn't some kind of native gmail app :(
    Talk to Google they dont want to play nice with windows phone and the brawl is on.
    03-28-2013 04:11 PM
LINK TO POST COPIED TO CLIPBOARD