Get ready for beta!

Prepare for Halo Wars 2 Blitz Mode beta: Everything you need to know!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 7 of 7
  1.    #1  
    I gave my 920 a hard reset in the settings menu and it appears to have killed it. :(.

    Trying a volume down and power rest does nothing, and I can't appear to get the exclamation mark screen listed in the service manual to do an OS reset.

    Instead the phone either stays stuck on the Nokia logo screen, then goes black turns off and restarts with the nokia logo..

    Or, strangely, if I mash the buttons enough, I get the attached screen, which I haven't seen before.

    Any tips?
  2. SinisterDuck's Avatar
    Member

    Posts
    120 Posts
    Global Posts
    123 Global Posts
    #2  
    I just had the same happen to mine. I'm staring at the Nokia logo right now. It's been this way for 20 minutes. If I do the 3 button reset, it just starts the same cycle over again -- AT&T logo screen, and Nokia logo screen forever. Yikes!
  3. mdecker79's Avatar
    Member

    Posts
    20 Posts
    #3  
    I had the same issue on launch day....


    It would cycle through the nokia logo and the ATT logo...

    Then after a few times.... I got a Please insert your windows CD to repair or reinstall.. LOL...

    I picked up the phone and looked around to see where I could fit a CD in... but I couldn't find a spot.. :)

    I had to exchange it for another phone.
  4. devize's Avatar
    Member

    Posts
    236 Posts
    Global Posts
    242 Global Posts
    #4  
    Quote Originally Posted by mdecker79 View Post
    Then after a few times.... I got a Please insert your windows CD to repair or reinstall.. LOL...
    Haha WP8 really is based off W8 isn't it.

    Anyway, it really isn't good seeing stock devices bricking themselves.
  5. dseiden's Avatar
    Member

    Posts
    48 Posts
    Global Posts
    152 Global Posts
    #5  
    I had the same thing happen with my Red 920. It started having sound issues and then I tried to reset it thru the menu. Cogs on the screen which I let run for a couple hours and then I tried the button reset.

    Ended up having to exchange it and got a white one. Hope that is a bug they fix.. Resetting should not brick the phone.
  6. 5tephen's Avatar
    Member

    Posts
    375 Posts
    Global Posts
    411 Global Posts
    #6  
    Having this issue right now. Unfortunately my store is 75 miles away so I can't go until Saturday
  7. hasasimo's Avatar
    Member

    Posts
    1,916 Posts
    Global Posts
    2,109 Global Posts
    #7  
    Scary :-/. To the OP, is that a dev version? I don't see an AT&T logo on the handset.

Posting Permissions