Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. ksj1's Avatar
    Member

    Posts
    102 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Just wondering if I need to go through activation or if I can just use the SIM in my L900. The SIM is a LTE one, so I don't need anything different in that regard.
  2. dkp23's Avatar
    Member

    Posts
    1,494 Posts
    Global Posts
    1,529 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    yes i did, my sim was LTE, i put it in the 920 and it worked for a day or so, then i haven't gotten LTE since. I might provision another sim later on to see if that works.
    ksj1 likes this.
  3. jfa1's Avatar
    Member

    Posts
    2,565 Posts
    Global Posts
    2,648 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    When I got my 920 last year I just put my 900 sim in and every thing has been fine since no sim card issues

Similar Threads

  1. So...has anyone used Straight Talk GSM service...?
    By jrdatrackstar1223 in forum Windows Phone 7
    Replies: 19
    Last Post: 08-14-2014, 06:15 AM
  2. Has anyone lost their notations in Calendar?
    By perbear in forum Samsung Omnia 7
    Replies: 2
    Last Post: 08-03-2012, 10:13 AM
  3. Has anyone used Bluetooth on Titan?
    By neftv in forum HTC TITAN
    Replies: 6
    Last Post: 01-02-2012, 07:30 PM
  4. Anyone use their focus as their mp3 player?
    By Salent in forum Samsung Focus
    Replies: 15
    Last Post: 06-21-2011, 08:47 AM

Posting Permissions

";