Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. ksj1's Avatar
    Member

    Posts
    45 Posts
       #1  
    Just wondering if I need to go through activation or if I can just use the SIM in my L900. The SIM is a LTE one, so I don't need anything different in that regard.
  2. dkp23's Avatar
    Member

    Posts
    1,415 Posts
    Global Posts
    1,444 Global Posts
    #2  
    yes i did, my sim was LTE, i put it in the 920 and it worked for a day or so, then i haven't gotten LTE since. I might provision another sim later on to see if that works.
    Thanked by:
    ksj1 
  3. jfa1's Avatar
    Member

    Posts
    2,359 Posts
    Global Posts
    2,438 Global Posts
    #3  
    When I got my 920 last year I just put my 900 sim in and every thing has been fine since no sim card issues
    Your smartphone is only as smart as YOU let it be!

Similar Threads

  1. So...has anyone used Straight Talk GSM service...?
    By jrdatrackstar1223 in forum Windows Phone 7
    Replies: 19
    Last Post: 08-14-2014, 06:15 AM
  2. Has anyone lost their notations in Calendar?
    By perbear in forum Samsung Omnia 7
    Replies: 2
    Last Post: 08-03-2012, 10:13 AM
  3. Has anyone used Bluetooth on Titan?
    By neftv in forum HTC TITAN
    Replies: 6
    Last Post: 01-02-2012, 07:30 PM
  4. Anyone use their focus as their mp3 player?
    By Salent in forum Samsung Focus
    Replies: 15
    Last Post: 06-21-2011, 08:47 AM

Posting Permissions