We made some changes

Our new forums are here!

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
Like Tree1Likes
  • 1 Post By lordofthereef
  • 1 Post By bitseizure
  1. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    Hello everyone,

    Given that I haven't found any post by anyone else regarding this issue, I've decided to create a new thread. I'm on my second 920 because of an issue that makes the phone pretty much unusable. Basically, some areas of the screen seem to constantly "auto trigger" without me touching them(or having my fingers close to that area). Sometimes the problem is so bad that I can't even unlock the phone. Usually it launches apps on its own from the home screen and types stuff/hits send on its own. On the first one, the problem was around the upper left border of the screen. On the second one I got the problem is actually around the bottom of the screen.

    Since this is the second phone I've gotten that has this issue I'm concluding that it's either something inherent in the screen's design that makes it prone to such a defect or something that I'm doing wrong. I haven't had this issue with any other cellphone before the Lumia. The only thing I could think of that's messing with the screen is that I live in Puerto Rico and the climate is very humid here. Perhaps Nokia made the screen too sensitive and that makes it unusable in this environment? I have sensitivity set to normal... setting it to high makes the problem even worse.

    Should I try a third Lumia or should I just give up on it and go with another Android? I don't really like the HTC 8x design... Should I try emailing Nokia to see what they think?
  2. lordofthereef's Avatar
    Member

    Posts
    656 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Screen cover?
  3. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #3  
    No... right out of the box I took off the "no texting while driving" film and the back film too.. I haven't put the cellphone inside any case or anything like that. It's weird because in both cases the problem only starts after a few hours of use.
  4. irvin792's Avatar
    Member

    Posts
    1,152 Posts
    Global Posts
    1,280 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    Quote Originally Posted by Jinxed1 View Post
    No... right out of the box I took off the "no texting while driving" film and the back film too.. I haven't put the cellphone inside any case or anything like that. It's weird because in both cases the problem only starts after a few hours of use.
    Contact Nokia , they are great.
    Last edited by Chris Parsons; 11-20-2012 at 10:02 AM.
  5. lordofthereef's Avatar
    Member

    Posts
    656 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    Truly strange that you had the same issues with two different phones. I agree with the above poster, contact Nokia and ask them about it.
    irvin792 likes this.
  6. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #6  
    Quote Originally Posted by lordofthereef View Post
    Truly strange that you had the same issues with two different phones. I agree with the above poster, contact Nokia and ask them about it.
    I agree.. that's why I decided to start a thread instead of just taking the phone to ATT and trying my luck a 3rd time. If it's something related to the humidity, ATT must be getting returns by the truckloads here though. Maybe it's related to the cable or plug that I used?(same one I use on a GSII without problems...) IDK.. every plausible explanation seems equally far fetched.
  7. bitseizure's Avatar
    Member

    Posts
    27 Posts
    Global Posts
    29 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    Maybe your AT&T retailer or UPS/FedEx driver played soccer with all the phones;)
    Ricky C likes this.
  8. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #8  
    Or somehow gave all the phones on the pallet a healthy dose of static electricity.... who knows...
  9. sirthunt's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    Is this issue only a problem when plugged into a charger? If so, WP is notorious for glitches under these circumstances.
  10. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #10  
    Quote Originally Posted by sirthunt View Post
    Is this issue only a problem when plugged into a charger? If so, WP is notorious for glitches under these circumstances.
    Nope.. happens when unplugged too...

    How long does Nokia usually take to respond to emails? This phone is only getting worse and I'm not taking it back until I decide whether or not to switch phone/brands or try a third L920...
  11. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #11  
    Alright... so I contacted Nokia through the chat and the guy just told me to get a new one through AT&T........ super helpful... :rolleyes:

    I think I'm getting a different phone.....
  12. ksj1's Avatar
    Member

    Posts
    102 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    I don't think it's humidity. I live in Puget Sound where the humidity is usually pretty high and don't have the problem. With that said, there was a similar problem with the L900's early on. I returned the first one I got because of it and the second one was fine.
  13. Dramer77's Avatar
    Member

    Posts
    22 Posts
    Global Posts
    476 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    try a hard reset and set everything back up.. dont restore from the backup.. it may bring th issue right back
  14. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #14  
    Already tried that.. but thanks for the suggestion
  15. lordofthereef's Avatar
    Member

    Posts
    656 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #15  
    Quote Originally Posted by Jinxed1 View Post
    Alright... so I contacted Nokia through the chat and the guy just told me to get a new one through AT&T........ super helpful... :rolleyes:

    I think I'm getting a different phone.....
    in his defense this sounds really weird. You are the first, and only, person I have read with this issue.

    (there was one other guy, but his issue had to do with his screen shield)

    To have two phones in a row doing this is just bizarre. I understand your frustration. I'd try at least once more before giving up. This sounds like hardware.
  16. socialcarpet's Avatar
    Banned

    Posts
    1,893 Posts
    Global Posts
    1,966 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #16  
    I can't believe no one has suggested you turn off the high sensitivity screen...

    Go to SETTINGS --> DISPLAY + TOUCH and set it to NORMAL

    Then see if your problem continues.
  17. Jinxed1's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #17  
    Quote Originally Posted by socialcarpet View Post
    I can't believe no one has suggested you turn off the high sensitivity screen...

    Go to SETTINGS --> DISPLAY + TOUCH and set it to NORMAL

    Then see if your problem continues.
    that's the first thing I tried.. unfortunately.. :-(

Similar Threads

  1. Skype preview app is a battery killer on my Lumia 920
    By Rong Zhou in forum Nokia Lumia 920
    Replies: 4
    Last Post: 11-18-2012, 11:33 PM
  2. Nokia 920 on my local Craigslist
    By redeyss in forum Nokia Lumia 920
    Replies: 4
    Last Post: 11-12-2012, 04:39 PM
  3. Got a text on my 920 sent to Google Voice number...
    By TenTwelve in forum Windows Phone 8
    Replies: 2
    Last Post: 11-11-2012, 11:11 AM
  4. Gonna make my Lumia 920 on friday even heavier
    By lovenokia in forum Nokia Lumia 920
    Replies: 28
    Last Post: 11-06-2012, 08:36 PM
  5. Calling Back the Dogs on My Nokia 920/820 Rants.
    By andrelamont in forum Upcoming & Rumored Windows Phones
    Replies: 35
    Last Post: 09-11-2012, 01:58 PM

Posting Permissions

";