1. Jinxed1's Avatar
    Hello everyone,

    Given that I haven't found any post by anyone else regarding this issue, I've decided to create a new thread. I'm on my second 920 because of an issue that makes the phone pretty much unusable. Basically, some areas of the screen seem to constantly "auto trigger" without me touching them(or having my fingers close to that area). Sometimes the problem is so bad that I can't even unlock the phone. Usually it launches apps on its own from the home screen and types stuff/hits send on its own. On the first one, the problem was around the upper left border of the screen. On the second one I got the problem is actually around the bottom of the screen.

    Since this is the second phone I've gotten that has this issue I'm concluding that it's either something inherent in the screen's design that makes it prone to such a defect or something that I'm doing wrong. I haven't had this issue with any other cellphone before the Lumia. The only thing I could think of that's messing with the screen is that I live in Puerto Rico and the climate is very humid here. Perhaps Nokia made the screen too sensitive and that makes it unusable in this environment? I have sensitivity set to normal... setting it to high makes the problem even worse.

    Should I try a third Lumia or should I just give up on it and go with another Android? I don't really like the HTC 8x design... Should I try emailing Nokia to see what they think?
    11-19-2012 11:19 PM
  2. lordofthereef's Avatar
    Screen cover?
    11-19-2012 11:22 PM
  3. Jinxed1's Avatar
    No... right out of the box I took off the "no texting while driving" film and the back film too.. I haven't put the cellphone inside any case or anything like that. It's weird because in both cases the problem only starts after a few hours of use.
    11-19-2012 11:26 PM
  4. irvin792's Avatar
    No... right out of the box I took off the "no texting while driving" film and the back film too.. I haven't put the cellphone inside any case or anything like that. It's weird because in both cases the problem only starts after a few hours of use.
    Contact Nokia , they are great.
    Last edited by Chris Parsons; 11-20-2012 at 09:02 AM.
    11-19-2012 11:37 PM
  5. lordofthereef's Avatar
    Truly strange that you had the same issues with two different phones. I agree with the above poster, contact Nokia and ask them about it.
    irvin792 likes this.
    11-19-2012 11:38 PM
  6. Jinxed1's Avatar
    Truly strange that you had the same issues with two different phones. I agree with the above poster, contact Nokia and ask them about it.
    I agree.. that's why I decided to start a thread instead of just taking the phone to ATT and trying my luck a 3rd time. If it's something related to the humidity, ATT must be getting returns by the truckloads here though. Maybe it's related to the cable or plug that I used?(same one I use on a GSII without problems...) IDK.. every plausible explanation seems equally far fetched.
    11-20-2012 01:08 AM
  7. bitseizure's Avatar
    Maybe your AT&T retailer or UPS/FedEx driver played soccer with all the phones;)
    Ricky C likes this.
    11-20-2012 01:11 AM
  8. Jinxed1's Avatar
    Or somehow gave all the phones on the pallet a healthy dose of static electricity.... who knows...
    11-20-2012 01:15 AM
  9. sirthunt's Avatar
    Is this issue only a problem when plugged into a charger? If so, WP is notorious for glitches under these circumstances.
    11-20-2012 04:46 AM
  10. Jinxed1's Avatar
    Is this issue only a problem when plugged into a charger? If so, WP is notorious for glitches under these circumstances.
    Nope.. happens when unplugged too...

    How long does Nokia usually take to respond to emails? This phone is only getting worse and I'm not taking it back until I decide whether or not to switch phone/brands or try a third L920...
    11-20-2012 06:39 PM
  11. Jinxed1's Avatar
    Alright... so I contacted Nokia through the chat and the guy just told me to get a new one through AT&T........ super helpful... :rolleyes:

    I think I'm getting a different phone.....
    11-20-2012 07:14 PM
  12. ksj1's Avatar
    I don't think it's humidity. I live in Puget Sound where the humidity is usually pretty high and don't have the problem. With that said, there was a similar problem with the L900's early on. I returned the first one I got because of it and the second one was fine.
    11-20-2012 07:16 PM
  13. Dramer77's Avatar
    try a hard reset and set everything back up.. dont restore from the backup.. it may bring th issue right back
    11-20-2012 08:08 PM
  14. Jinxed1's Avatar
    Already tried that.. but thanks for the suggestion
    11-20-2012 08:20 PM
  15. lordofthereef's Avatar
    Alright... so I contacted Nokia through the chat and the guy just told me to get a new one through AT&T........ super helpful... :rolleyes:

    I think I'm getting a different phone.....
    in his defense this sounds really weird. You are the first, and only, person I have read with this issue.

    (there was one other guy, but his issue had to do with his screen shield)

    To have two phones in a row doing this is just bizarre. I understand your frustration. I'd try at least once more before giving up. This sounds like hardware.
    11-20-2012 10:01 PM
  16. socialcarpet's Avatar
    I can't believe no one has suggested you turn off the high sensitivity screen...

    Go to SETTINGS --> DISPLAY + TOUCH and set it to NORMAL

    Then see if your problem continues.
    11-20-2012 10:06 PM
  17. Jinxed1's Avatar
    I can't believe no one has suggested you turn off the high sensitivity screen...

    Go to SETTINGS --> DISPLAY + TOUCH and set it to NORMAL

    Then see if your problem continues.
    that's the first thing I tried.. unfortunately.. :-(
    11-20-2012 10:42 PM

Similar Threads

  1. Skype preview app is a battery killer on my Lumia 920
    By Rong Zhou in forum Nokia Lumia 920
    Replies: 4
    Last Post: 11-18-2012, 10:33 PM
  2. Nokia 920 on my local Craigslist
    By redeyss in forum Nokia Lumia 920
    Replies: 4
    Last Post: 11-12-2012, 03:39 PM
  3. Got a text on my 920 sent to Google Voice number...
    By TenTwelve in forum Windows Phone 8
    Replies: 2
    Last Post: 11-11-2012, 10:11 AM
  4. Gonna make my Lumia 920 on friday even heavier
    By lovenokia in forum Nokia Lumia 920
    Replies: 28
    Last Post: 11-06-2012, 07:36 PM
  5. Calling Back the Dogs on My Nokia 920/820 Rants.
    By andrelamont in forum Upcoming & Rumored Windows Phones
    Replies: 35
    Last Post: 09-11-2012, 12:58 PM
LINK TO POST COPIED TO CLIPBOARD
";