Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By Mason Wright
  1. BotanicalStig's Avatar
    Member

    Posts
    147 Posts
    Global Posts
    148 Global Posts
       #1  
    This is just what I needed. My replacement 920 came in today. This one doesn't bang around when you move it, but I found an extremely annoying problem with it when I plugged it in. The screen goes numb. Scrolling becomes very difficult, apps open without me touching them, and when it does scroll it's really laggy. I don't remember my old one doing this, did I get another lemon?

    High sensitive touch on or off, it happens. I've done a soft reset, hard reset, etc. It does it no matter what.
  2. #2  
    When I had a Lumia 900, i had this same issue until i put a screen protector on it. My Titan 2 and my Lumia 920 do not have this issue.
  3. Mason Wright's Avatar
    Member

    Posts
    28 Posts
    Global Posts
    33 Global Posts
    #3  
    I have this problem with my smart phones whenever the wrong type of charger is attached. For some reason all my windows phones (focus, 900, 920) have all acted funny whenever the wrong power adapter is attached (doing the same things you describe). If your using the adapter that came with your phone, then this doesn't apply. Best of luck though.
    Bundalings likes this.
  4. robertre's Avatar
    Member

    Posts
    173 Posts
    #4  
    If you are having that issue using the included Nokia charger, I would say you have a problem with the phone or the charger. I had that kind of issue with my ZUNE HD if I used non Microsoft chargers. My touch on my first 920 was flaky when plugged it into the charger, but it turns out that device had a defective screen with a quarter inch across the middle where the touch did not work at all. My replacement phone touch works perfect when it is plugged into the charger or on top of the wireless charging pad.
  5. zolgi's Avatar
    Member

    Posts
    80 Posts
    Global Posts
    97 Global Posts
    #5  
    My 900 did this but not with Nokia's charger.
  6. tumaykilinc's Avatar
    Member

    Posts
    63 Posts
    Global Posts
    64 Global Posts
    #6  
    My iPad is doing this with the original charger, but Lumia 920 no.
  7. igoramadas's Avatar
    Member

    Posts
    100 Posts
    #7  
    This is a common issue especially with Windows Phones (the OS itself has nothing to do with it... maybe because of the similar components used). If you use a charger that doesn't have EXACTLY the same specs as the original one, screen will go nuts and sometimes the phone will get hotter than usual as well.

    Solution? Use the supplied charger, or at least one with exactly the same specs.

    Charging via the computer USB doesn't seem to cause troubles, no matter which cable you use.
  8. BotanicalStig's Avatar
    Member

    Posts
    147 Posts
    Global Posts
    148 Global Posts
       #8  
    Should have specified that I am using the supplied charger, does it plugged into a wall or a computer. Guess this one has to go back too. Great QC you got there Nokia.
  9. Richhy's Avatar
    Member

    Posts
    23 Posts
    #9  
    I experience the exact same issue sometimes. I Should also note that I'm usually using a generic charger from Monoprice. Stupid that it has this effect.

Similar Threads

  1. usb not working but it does charge
    By Xnitro67 in forum Samsung Focus S 4G
    Replies: 3
    Last Post: 04-17-2012, 12:01 AM
  2. Screen Rotation not working?
    By mhc48#CB in forum Samsung Focus
    Replies: 4
    Last Post: 11-09-2010, 11:45 AM

Posting Permissions