Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. kiddori's Avatar
    Member

    Posts
    157 Posts
    Global Posts
    175 Global Posts
       #1  
    I received my charging plate yesterday but the excitement died down pretty fast when I realized that it didn't work properly. I put my phone on and it charges for a few minutes and then fails. At one point I was able to charge from 47% to 49% and then it stopped. Sometimes, it starts charging again after a while. It's extremely spotty and is not working properly. Anyone else with this problem?
  2. Ekin Koc's Avatar
    Member

    Posts
    32 Posts
    #2  
    Mine seems to be working fine except that the led blinks from time to time, guess it loses connection or something.
    Is it the bare one or the fatboy? It is possible to have a large gap between the plate and phone with the fatboy, then the charging becomes spotty.
  3. kiddori's Avatar
    Member

    Posts
    157 Posts
    Global Posts
    175 Global Posts
       #3  
    I have the bare one. Yeah, it starts blinking often so I guess it can't keep the connection very well. Disappointed!

Similar Threads

  1. Just recieved 11/07 cyan preorder with charging plate!
    By Gladstoner in forum Nokia Lumia 920
    Replies: 14
    Last Post: 11-10-2012, 08:08 PM
  2. Problem getting free wireless charge plate with ATT preorder
    By tapiocamilktea in forum Nokia Lumia 920
    Replies: 25
    Last Post: 11-07-2012, 10:24 AM
  3. Replies: 0
    Last Post: 11-06-2012, 05:31 PM
  4. Free wireless charging plate with Lumia 920 @ Phones4u (UK)
    By Andy_McG84 in forum Nokia Lumia 920
    Replies: 0
    Last Post: 11-02-2012, 05:03 AM
  5. Charging/Battery issues with Samsung Focus.
    By ConductingAlpine in forum Samsung Focus S 4G
    Replies: 2
    Last Post: 09-08-2012, 11:15 AM

Posting Permissions