We made some changes

Our new forums are here!

Saving money on data

Mint SIM is the perfect way to get cheap data in the U.S.

Don't count Windows Phone out just yet

Dead? Psh. Here are 5 reasons to stick with Windows 10 Mobile

VPN vs. Proxy

The difference between a proxy and a VPN

Latitude attitude

Dell Latitude 7280 is a business laptop with tons of consumer attitude

4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 13 of 13
  1. Onyx Z32's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    So I bought a Dev Lumia 920 used off eBay since I'm using T-Mobile and need the 1700mhz band.

    I turned it on today for the first time (again, the phone is used so this is the first time for me) and briefly the AT&T logo appears...

    The phone has AT&T live tiles too so now I'm starting to think I was bait-n-switched...

    However the IMEI number in device settings matches the IMEI on the Dev box and the phone is missing the AT&T logo at the top left. I can prove it with pictures, lol.

    So anyone know what's going on with this phone? Looks Like I have Dev hardware but AT&T software?

    I've done a hard reset and the AT&T software stays... am i stuck with AT&T software?

    With a T-Mobile SIM the phone makes calls, but only lets me access EDGE speeds...

    Any insight is appreciated!
  2. spincel's Avatar
    Member

    Posts
    131 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Check the box to make sure it is the variant 920.3 and it has the "DEV" word written on it as well as the AWS band 1700_2100. If it is, go to setting and check to see the name of the phone. It should be 820_nam_roger or maybe dev (I don't really remember). There is no way the dev phone has AT&T boot screen unless it has been flashed with AT&T firmware. Right now there is no confirmation that flashing different variant to the phone will effect the frequency like enable or disable, so it's hard to tell if you just put the sim card into it. The next thing you want to try is to follow this post to see it actually has the AWS band and using it or not.
    Determining the 3G frequency being used - xda-developers

    If not, then contact the seller and ask for detail. By the way, check the content of the box. Dev box will only come with USB cable and that's it. No earphone or AC adapter.

    P/s: If it turns out to have been flashed with AT&T firmware, you can go to xda section Lumia 920 dev to follow the instruction to flash back Rogers firmware.
  3. hfcas's Avatar
    Member

    Posts
    58 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    The firmware of the dev version is rm-820_nam_canada_246.probably your phone has been flashed with att firmware as mentioned above
  4. Onyx Z32's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #4  
    Quote Originally Posted by spincel View Post
    Check the box to make sure it is the variant 920.3 and it has the "DEV" word written on it as well as the AWS band 1700_2100. If it is, go to setting and check to see the name of the phone. It should be 820_nam_roger or maybe dev (I don't really remember). There is no way the dev phone has AT&T boot screen unless it has been flashed with AT&T firmware. Right now there is no confirmation that flashing different variant to the phone will effect the frequency like enable or disable, so it's hard to tell if you just put the sim card into it. The next thing you want to try is to follow this post to see it actually has the AWS band and using it or not.
    Determining the 3G frequency being used - xda-developers

    If not, then contact the seller and ask for detail. By the way, check the content of the box. Dev box will only come with USB cable and that's it. No earphone or AC adapter.

    P/s: If it turns out to have been flashed with AT&T firmware, you can go to xda section Lumia 920 dev to follow the instruction to flash back Rogers firmware.
    Box says 920.3, Dev Kit, 1700_2100, etc. And the IMEI number in settings matches the box BUT the phone also says AT&T in settings, lol. I'm 100% sure it's a developer box, and if the phone matches the box it must be dev hardware.

    It must have been flashed with an AT&T rom.

    I can confirm, if this is indeed a dev phone (and all signs point to that it is) that with an AT&T rom that the AWS bands are disabled. The only speed I can get on T-Mobile is EDGE ("E" in the top bar)

    Quote Originally Posted by hfcas View Post
    The firmware of the dev version is rm-820_nam_canada_246.probably your phone has been flashed with att firmware as mentioned above
    Is this firmware available? I was reading the rom flashing thread on XDA and it seems like the closest I can get is the Rogers? I'd really prefer an unbranded setup and put the phone back to original condition.

    Thanks guys for your help... kinda frustrated here, lol.
  5. spincel's Avatar
    Member

    Posts
    131 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    At this point, your best solution is to go with Rogers. Otherwise, you will need to contact Nokia directly and ask them if they can reflash the phone to original.
  6. Onyx Z32's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #6  
    Yeah, but with the Rogers tethering problems...

    Where do you think I should ask first? Nokia support seems like it wouldn't be the fastest way... maybe I'll tweet Elop, lol.

    There isn't a way to get a copy from someone who already has a Dev device?
  7. spincel's Avatar
    Member

    Posts
    131 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #7  
    Quote Originally Posted by Onyx Z32 View Post
    Yeah, but with the Rogers tethering problems...

    Where do you think I should ask first? Nokia support seems like it wouldn't be the fastest way... maybe I'll tweet Elop, lol.

    There isn't a way to get a copy from someone who already has a Dev device?
    Email Elop is more efficient to get faster respond and I would recommend to do it.

    There is no way to extract a firmware from a current device. You need to find the firmware file to flash it into the device.
  8. Onyx Z32's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #8  
    Update:

    I can't find RM-820_nam_canada_246 anywhere.

    I tried to flash to RM-821_ROW_DeveloperDevice_VAR251040_Black_V2_Black but that won't work because the device is RM-820.

    Then I tried an RM-820_Rogers_Canada flash because the Rogers phones have use of 1700mhz and it worked to get the phone started but still no T-Mobile 3G.

    Damn, lol.
  9. BlackbirdArg's Avatar
    Member

    Posts
    2 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    Same situation here.
    Anybody find a solution??
  10. Onyx Z32's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #10  
    The only solution I got from Nokia Experts was that I need a new phone, lol. They don't give out the original firmware even to developers apparently. I game them my IMEI and I was told I'd get a call back when a new device was available.
  11. BlackbirdArg's Avatar
    Member

    Posts
    2 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    You are lucky, Im from Argentina and I dont know what to do....
  12. michail71's Avatar
    Member

    Posts
    1,821 Posts
    Global Posts
    1,844 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #12  
    What is the different on the dev version?
  13. Onyx Z32's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #13  
    Quote Originally Posted by BlackbirdArg View Post
    You are lucky, Im from Argentina and I dont know what to do....
    Try contacting Nokia Experts. They have a website for developers that you can sign up for then create a ticket about the problem. I can't remember the URL off hand. They can look up the IMEI # of your phone and give you advice.

    That's all I can really suggest at this point because I have a phone I can't use either, lol.

    Quote Originally Posted by michail71 View Post
    What is the different on the dev version?
    Main difference is AWS 1700mhz band like with Rogers phones, except they're unlocked and unbranded to begin with.

Similar Threads

  1. Replies: 9
    Last Post: 12-27-2012, 01:19 AM
  2. New Lumia owner, need some help!
    By Superboy Micah in forum Nokia Lumia 810
    Replies: 4
    Last Post: 11-21-2012, 12:04 AM
  3. Lumia 920 need help ASAP with email issue
    By c d in forum Windows Phone 8
    Replies: 8
    Last Post: 11-14-2012, 11:40 AM
  4. Replies: 8
    Last Post: 03-10-2011, 12:42 PM

Posting Permissions

";