The king is back baby!

Resident Evil 7: Biohazard Review — a series risen from the dead

Fitness Apps

Keep your New Year's fitness resolutions with these great Windows 10 apps!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

Get ready for beta!

Halo Wars 2 Blitz: Game modes, beginner's tips, and more

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. DFB
    DFB is offline
    DFB's Avatar
    Member

    Posts
    19 Posts
       #1  
    Ok, so to keep it short:

    I've bought a grey-market Lumia 920 and the device is as almighty as I expected it to be, from the camera to the battery etc.

    The thing is: when turned on, first comes a Vodafone splash screen. My SIM works ok (I'm on Orange Romania, the phone is obviously deutsch since everything was so german at the first boot), it takes a moment to get recognized but I'm able to make/receive calls, SMS works fine. I'm just not getting any data connection and I'm thinking that's some locking-unlocking business since my boo bought an HTC One S with a T-Mobile first splash (I know), to on orange and running into the same issue.

    Question: Is there a fix for it? :) Will factory resetting the thing bring it back to life? It's a shame that I'm stuck with no data traffic only, I feel lonely with no wi-fi nearby.
    In a somewhat-unrelated Android topic, does anyone have a fix for the One S? I'd love to come out as a hero and turn this blob into husband material.

    Thank you!
  2. DFB
    DFB is offline
    DFB's Avatar
    Member

    Posts
    19 Posts
       #2  
    Okay, I've edited the APN settings using the ones my carrier provided, only now IE doesn't say can't contact DNS server (I think) but has trouble sith the page I'm trying to reach (google). Any ideas? I've seen on a different forum that someone performed a reset and before logging in with the microsoft account, he downloaded the spanish keyboards (?) which triggered some updates that enabled his data connection. Does anyone know anything about this?
  3. DFB
    DFB is offline
    DFB's Avatar
    Member

    Posts
    19 Posts
       #3  
    Done! Talked to a kind sir over at Orange, problem solved!
    Thank you for your views, I'd close the thread if I could, I can't. :)
  4. hyderaly's Avatar
    Member

    Posts
    14 Posts
    Global Posts
    15 Global Posts
    #4  
    Quote Originally Posted by DFB View Post
    Done! Talked to a kind sir over at Orange, problem solved!
    Thank you for your views, I'd close the thread if I could, I can't. :)
    Hi.

    How did you manage to resolve the issue in the end?

Similar Threads

  1. Do I have the dropping data connection issue?
    By choover in forum Nokia Lumia 900
    Replies: 2
    Last Post: 06-01-2012, 08:49 AM
  2. Data Connection Issue Wifi + LTE
    By badMojo69 in forum Nokia Lumia 900
    Replies: 8
    Last Post: 04-25-2012, 05:39 PM
  3. Replies: 13
    Last Post: 04-10-2012, 02:15 AM
  4. Data connection issues
    By kltye in forum HTC TITAN
    Replies: 14
    Last Post: 12-06-2011, 09:51 PM
  5. Issues with data connection
    By Redbird1 in forum HTC HD 7 / 7s
    Replies: 6
    Last Post: 11-22-2010, 06:35 PM

Posting Permissions