4K all the way

You probably don't NEED a 4K webcam, but we love Logitech's BRIO 4K anyway

Long live Windows phone

Contrary to popular belief, Windows phone won't die anytime soon

XP-YESSSSSSS

Dell's already awesome XPS 15 gets even better in 2017

Surface Pwn 5

Surface Pro 5, Project NEON details leaked on LinkedIn?

Redefining the PC

Why Microsoft's Surface phone could be MUCH more than a mere 'phone'

Surface table meets Windows 10

Yes, we did put Windows 10 on the original Surface table ... and it rocks

Cream o' the crop

Before buying a Microsoft laptop, check out our pick for the absolute best

Simple and secure, just the way I like it

We think Windows 10 Cloud is a great idea, here's why

uber micro

Halo Wars 2 has something for everyone. Here's our full review.

Oldie but goldie

We reviewed Microsoft's decade-old Surface table

Creators Update comin' at ya

These are the coolest new features in the next big Xbox One update (video)

Buyer's guide

The Razer Blade 14 is the best laptop Razer has to offer

Windows 10 app gems

10 terrific Windows 10 apps you should be using

Tower of power

Here's what we think of Dell's XPS Tower Special Edition

Quite a deal

Grab the complete C# coding bootcamp for $41!

Your go-to laptop guide

Introducing our ultimate laptop buyer's guide

Listen here

Attn Android and iPhone users: What you need to know about Windows phone

Old is new?

The original Surface Pro still holds its own in the 2-in-1 world

Xbox Greenlight?

No, internet, Microsoft isn't opening Xbox to all UWP games

Falling in love

HP Envy 34 review: An ultrawide curved all-in-one after my heart

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
Like Tree1Likes
  • 1 Post By ballanda
  1. the_icon12's Avatar
    Member

    Posts
    55 Posts
    Global Posts
    87 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #1  
    I got straight talks service working on my white 920, and all was good until yesterday. For some reason, MMS messages can't be received but I can still send them. This is a real downer. Anyone else with this problem?
  2. NokiaCom's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #2  
    Quick question.

    How did you get the 920 on straight talk in the first place? I thought it was At&T locked. Sorry that might be a dumb question.

    Anyway, I don't have the 920 on straight talk yet, but it is something i will do by the end of the month. I can only imagine that it has something to do with the app settings.

    Hope this helps
  3. adebo's Avatar
    Member

    Posts
    45 Posts
    Global Posts
    102 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #3  
    Did you try to reboot the phone. For some reason my MMS goes out with Net10 every once in a while. Once I reboot it works fine.
  4. adebo's Avatar
    Member

    Posts
    45 Posts
    Global Posts
    102 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #4  
    Quote Originally Posted by NokiaCom View Post
    Quick question.

    How did you get the 920 on straight talk in the first place? I thought it was At&T locked. Sorry that might be a dumb question.

    Anyway, I don't have the 920 on straight talk yet, but it is something i will do by the end of the month. I can only imagine that it has something to do with the app settings.

    Hope this helps
    With Straight Talk and Net10 BYOD, you can use any AT&T phone (expect Blackberry). They use the AT&T network for coverage with BYOD (unless you choose the T-Mobile SIM card with Net10).
  5. inteller's Avatar
    Banned

    Posts
    2,530 Posts
    Global Posts
    2,535 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #5  
    oh god I wish someone would bust that myth for good. YOU DO NOT NEED UNLOCKED PHONES ON STRAIGHT TALK!!!!!
  6. wpta's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #6  
    MMS is working fine for me on straighttalk. If you had it working previously I feel like it might just be service at the time you're trying to reiceve the message
  7. the_icon12's Avatar
    Member

    Posts
    55 Posts
    Global Posts
    87 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #7  
    Quote Originally Posted by wpta View Post
    MMS is working fine for me on straighttalk. If you had it working previously I feel like it might just be service at the time you're trying to reiceve the message
    its been a few days and still doesn't work.. Hmm
  8. dogfish54's Avatar
    Member

    Posts
    299 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #8  
    It could be something to do with your APN settings. I know I had to mess with them a bit to get them to work with my straighttalk service. I don't have my 920 near me, but I'm sure someone can post their settings.

    It was MUCH easier to set up straight talk on my 920 than on my 900. And my 920 is an AT&T locked device, straighttalk uses the ATT network, no issues.
  9. ClixT's Avatar
    Member

    Posts
    276 Posts
    Global Posts
    279 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #9  
    Try these:
    APN: att.mnvo
    User name: (leave it blank)
    password: (leave it blank)
    WAP gateway URL: 66.209.11.33
    WAP gateway port: 80
    MMSC url: http://mmsc.cingular.com
    MMSC port: 80
    Max MMS size: (leave it blank)
  10. dogfish54's Avatar
    Member

    Posts
    299 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #10  
    settings ---> Cellular ---> edit mms apn

    APN: att.mvno
    WAP Gateway: 66.209.11.33
    WAP gateway port: 80
    MMSC: http://mmsc.cingular.com
    MMSC port: 80

    Leave everything else blank and press the little disk icon to save.

    My internet APN settings are as follows (works awesome just in case yours are different):

    APN: straight talk
    proxy server: proxy.mvno.tracfone.com
    proxy port: 80
  11. inteller's Avatar
    Banned

    Posts
    2,530 Posts
    Global Posts
    2,535 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #11  
    you cannot edit MMS APNs on WP7 devices.
  12. the_icon12's Avatar
    Member

    Posts
    55 Posts
    Global Posts
    87 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
       #12  
    Quote Originally Posted by inteller View Post
    you cannot edit MMS APNs on WP7 devices.
    we're talking about the 920, which runs WP8..
  13. all_trev's Avatar
    Member

    Posts
    1 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #13  
    Quote Originally Posted by inteller View Post
    you cannot edit MMS APNs on WP7 devices.
    sure you can just not the mmsc without the network setup app
  14. neogodless's Avatar
    Member

    Posts
    32 Posts
    Global Posts
    45 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #14  
    I find the settings above work well Except...

    With the Internet proxy settings
    • proxy server: proxy.mvno.tracfone.com
    • proxy port: 80

    I find that Bing Search (especially Local Scout trying to connect to Bing Search) fails frequently. Anyone else have this issue?

    Having said that, after removing those settings, I've had some issues with MMS... and I've seen conflicting information on what the WAP Gateway IP address should be
    • 66.209.11.33
    • 66.209.11.32

  15. AlexRodriguezNY's Avatar
    Member

    Posts
    83 Posts
    Global Posts
    85 Global Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #15  
    Quote Originally Posted by ClixT View Post
    Try these:
    APN: att.mnvo
    User name: (leave it blank)
    password: (leave it blank)
    WAP gateway URL: 66.209.11.33
    WAP gateway port: 80
    MMSC url: http://mmsc.cingular.com
    MMSC port: 80
    Max MMS size: (leave it blank)
    Use 66.209.11.32 if the one given before doesn't work. Just change the last number
  16. morete908's Avatar
    Member

    Posts
    10 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #16  
    This will be the solution to the problem for many. When you enter the "http://mmsc.cingular.com" address, put a semicolon : after "http". People are entering http// without the semicolon and that is why MMS isn't working.
  17. damnfob's Avatar
    Member

    Posts
    7 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #17  
    Not so sure about adding a semicolon, since the field adds it automatically when starting with a blank profile. What's tripping most people up is not deleting the old profile before entering a new one.
  18. ballanda's Avatar
    Member

    Posts
    176 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    #18  
    Quote Originally Posted by inteller View Post
    oh god I wish someone would bust that myth for good. YOU DO NOT NEED UNLOCKED PHONES ON STRAIGHT TALK!!!!!
    Yeah but it looks way cooler without a dumb ATT logo on your phone. Well worth the extra $200 IMO.

Similar Threads

  1. MMS not working
    By commops7 in forum Nokia Lumia 900
    Replies: 12
    Last Post: 06-17-2013, 01:40 PM
  2. Replies: 11
    Last Post: 12-16-2012, 12:43 PM
  3. attaching video to MMS not working with latest update
    By v10type-r in forum Windows Phone 7
    Replies: 0
    Last Post: 07-26-2012, 11:52 AM
  4. MMS not working
    By starsoccer9 in forum HTC Arrive / 7 Pro
    Replies: 25
    Last Post: 12-19-2011, 06:27 PM

Posting Permissions

";