Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
Like Tree2Likes
  • 1 Post By Harry Ola
  • 1 Post By michail71
  1. annafany's Avatar
    Member

    Posts
    2 Posts
       #1  
    sorry for my very bad english
    i'm Thai

    i use lumia 920 and I have a problem with Nokia Map, Nokia Drive +, gMaps, Maps (Bing Maps).
    GPS found my location but freezing, it not move when i'm move untill it update my new location

    i downloaded "Compass" app in store, it work fine, my compass work fine, but gps still freezing when i'm movin

    i don't know this issue as my handset or software

    my connection that i have this issue: EDGE, 3G, Wi-Fi
    Nokia Maps version: 3.0.125.8
    Nokia Drive version: 2.0.0.1189

    sorry again for my bad eng

    i do a factory reset my phone a lot, but not work
    Last edited by annafany; 12-09-2012 at 10:01 AM.
  2. Harry Ola's Avatar
    Member

    Posts
    35 Posts
    #2  
    I had a similar problem the first time I used nokia drive. It seemed to be related to having the Wifi switched on. Obviously when I moved away from the house it dropped my wifi connection and it seemed to freeze. The audio directions were still working but the map had not moved. Next time, I turned off wifi before setting off and had no problems.
    Thanked by:
    annafany likes this.
  3. annafany's Avatar
    Member

    Posts
    2 Posts
       #3  
    thank you for your useful exp
  4. michail71's Avatar
    Member

    Posts
    651 Posts
    #4  
    In theory WiFi should be on and work better if the phone uses aGPS.
    annafany likes this.
  5. matrixbjk's Avatar
    Member

    Posts
    1 Posts
    #5  
    My grammer is bad. Sorry !!!

    I from İstanbul, Turkey.

    Yes, I have the same problem.

    GPS detects too late.

    I use lumia 920 and I have a problem with Nokia Map, Nokia Drive +, gMaps, Maps (Bing Maps).
    GPS found my location but freezing, it not move when navigation.

    I don't know this issue as my handset or software.

    Or think that the GPS antenna is defective or software.

    I am wait new software update.

    If this problem continue then I send to phone Nokia Service.
  6. Xniaeln's Avatar
    Member

    Posts
    6 Posts
    #6  
    matrix, funny that. I was just in Istanbul using my 920 and I must say the GPS was atrocious.

    I had been in Athens before going to Istanbul and even after getting several "green" GPS locks in Nokia maps, for several days, Nokia maps would say I was still in Athens even while I was standing outside the Blue Mosque.

    The GPS would completely fail to give me a location lock at all. I maybe had successful location locks maybe once per day in Istanbul. The same behavior in Athens too.
  7. Noob1ee's Avatar
    Member

    Posts
    92 Posts
    Global Posts
    93 Global Posts
    #7  
    Turn your WIFI off, thats what was causing my Nokia Drive to freeze.
  8. Jari P's Avatar
    Member

    Posts
    89 Posts
    #8  
    Quote Originally Posted by annafany View Post
    sorry for my very bad english
    i'm Thai

    i use lumia 920 and I have a problem with Nokia Map, Nokia Drive +, gMaps, Maps (Bing Maps).
    GPS found my location but freezing, it not move when i'm move untill it update my new location

    i downloaded "Compass" app in store, it work fine, my compass work fine, but gps still freezing when i'm movin

    i don't know this issue as my handset or software

    my connection that i have this issue: EDGE, 3G, Wi-Fi
    Nokia Maps version: 3.0.125.8
    Nokia Drive version: 2.0.0.1189

    sorry again for my bad eng

    i do a factory reset my phone a lot, but not work
    It sounds that GPS signal is not detected continuously, as you have the same problem with all apps ... it is known that it is harder to catch GPS signal inside of buildings, compared on being outside - did you try outside or inside ?
  9. Xniaeln's Avatar
    Member

    Posts
    6 Posts
    #9  
    Quote Originally Posted by Jari P View Post
    It sounds that GPS signal is not detected continuously, as you have the same problem with all apps ... it is known that it is harder to catch GPS signal inside of buildings, compared on being outside - did you try outside or inside ?
    Hey Jari, I was just on Santorini Island (off the coast of Greece) and after 10 minutes standing on top of the highest point of elevation on the island, surrounded by flat water on a cloudless day, I still was unable to achieve a GPS lock. The island is tiny and has nothing that could interfere with a GPS signal yet of the 2 days I spent there, I was hardly ever able to achieve a proper GPS lock. I would get the "grey dot" occasionally, but the full "green" lock almost never occured.

    There is something else that is going on here that is affecting the quality of GPS. I am able to achieve location locks at home in San Francisco, but while I was in Athens and Istanbul it was utterly disappointing both in the city and in rural flat areas.
  10. Jari P's Avatar
    Member

    Posts
    89 Posts
    #10  
    Quote Originally Posted by Xniaeln View Post
    matrix, funny that. I was just in Istanbul using my 920 and I must say the GPS was atrocious.

    I had been in Athens before going to Istanbul and even after getting several "green" GPS locks in Nokia maps, for several days, Nokia maps would say I was still in Athens even while I was standing outside the Blue Mosque.

    The GPS would completely fail to give me a location lock at all. I maybe had successful location locks maybe once per day in Istanbul. The same behavior in Athens too.
    I think that you have problem with your Nokia maps ... well, I would try to uninstall it and reinstall it again from store ...

    1. Delete history of maps
    2. Uninstall it
    3. Install it again from STORE
    4. Check the installed country maps, update and install all country maps what you are using ...
  11. Jari P's Avatar
    Member

    Posts
    89 Posts
    #11  
    Quote Originally Posted by Xniaeln View Post
    Hey Jari, I was just on Santorini Island (off the coast of Greece) and after 10 minutes standing on top of the highest point of elevation on the island, surrounded by flat water on a cloudless day, I still was unable to achieve a GPS lock. The island is tiny and has nothing that could interfere with a GPS signal yet of the 2 days I spent there, I was hardly ever able to achieve a proper GPS lock. I would get the "grey dot" occasionally, but the full "green" lock almost never occured.

    There is something else that is going on here that is affecting the quality of GPS. I am able to achieve location locks at home in San Francisco, but while I was in Athens and Istanbul it was utterly disappointing both in the city and in rural flat areas.
    If you go settings - applications - maps - is your location of maps enabled there ?

    Did you try Nokia Drive+ beta OFFLINE (you can set it offline from settings) ?

    EDIT: - did you see GPS icon in an up row (a little ball inside of bigger ball) there ?
  12. Xniaeln's Avatar
    Member

    Posts
    6 Posts
    #12  
    Jari,

    My answer to all of your questions is yes.

    Offline, location enabled, GPS icon shows up.

    This behavior is observable in many other apps (I have 4 total GPS dependent apps and they all behave the same).

    For isntance, in gmaps, it's entirely unable to do live tracking of my location. The "speed" indicator that shows up with the current location indicator will jump to 50mph (or whatever speed I'm going), then drop back down to 0, then back up and back down. At least in Nokia maps I'm able to see live tracking of my location even if it is slightly sporadic (sometimes it can go for 30 or so minutes before losing signal).

    Have tried reinstalling the app, it doesn't help. Considering doing a master reset but thinking I'll just wait for portico (running on a Singapore international variant phone) and see if the problem persists.
  13. Chris Gregory's Avatar
    Member

    Posts
    10 Posts
    #13  
    I had this same issue.
    tries all the wi-fi/uninstall types of fixes.

    Hard reset and no issues since
  14. Xniaeln's Avatar
    Member

    Posts
    6 Posts
    #14  
    Well funny how things work. The one thing that I should've done at the start I just did and it worked.

    Turning the phone off then back on solved the problem.

    I used the "GPS Satellite" app (which is awesome by the way) and was observing that my gps accuracy usually started at around 9000ft horizontal and vertical and most of the time would fall to 50ft or so after a few minutes. Restarting the phone gps accuracy now starts at around 100ft and drops to 20ft almost immediately. Looks like some kind of submarine update needed a restart to be applied.

    Not sure if this is a permanet fix because my phone crashed regularly while I was in Athens/Istanbul (the panorama app caused crashes occasionally). Perhaps a proper shutdown was in order.
  15. Rickosw's Avatar
    Member

    Posts
    133 Posts
    Global Posts
    153 Global Posts
    #15  
    Quote Originally Posted by Xniaeln View Post
    Hey Jari, I was just on Santorini Island (off the coast of Greece) and after 10 minutes standing on top of the highest point of elevation on the island, surrounded by flat water on a cloudless day, I still was unable to achieve a GPS lock. The island is tiny and has nothing that could interfere with a GPS signal yet of the 2 days I spent there, I was hardly ever able to achieve a proper GPS lock. I would get the "grey dot" occasionally, but the full "green" lock almost never occured.

    There is something else that is going on here that is affecting the quality of GPS. I am able to achieve location locks at home in San Francisco, but while I was in Athens and Istanbul it was utterly disappointing both in the city and in rural flat areas.
    Hi Xniaeln,

    i was in a similar situation as you...
    but i was in a major city in the open carpark with no tall buildings, Carrefour Supermarket & Mac Donalds drive through is about 200 meters away ... yet i'm unable to get a GPS lock...

    see my other post ...
    http://forums.wpcentral.com/nokia-lu...ml#post1870953

    as suggested by several WPcentral members, i will take their suggestions and see if it works ...



    Hi Annafany,

    You can click on the above link, for other views & advice as well ....
  16. #16  
    I'm now having the same problem,couldn't work offline. The audio of Nokia Drive works fine, and the green arrow just wouldn't move. And what's worse is that it couldn't work offline at all. The only times I could use Nokia Drive offline is after I've start the app with data connection, and after that it would work for a couple of hours without data and the offline navigation availability is gone. )that's what I've realised.) Complained to Nokia. Really hope they take this into consideration.
  17. #17  
    People, if you guys have problems like this, PLEASE MAKE A CALL TO NOKIA. More complains from us, and they'll notice it and give some upgrade or whatever.
  18. JohnMurdoch14's Avatar
    Member

    Posts
    1 Posts
    #18  
    I have been having the exact same issue with my phone. Wi-fi on or off does not matter. I have done hard resets, reinstallations, etc. etc. etc.

    I even sent the phone in for repair and they could not "replicate" the issue.

    After countless calls I believe I will finally get the assistance that I need. I will have to send the phone out a second time, though...
  19. maz olim's Avatar
    Member

    Posts
    1 Posts
    #19  
    problem is the 4g network, switch back to 3g.
  20. #20  
    My GPS doesn't work either.

    I'm using a factory unlocked lumia 920 in the UK but still haven't had portico update, and seemingly looks like I never will ;(

    I guess we have to accept thatwe are the unfortunate lot who got 920s without functioning GPS. Sucks I know but as stated above Nokia seem incapabale of fixing it. best advice3; stay away from Nokia!

Similar Threads

  1. Replies: 14
    Last Post: 04-13-2013, 12:07 PM
  2. GPS Problem
    By jjbottone in forum Nokia Lumia 900
    Replies: 1
    Last Post: 04-17-2012, 02:35 PM
  3. Wifi problem still not fixed??
    By gabfall in forum Windows Phone 7
    Replies: 48
    Last Post: 04-15-2012, 10:05 PM
  4. Titan Problems or not?
    By TreizFaction in forum Windows Phone 7
    Replies: 2
    Last Post: 11-18-2011, 11:53 AM

Posting Permissions