Get ready for beta!

Prepare for Halo Wars 2 Blitz Mode beta: Everything you need to know!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. djncanada1's Avatar
    Member

    Posts
    47 Posts
    Global Posts
    67 Global Posts
       #1  
    Hi,

    I have an unlocked Lumia 920, was unlocked by Rogers last night.

    Last night, I installed my Telus micro SIM and got a LTE signal.

    Today, I purchased an additional micro SIM and installed in Lumia 920.

    I have moved SIM's between Samsug Galaxy SIII and Lumia 920, always get LTE on Samsung, 4G on the Lumia 920.

    I called Telus, I am connected to LTE service.

    Any suggestions?
  2. djncanada1's Avatar
    Member

    Posts
    47 Posts
    Global Posts
    67 Global Posts
       #2  
    Hi,

    Just an update. I really feel like a knob..

    When I fired up IE and looked to download something..LTE shows up.

    Could someone verify that Lumia 920 normally uses 4G mode until a data activity starts and then moves to LTE? If yes, this is brilliant!!!

    Dave
  3. EG8196's Avatar
    Member

    Posts
    74 Posts
    Global Posts
    101 Global Posts
    #3  
    Quote Originally Posted by djncanada1 View Post
    Hi,

    Just an update. I really feel like a knob..

    When I fired up IE and looked to download something..LTE shows up.

    Could someone verify that Lumia 920 normally uses 4G mode until a data activity starts and then moves to LTE? If yes, this is brilliant!!!

    Dave
    No, mine is always LTE, unless no LTE signal.
    If no LTE signal, it will be 3G until a data activity starts and then moves to 4G

Similar Threads

  1. Rogers Lumia 920 Signal issues.
    By MikeLynch001 in forum Nokia Lumia 920
    Replies: 7
    Last Post: 12-09-2012, 11:50 AM
  2. got a lumia 920! one issue
    By graigsmith in forum Windows Phone 8
    Replies: 1
    Last Post: 11-10-2012, 12:41 AM
  3. Rogers' Lumia 920
    By miki20021 in forum Nokia Lumia 920
    Replies: 4
    Last Post: 11-07-2012, 10:25 AM
  4. Replies: 15
    Last Post: 11-01-2012, 03:44 AM

Posting Permissions