Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 21 of 21
  1. kittshelby's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    130 Global Posts
       #1  
    I got a first batch Nokia 920 from Rogers; I'm pretty sure it's unlocked since it's working on Fido right now. Internet sharing is working, but I can't get MMS to work. Has anyone gotten their 920 to work on Fido?

    I'm using the $25 text&call plan by the way, so no LTE/data.
  2. o4komodo's Avatar
    Member

    Posts
    102 Posts
    #2  
    You need an MMS plan or data to send MMS.
    You should also check your APN settings.
  3. Andrew Wilson's Avatar
    Member

    Posts
    2 Posts
    #3  
    Not true, you don't need an MMS plan to send MMS. I have the exact same plan as the OP on Fido and can send MMS.

    Weirdly enough, remove all APN settings and all MMS settings (put the phone back at stock) and everything will work properly. You might need to do a factory reset afterwards, but I didn't have to.
  4. kittshelby's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    130 Global Posts
       #4  
    Quote Originally Posted by Andrew Wilson View Post
    Not true, you don't need an MMS plan to send MMS. I have the exact same plan as the OP on Fido and can send MMS.

    Weirdly enough, remove all APN settings and all MMS settings (put the phone back at stock) and everything will work properly. You might need to do a factory reset afterwards, but I didn't have to.

    But even before I added any MMS APN's, the MMS didn't work.
  5. chris2go's Avatar
    Member

    Posts
    12 Posts
    #5  
    Remove all your MMS settings, it should work.
  6. kittshelby's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    130 Global Posts
       #6  
    Quote Originally Posted by chris2go View Post
    Remove all your MMS settings, it should work.
    By remove all MMS settings, do you mean delete the MMS APN settings? Cause I already did that. Or do you mean something else? Please help, I really need MMS to work.

    Or maybe can you tell me what the defaut settings for MMS are? Thanks!
    Last edited by kittshelby; 12-11-2012 at 01:35 PM.
  7. #7  
    Because FIDO operates on the Rogers network, I've read that by leaving the MMS setting default it should work. In my case, MMS works fine using it on Virgin Mobile (which operates on the BELL network), so you shouldn't have an issue - but I had to put in custom MMS APN settings.
  8. #8  
    Quote Originally Posted by kittshelby View Post
    By remove all MMS settings, do you mean delete the MMS APN settings? Cause I already did that. Or do you mean something else? Please help, I really need MMS to work.

    Or maybe can you tell me what the defaut settings for MMS are? Thanks!
    That's what he means by default. If you manually added any setting, remove them, since it is a Rogers flashed ROM, its likely to work as is out the of the box.
    If not, then more troubleshooting. But try that first.
  9. #9  
    Quote Originally Posted by o4komodo View Post
    You need an MMS plan or data to send MMS.
    You should also check your APN settings.
    Not necessarily. It just means you will be BILLED for that MMS message, as opposed to it being a part of a plan/add-on
  10. kittshelby's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    130 Global Posts
       #10  
    Ok, I deleted the MMS APN. But it still doesn't work. I'm going to try to reset the general Messaging (SMS) settings back to default. Can someone tell me what the default settings in Messaging was? "Text message backup", "Use Facebook Chat", "SMS Delivery confirmation", "MMS delivery confirmation", "Send MMS acknowledgement", "Group Chat". Those are the settings in Messaging. Can someone tell me the defaults for these. Thanks!

    PS: I'm using the $25 text&chat plan. I have unlimited texting and MMS. But I don't have data.
  11. KillaRizzay's Avatar
    Member

    Posts
    1 Posts
    #11  
    Here's my 920's default settings (Rogers):

    Text Message Backup - On
    Chat Backup - On
    Use Facebook Chat - On
    SMS Delivery Confirmation - Off
    MMS Delivery Confirmation - Off
    Send MMS Acknowlegement - On
    Group Text - Off
  12. #12  
    Quote Originally Posted by kittshelby View Post
    Ok, I deleted the MMS APN. But it still doesn't work. I'm going to try to reset the general Messaging (SMS) settings back to default. Can someone tell me what the default settings in Messaging was? "Text message backup", "Use Facebook Chat", "SMS Delivery confirmation", "MMS delivery confirmation", "Send MMS acknowledgement", "Group Chat". Those are the settings in Messaging. Can someone tell me the defaults for these. Thanks!

    PS: I'm using the $25 text&chat plan. I have unlimited texting and MMS. But I don't have data.
    Quick call to FIDO to see if MMS messages are not allowed/disabled when using that plan? Probably not, but no sense trying to figure out something if the carrier is blocking it.
  13. o4komodo's Avatar
    Member

    Posts
    102 Posts
    #13  
    Right, I forgot about the 50 cent charge from Fido with a non mms-ad-on.
    Sorry about that!

    You need to enter the correct apn settings for MMS as well as potentially the data/wireless apn.
    It's usually...
    internet.fido.ca
    and
    mms.fido.ca

    user name is often...
    fido

    password is often...
    fido

    edit: on my old unlocked-international-Nokia-N8 I was unable to send MMS when connected with the rogers APN.
    There were rare occasions where it send, but on the Edge network as opposed to 3G or "3.5G" as the phone displayed.

    Currently my settings on my temporary Galaxy Ace are (and these are the same settings on ALL my phones, been with Fido for 8-9 years):
    Name:
    Fido Internet
    APN:
    internet.fido.ca
    Proxy:
    Not set
    Port:
    Not set
    User name:
    Not set
    Password:
    Not set
    Server:
    Not set
    MMSC:
    http://mms.fido.ca
    MMS proxy:
    205.151.11.13
    MMS port:
    80
    MCC:
    302
    Authentication type:
    Not set
    APN type:
    Internet + mms

    Granted this is on an Android device. I've only ever used Symbian (and this is my first Android).
  14. o4komodo's Avatar
    Member

    Posts
    102 Posts
    #14  
    I'll be receiving my international-unlocked-L920 on Wednesday or Thursday. I'll post an update once the phone comes, if you're still having issues.
  15. kittshelby's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    130 Global Posts
       #15  
    Quote Originally Posted by o4komodo View Post
    I'll be receiving my international-unlocked-L920 on Wednesday or Thursday. I'll post an update once the phone comes, if you're still having issues.
    Yes I would much appreciate it. Thanks. I will be heading down to a Fido store tomorrow to see if they can help me solve this problem. I'll post an update if I get it to work.
  16. o4komodo's Avatar
    Member

    Posts
    102 Posts
    #16  
    Quote Originally Posted by kittshelby View Post
    Yes I would much appreciate it. Thanks. I will be heading down to a Fido store tomorrow to see if they can help me solve this problem. I'll post an update if I get it to work.
    Did you get your issue solved? I should get my phone tomorrow. It's arrived in Windsor but hasn't stated it departed yet [since 1pm]
  17. kittshelby's Avatar
    Member

    Posts
    129 Posts
    Global Posts
    130 Global Posts
       #17  
    Quote Originally Posted by o4komodo View Post
    Did you get your issue solved? I should get my phone tomorrow. It's arrived in Windsor but hasn't stated it departed yet [since 1pm]
    I'm really busy this week so haven't gone to Fido yet. I'll go sometime next week and update you then. Please let me know if MMS works for your 920 when you get it and how. Thanks
  18. o4komodo's Avatar
    Member

    Posts
    102 Posts
    #18  
    Buddy didn't let the UPS guy in... so I missed the delivery.
    Going to try again tomorrow--I work 1-9:30 so hopefully one of my roommates will get it for me this time. Bastards. Made me wait 9 hours for nothing.
  19. o4komodo's Avatar
    Member

    Posts
    102 Posts
    #19  
    Got my L920 today. So far the highest network I've been able to hit is HSDPA. Most of the time I'm on 3G. Have yet to see LTE.
    Upon inserting my sim, there were two options I've noticed in the apn settings.
    Fido 3G and Fido LTE.
    Here is where you can add and edit APNs. I tried, and you cannot edit existing APNs.

    I tried adding my own APN+MMS settings... but cannot send MMS. Using either the provided Fido 3G or Fido LTE is fine though.
  20. dislal's Avatar
    Member

    Posts
    1 Posts
    #20  
    those settings are working for me:

    device: rogers lumia 920

    APN: Fido-core-appl1.apn
    Username: Blank
    Password: Blank
    Wap Gateway: 205.151.11.13
    Wap gateway port: 80
    MMSC (url): http://mms.fido.ca
    MMSC port: 80
    Max mms size: blank
    IP type: ip4v6


    Enjoy!
    Thanked by:
    aafa 
  21. lord_yoda's Avatar
    Member

    Posts
    1 Posts
    #21  
    Just an update

    Came across this thread and found that none of the settings provided here worked.

    Here's what worked for my: Factory unlocked Lumia 820

    APN: LTEMOBILE.APN
    Username:
    Password:
    Wap Gateway: 205.151.11.13
    MMSC (url): http://mms.fido.ca
    MMSC port: 80
    IP type: ip4
    Authentication type : none

    For LTE settings, just use the APN and leave everything else blank.

Similar Threads

  1. Cannot get "Quick Share Account" to work with Facebook
    By crayneogeo in forum Nokia Lumia 920
    Replies: 3
    Last Post: 12-04-2012, 08:36 AM
  2. How do I get XBOX Live to work with my GMail Account
    By KronicOD in forum Windows Phone 7
    Replies: 4
    Last Post: 12-01-2012, 11:40 AM
  3. How do I get Internet Sharing and MMS to work?
    By Richhy in forum Nokia Lumia 920
    Replies: 3
    Last Post: 11-20-2012, 12:13 PM
  4. attaching video to MMS not working with latest update
    By v10type-r in forum Windows Phone 7
    Replies: 0
    Last Post: 07-26-2012, 10:52 AM
  5. Getting the Titan MMS to work
    By RyanGross in forum HTC TITAN
    Replies: 8
    Last Post: 12-24-2011, 04:43 PM

Posting Permissions