Get ready for beta!

Prepare for Halo Wars 2 Blitz Mode beta: Everything you need to know!

One Windows

Microsoft is building a new Windows 10 Shell for PC, Mobile and Xbox

On the Inside

Everything you need to know about the Xbox Insider Program

Beautiful compromises

Surface Studio review: you'll want one, even if you don't need one

3-in-1

Is this the Surface Phone? Microsoft awarded patents for foldable devices

Windows Central Offers

MCSE Certification bundle is just $39

Even more improvements

All the changes found in Windows 10 build 15007!

Games as a Service

What does the cancellation of Scalebound mean for future Xbox exclusives?

Windows Central Offers

Save $90 on these FRESHeBUDS Pro Magnetic Bluetooth Earbuds

Returning for 2017

We're back with an new episode of #AskDanWindows

Lifetime Subscription

VPNSecure is currently 91% off

Our favorite things

The Best of CES 2017 Awards

Infinity Edge in your hand

The XPS 13 2-in-1 is the Dell convertible we've always wanted

Project Valerie

Razer just made a laptop with three — THREE! — 17-inch 4K displays. 😱

Great design from Palo Alto

HP's CES 2017 releases are truly gorgeous PCs

Intel and Google's big day

CES 2017 Day Two: New laptops, new phones, and old ideas made new

Take five is better than ever

The updated Lenovo ThinkPad X1 packs Kaby Lake chips and zero bloatware

Everything we know about the next Xbox: Project Scorpio

UWPowered

'Game Mode' for Windows 10 will power Xbox One and Scorpio games too

Buyer's guide

Best accessories for Microsoft Surface Book

< >
Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. xenoglyph's Avatar
    Member

    Posts
    17 Posts
       #1  
    The first real problem I've had with my phone is the extra battery drain since Portico. Where I live I have a pretty weak LTE signal that cuts in and out.

    Went into field test menu and set the phone to 3G only. Overnight battery drain seems to be back to normal. I'll wait a couple days for a final verdict, but it's looking like a possible radio bug to me.

    Maybe later on I'll see if polling frequency has an effect.
  2. newfiend's Avatar
    Member

    Posts
    58 Posts
    #2  
    Contact Nokia with your findings.. It may help them determine the cause of the problem and issue a fix if need be.
  3. joeynox's Avatar
    Member

    Posts
    578 Posts
    Global Posts
    616 Global Posts
    #3  
    i cant switch lte off. ive tried many times and it just turns back on.
  4. xenoglyph's Avatar
    Member

    Posts
    17 Posts
       #4  
    I can confirm that so far battery drain is much much better. LTE has remained disabled for me, I think you need to disable ENS. Note that '3G' only will show you as connected to 4G network in the status dropdown.

Similar Threads

  1. On vacation: odd issues with data
    By bigdjunk in forum Nokia Lumia 822
    Replies: 2
    Last Post: 12-07-2012, 10:09 AM
  2. Titan II battery drain issues.
    By karelj in forum HTC TITAN II
    Replies: 10
    Last Post: 06-06-2012, 05:02 PM
  3. My battery on my HTC Arrive with Mango. Explain this.
    By Jazmac in forum HTC Arrive / 7 Pro
    Replies: 4
    Last Post: 08-01-2011, 01:46 PM
  4. Issues with facebook photo sync on Focus.
    By DG788 in forum Samsung Focus
    Replies: 2
    Last Post: 01-11-2011, 12:45 PM

Posting Permissions